Bug 618707 - And warning text to doc about relying on UI w/o core understanding of clustering
Summary: And warning text to doc about relying on UI w/o core understanding of clustering
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Cluster_Administration (Show other bugs)
(Show other bugs)
Version: 6.0
Hardware: All Linux
low
medium
Target Milestone: rc
: ---
Assignee: Steven J. Levine
QA Contact: ecs-bugs
URL:
Whiteboard:
Keywords: Documentation
Depends On:
Blocks: 671285
TreeView+ depends on / blocked
 
Reported: 2010-07-27 14:59 UTC by Perry Myers
Modified: 2011-05-24 18:21 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 671285 (view as bug list)
Environment:
Last Closed: 2011-05-24 18:21:37 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Perry Myers 2010-07-27 14:59:59 UTC
Description of problem:
Add smth like this to the docs:

"But be warned; although this is a graphical user interface to your cluster, you still need to have a good and clear understanding of the concepts of such clusters. Learning by exploring the available features in the user interface may not result in a cluster that actually keeps your service running when disaster strikes."

Note, this quote was taken from Linbit's GUI at:
http://www.drbd.org/mc/management-console/

Comment 4 Steven J. Levine 2011-01-20 20:20:33 UTC
Perry:

I'll add something along these lines for 6.1, since that's pretty straightforward, but I don't know what to do about Paul's suggestion that something along these lines be incorporated into the GUI itself -- it certainly would be more effective there (in general people only look at GUI documentation if they have problems I suspect), but I don't know where or when such a statement might appear. That seems a GUI design/interface question rather than a documentation question.

It does seem a given to me, but how about this as the note in the Conga doc:

"Conga is a graphical user interface that you can use to administer the Red Hat High Availability Add-On. Note, however, that in order to use this interface effectively you need to have a good and clear understanding of the underlying concepts. Learning about cluster configuration by exploring the available features in the user interface is not recommended, as it may result in a system that is not robust enough to keep all services running when components fail."

Comment 5 Perry Myers 2011-01-21 00:04:46 UTC
(In reply to comment #4)
> Perry:
> 
> I'll add something along these lines for 6.1, since that's pretty
> straightforward, but I don't know what to do about Paul's suggestion that
> something along these lines be incorporated into the GUI itself -- it certainly
> would be more effective there (in general people only look at GUI documentation
> if they have problems I suspect), but I don't know where or when such a
> statement might appear. That seems a GUI design/interface question rather than
> a documentation question.

ack, I'll clone this for Luci component as that is a good idea.
 
> It does seem a given to me, but how about this as the note in the Conga doc:
> 
> "Conga is a graphical user interface that you can use to administer the Red Hat
> High Availability Add-On. Note, however, that in order to use this interface
> effectively you need to have a good and clear understanding of the underlying
> concepts. Learning about cluster configuration by exploring the available
> features in the user interface is not recommended, as it may result in a system
> that is not robust enough to keep all services running when components fail."

I'd say Luci instead of Conga perhaps?  Otherwise that warning looks fine to me.

Comment 6 Steven J. Levine 2011-01-21 15:14:20 UTC
Perry: 

Thanks for the quick turnaround. This note would go right at the beginning of an existing chapter in the Cluster Admin Guide which is titled "Configuring Red Hat High Availability Add-On With Conga" (and then uses Conga to refer to the whole system). That title (and specific usage) predates my involvement in the chapter, so I'm only thinking about that now that you've brought it up -- but I think that using "Conga" in this case refers to the whole package, both the luci and ricci components -- even though I get your point that the graphical configuration interface itself is the luci component. But in general it seems consistent to me to leave that as Conga here.

I think the luci distinction is important for things like developement and installation, but in talking about using the interface in a general way, from the admin's perspective, using Conga here makes sense to me.

-Steven

Comment 7 Perry Myers 2011-01-21 15:29:16 UTC
(In reply to comment #6)
Sounds resonable, ack

Comment 8 Steven J. Levine 2011-01-21 15:32:39 UTC
I have added this note to the 6.1 working draft of the Cluster Administration Guide and I have checked the updated files into the svn repository so I am moving this bug to MODIFIED.

Comment 10 Andrew Ross 2011-05-11 03:31:25 UTC
Red_Hat_Enterprise_Linux-Cluster_Administration-6-web-en-US-0-75.el5

Verified the note is added as per comment#4. 

One minor point, the last sentence is missing a full stop:

"Learning about cluster configuration by exploring the available features in the user interface is not recommended, as it may result in a system that is not robust enough to keep all services running when components fail "

Comment 11 Steven J. Levine 2011-05-11 15:09:18 UTC
I have added the full stop to the sentence in my working copy. I will move this to ON_QA when I rebuild the document.

Comment 13 Andrew Ross 2011-05-11 23:20:04 UTC
Verified: Red_Hat_Enterprise_Linux-Cluster_Administration-6-web-en-US-0-76.el5

Comment 14 Steven J. Levine 2011-05-24 18:21:37 UTC
With the release of RHEL 6.1, I'm closing this bug.


Note You need to log in before you can comment on or make changes to this bug.