Bug 671285 - And warning text to Luci UI about relying on UI w/o core understanding of clustering
Summary: And warning text to Luci UI about relying on UI w/o core understanding of clu...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: luci
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ryan McCabe
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On: 618707
Blocks: 522005 693781
TreeView+ depends on / blocked
 
Reported: 2011-01-21 00:05 UTC by Perry Myers
Modified: 2011-12-06 10:07 UTC (History)
8 users (show)

Fixed In Version: luci-0.23.0-20.el6
Doc Type: Bug Fix
Doc Text:
Clone Of: 618707
Environment:
Last Closed: 2011-12-06 10:07:03 UTC
Target Upstream Version:


Attachments (Terms of Use)
Captured warning message. (6.38 KB, image/png)
2011-08-25 16:23 UTC, Jan Pokorný [poki]
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1510 normal SHIPPED_LIVE luci bug fix update 2011-12-06 00:39:20 UTC

Description Perry Myers 2011-01-21 00:05:41 UTC
+++ This bug was initially created as a clone of Bug #618707 +++

Description of problem:
Add smth like this to the docs:

"But be warned; although this is a graphical user interface to your cluster, you still need to have a good and clear understanding of the concepts of such clusters. Learning by exploring the available features in the user interface may not result in a cluster that actually keeps your service running when disaster strikes."

Note, this quote was taken from Linbit's GUI at:
http://www.drbd.org/mc/management-console/

--- Additional comment from slevine@redhat.com on 2011-01-20 15:20:33 EST ---

Perry:

I'll add something along these lines for 6.1, since that's pretty straightforward, but I don't know what to do about Paul's suggestion that something along these lines be incorporated into the GUI itself -- it certainly would be more effective there (in general people only look at GUI documentation if they have problems I suspect), but I don't know where or when such a statement might appear. That seems a GUI design/interface question rather than a documentation question.

It does seem a given to me, but how about this as the note in the Conga doc:

"Conga is a graphical user interface that you can use to administer the Red Hat High Availability Add-On. Note, however, that in order to use this interface effectively you need to have a good and clear understanding of the underlying concepts. Learning about cluster configuration by exploring the available features in the user interface is not recommended, as it may result in a system that is not robust enough to keep all services running when components fail."

--- Additional comment from pmyers@redhat.com on 2011-01-20 19:04:46 EST ---

(In reply to comment #4)
> Perry:
> 
> I'll add something along these lines for 6.1, since that's pretty
> straightforward, but I don't know what to do about Paul's suggestion that
> something along these lines be incorporated into the GUI itself -- it certainly
> would be more effective there (in general people only look at GUI documentation
> if they have problems I suspect), but I don't know where or when such a
> statement might appear. That seems a GUI design/interface question rather than
> a documentation question.

ack, I'll clone this for Luci component as that is a good idea.
 
> It does seem a given to me, but how about this as the note in the Conga doc:
> 
> "Conga is a graphical user interface that you can use to administer the Red Hat
> High Availability Add-On. Note, however, that in order to use this interface
> effectively you need to have a good and clear understanding of the underlying
> concepts. Learning about cluster configuration by exploring the available
> features in the user interface is not recommended, as it may result in a system
> that is not robust enough to keep all services running when components fail."

I'd say Luci instead of Conga perhaps?  Otherwise that warning looks fine to me.

Comment 7 Jan Pokorný [poki] 2011-08-25 16:23:41 UTC
Created attachment 519921 [details]
Captured warning message.

Trying freshly-installed luci-0.23.0-20.el6 (after uninstalling
luci-0.23.0-13.el6), I was provided with a warning as captured in
the attached image upon logging in.

After logging out and repeating this as the same user, the warning has
not appeared anymore, even when doing a restart of luci in between.

When logging in as another user, the same applied (i.e., show warning
for the first time being in and never repeat it again).

I found out that this warning box is not prone to accidentaly pressing
ESC key that would close the box and thus the message was missed.
(This is contrary to dialog boxes, but it's IMHO okay with them.)

Comment 8 Jan Pokorný [poki] 2011-08-26 16:27:27 UTC
There is a regression in behavior brought along this bug, introduced by later
fix of another bug, see https://bugzilla.redhat.com/show_bug.cgi?id=522005#c19.

Comment 10 errata-xmlrpc 2011-12-06 10:07:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1510.html


Note You need to log in before you can comment on or make changes to this bug.