Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 619095 - [abrt] crash in system-config-printer-1.2.3-3.fc13: system-config-printer.py:3675:checkNPName:AttributeError: GUI instance has no attribute 'printers'
[abrt] crash in system-config-printer-1.2.3-3.fc13: system-config-printer.py:...
Status: CLOSED DUPLICATE of bug 589793
Product: Fedora
Classification: Fedora
Component: system-config-printer (Show other bugs)
13
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
abrt_hash:6ad655e2
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-28 10:49 EDT by pierpaolo.franco
Modified: 2010-07-29 06:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-29 06:25:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (893 bytes, text/plain)
2010-07-28 10:49 EDT, pierpaolo.franco
no flags Details

  None (edit)
Description pierpaolo.franco 2010-07-28 10:49:26 EDT
abrt 1.1.1 detected a crash.

architecture: i686
cmdline: python /usr/share/system-config-printer/system-config-printer.py
component: system-config-printer
executable: /usr/share/system-config-printer/system-config-printer.py
kernel: 2.6.33.6-147.fc13.i686
package: system-config-printer-1.2.3-3.fc13
reason: system-config-printer.py:3675:checkNPName:AttributeError: GUI instance has no attribute 'printers'
release: Fedora release 13 (Goddard)

backtrace
-----
system-config-printer.py:3675:checkNPName:AttributeError: GUI instance has no attribute 'printers'

Traceback (most recent call last):
  File "/usr/share/system-config-printer/system-config-printer.py", line 6441, in on_tvNPModels_cursor_changed
    self.on_tvNPDrivers_cursor_changed(self.tvNPDrivers)
  File "/usr/share/system-config-printer/system-config-printer.py", line 6444, in on_tvNPDrivers_cursor_changed
    self.setNPButtons()
  File "/usr/share/system-config-printer/system-config-printer.py", line 4732, in setNPButtons
    self.mainapp.checkNPName(self.entNPName.get_text()))
  File "/usr/share/system-config-printer/system-config-printer.py", line 3675, in checkNPName
    for printer in self.printers.values():
AttributeError: GUI instance has no attribute 'printers'

Local variables in innermost frame:
self: <__main__.GUI instance at 0x9b78bcc>
name: u'dell-laser-mfp1815'
Comment 1 pierpaolo.franco 2010-07-28 10:49:29 EDT
Created attachment 435038 [details]
File: backtrace
Comment 2 Jiri Popelka 2010-07-29 06:25:23 EDT
Same problem as in bug #618815,
i.e. missing attribute (GUI.printers this time).

GUI.printers gets initialized (self.printers = {}) in __init__()
and is only deleted on Quit.

*** This bug has been marked as a duplicate of bug 618815 ***
Comment 3 Jiri Popelka 2010-07-29 06:31:26 EDT
Actually it's duplicate of much older bug.

*** This bug has been marked as a duplicate of bug 589793 ***

Note You need to log in before you can comment on or make changes to this bug.