Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 619156 - gcc-java fails to compile to native image on Rawhide
gcc-java fails to compile to native image on Rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gcc (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Fedora Extras Quality Assurance
:
: 621321 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-28 13:36 EDT by W. Michael Petullo
Modified: 2010-08-21 09:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: gcc-4.5.1-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 21:04:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2010-07-28 13:36:41 EDT
Description of problem:
Using Fedora 12, "gcj --main=Test Test.java" produces a native a.out. When using Rawhide, the linking process fails.

Version-Release number of selected component (if applicable):
gcc-java-4.5.0-3.fc14.x86_64

How reproducible:
Every time

Steps to Reproduce:
Compile the following code with "gcc-java-4.5.0-3.fc14.x86_64:"

public class Test {
        public static void main(String args[]) {
                System.out.println ("Hello world!");
        }
}
  
Actual results:
$ gcj --main=Test Test.java 
/usr/bin/ld: cannot find -lgcj
collect2: ld returned 1 exit status

Expected results:
gcj should compile and link Test.java into a.out.

Additional info:
I created the Rawhide environment using mock. The following files are installed:

/usr/lib/gcc/x86_64-redhat-linux/4.5.0/libgcj.so
/usr/lib64/libgcj.so.11
/usr/lib64/libgcj.so.11.0.0
Comment 1 Jakub Jelinek 2010-08-11 09:48:14 EDT
Oh, I see, the spec file hasn't been adjusted for the lib{gcj,gij,gcj-tools}.so.10 to so.11 transition.  Will be fixed in gcc-4.5.0-5.
Comment 2 Jakub Jelinek 2010-08-11 09:48:33 EDT
*** Bug 621321 has been marked as a duplicate of this bug. ***
Comment 3 Fedora Update System 2010-08-13 02:48:55 EDT
gcc-4.5.1-1.fc14,libtool-2.2.10-3.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/gcc-4.5.1-1.fc14,libtool-2.2.10-3.fc14
Comment 4 Jochen Schmitt 2010-08-16 13:11:01 EDT
Why did you not built this release for rawhide=
Comment 5 Fedora Update System 2010-08-18 21:04:26 EDT
gcc-4.5.1-1.fc14, libtool-2.2.10-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 6 W. Michael Petullo 2010-08-21 09:39:47 EDT
Confirmed fixed with gcc-java-4.5.1-1.fc14.x86_64 and its dependencies.

Note You need to log in before you can comment on or make changes to this bug.