Bug 619162 - Repo reports having packages even thou never synced
Summary: Repo reports having packages even thou never synced
Status: CLOSED DUPLICATE of bug 621246
Alias: None
Product: Pulp
Classification: Retired
Component: z_other   
(Show other bugs)
Version: unspecified
Hardware: All Linux
low
medium
Target Milestone: ---
: ---
Assignee: Mike McCune
QA Contact: wes hayutin
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-07-28 18:11 UTC by Mike McCune
Modified: 2013-01-10 10:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 14:43:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Mike McCune 2010-07-28 18:11:46 UTC
* No repo schedule defined, no feed defined yet the repo has packages:

+-------------------------------------------+
    List of Available Repositories 
+-------------------------------------------+

Label              	my-repo                  
Name               	my repo's name           
Feed               	None                     
Arch               	i686                     
Sync Schedule      	None                     
Packages           	31                       

DB reports no packages either:

use _database / db.repos.find()[0]:

 "packages" : {}

need to figure out why this is.

Comment 1 John Matthews 2010-07-28 18:25:17 UTC
This is due to the change to using 'deferred fields'.  The CLI is simply doing a len on 'packages', which is a string of a URL.

Fix we discussed a bit back would be to change the API and fetch the number of packages in a repo and return that, then update the CLI so it displays that package_count.

Comment 2 Pradeep Kilambi 2010-08-17 14:43:00 UTC

*** This bug has been marked as a duplicate of bug 621246 ***


Note You need to log in before you can comment on or make changes to this bug.