Bug 621246 - Wrong package count shown in repo list
Wrong package count shown in repo list
Status: CLOSED CURRENTRELEASE
Product: Pulp
Classification: Community
Component: z_other (Show other bugs)
unspecified
All Linux
high Severity high
: ---
: ---
Assigned To: Jason Connor
Preethi Thomas
:
: 619162 (view as bug list)
Depends On:
Blocks: verified-to-close
  Show dependency treegraph
 
Reported: 2010-08-04 11:14 EDT by Preethi Thomas
Modified: 2011-08-16 10:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-16 10:02:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2010-08-04 11:14:35 EDT
Description of problem:


1. Create a rhn repo rhel-x86_64-client-vt-5 

2. Repo sync 

[root@preethi pulp]# pulp -u admin -p admin repo sync --id=rhel-x86_64-client-vt-5
Sync Status:: running
Sync Status:: running
Sync Status:: finished
 Sync Successful. Repo [ rhel-x86_64-client-vt-5 ] now has a total of [ 86 ] packages
[root@preethi pulp]# pulp -u admin -p admin repo list

see the message  Repo [ rhel-x86_64-client-vt-5 ] now has a total of [ 86 ] packages

3. 

[root@preethi pulp]# pulp -u admin -p admin repo list
+-------------------------------------------+
    List of Available Repositories 
+-------------------------------------------+

Label                   rhel-x86_64-client-vt-5  
Name                    rhel-x86_64-client-vt-5  
Feed                    {u'url': u'satellite.rhn.redhat.com/rhel-x86_64-client-vt-5', u'type': u'rhn', u'supported_types': [u'yum', u'local', u'rhn']}
Arch                    x86_64                   
Sync Schedule           None                     
Packages                47
Comment 2 Pradeep Kilambi 2010-08-17 10:43:00 EDT
*** Bug 619162 has been marked as a duplicate of this bug. ***
Comment 3 Jason Connor 2010-09-14 11:37:12 EDT
I've added a new package count field, so the output now looks like:
sudo pulp-admin -u admin -p admin repo list
+-------------------------------------------+
    List of Available Repositories 
+-------------------------------------------+

Label              	my-rawhide               
Name               	My Fedora Rawhide Repo   
Feed               	{u'url': u'ftp://mirror.cs.princeton.edu/pub/mirrors/fedora/linux/development/x86_64/os/', u'type': u'yum', u'supported_types': [u'yum', u'local', u'rhn']}
Arch               	x86_64                   
Sync Schedule      	None                     
Package Count      	0                        
Packages           	/pulp/api/repositories/my-rawhide/packages/

Should I replace the packages field? or just leave it?
Comment 4 Jason Connor 2010-09-14 12:07:45 EDT
Got rid of the Package Count field and just replaced Packages with the count:
sudo pulp-admin -u admin -p admin repo list
+-------------------------------------------+
    List of Available Repositories 
+-------------------------------------------+

Label              	my-rawhide               
Name               	My Fedora Rawhide Repo   
Feed               	{u'url': u'ftp://mirror.cs.princeton.edu/pub/mirrors/fedora/linux/development/x86_64/os/', u'type': u'yum', u'supported_types': [u'yum', u'local', u'rhn']}
Arch               	x86_64                   
Sync Schedule      	None                     
Packages           	0
Comment 5 Preethi Thomas 2010-09-21 11:18:14 EDT
verified
[root@preethi ~]# rpm -qa  |grep pulp
pulp-client-0.0.65-1.fc13.noarch
pulp-common-0.0.65-1.fc13.noarch
pulp-0.0.65-1.fc13.noarch


[root@preethi ~]# pulp-admin -u admin -p admin repo sync --id=f12_x86_64
Task created with ID:: 0732f49e-c594-11df-ac2d-002564a85a58
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: running
Sync Status:: finished
 Sync Successful. Repo [ f12_x86_64 ] now has a total of [ 2998 ] packages
[root@preethi ~]# pulp-admin -u admin -p admin repo list
+-------------------------------------------+
    List of Available Repositories 
+-------------------------------------------+



Label                   f13                      
Name                    f13                      
Feed                    {u'url': u'http://download.devel.redhat.com/released/F-13/GOLD/Fedora/x86_64/os/', u'type': u'yum', u'supported_types': [u'yum', u'local', u'rhn']}
Arch                    x86_64                   
Sync Schedule           None                     
Packages                3102                     
Files                   8                        


Label                   f12_x86_64               
Name                    f12                      
Feed                    {u'url': u'http://download.devel.redhat.com/released/F-12/GOLD/Fedora/x86_64/os/', u'type': u'yum', u'supported_types': [u'yum', u'local', u'rhn']}
Arch                    x86_64                   
Sync Schedule           None                     
Packages                2998                     
Files                   8
Comment 6 Preethi Thomas 2011-08-16 10:02:48 EDT
Closing with Community Release 15

pulp-0.0.223-4.

Note You need to log in before you can comment on or make changes to this bug.