Bug 619309 - problems with Thai input (preedit)?
problems with Thai input (preedit)?
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus-m17n (Show other bugs)
13
All Linux
low Severity low
: ---
: ---
Assigned To: Daiki Ueno
Fedora Extras Quality Assurance
: FutureFeature, MoveUpstream, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-29 04:55 EDT by Jens Petersen
Modified: 2011-05-19 17:37 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 530850
Environment:
Last Closed: 2011-05-19 01:27:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2010-07-29 04:55:03 EDT
+++ This bug was initially created as a clone of Bug #530850 +++

--- Additional comment from manatsawin@gmail.com on 2009-11-20 18:21:45 EST ---
[..]

I tried IBus, it can use grave as one of the toggle key but the way IBus enter Thai character isn't what Thais use. (In IBus I have to type next character before it write the last character into the input box. Other OS use XIM-like method: type everything into the input box)

--- Additional comment from petersen@redhat.com on 2010-01-20 15:55:22 EST ---
[..]
> I tried IBus, it can use grave as one of the toggle key but the way IBus enter
> Thai character isn't what Thais use. (In IBus I have to type next character
> before it write the last character into the input box. Other OS use XIM-like
> method: type everything into the input box)    

Can you please tell us exactly what you tested so we can improve it.

--- Additional comment from manatsawin@gmail.com on 2010-01-20 18:41:57 EST ---

"Traditional" Thai input is to input like English: everything into the input box.
IBus Thai Input use a small box to type in base character + vowels before put it into the input box.

Like when you type ที่วันนี้ the IBus input box will show "ที่" "วั" "น" "นี้" while traditional way is type the entire string as-is into the box.

--- Additional comment from manatsawin@gmail.com on 2010-01-21 18:38:29 EST ---
[..] method (which we preferred) is th-kesmanee. [..]



It would be good if you could test latest ibus-m17n since this
might already be fixed.
Comment 1 Daiki Ueno 2010-07-30 01:05:01 EDT
Manatsawin,

> It would be good if you could test latest ibus-m17n since this
> might already be fixed.

Or perhaps you may want to try my experimental package:
https://bugzilla.redhat.com/show_bug.cgi?id=615158#c2
which does not add color to the pre-edit buffer for Thai language.
Comment 2 Fedora Admin XMLRPC Client 2010-08-02 02:20:53 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 3 Daiki Ueno 2011-05-19 01:27:08 EDT
I assume that the requested feature here is to not decorate preedit buffer for Thai input, and it is already implemented in the latest ibus-m17n package.

Closing this for now.  If it is not the case, please reopen.
Comment 4 Manatsawin Hanmongkolchai 2011-05-19 05:57:50 EDT
Sorry for no reply so far, 

I have checked this in Fedora 15 Alpha and Thai SCIM input is fully working as expected. The bug can be closed now.
Comment 5 Jens Petersen 2011-05-19 17:37:28 EDT
(In reply to comment #4)
> I have checked this in Fedora 15 Alpha and Thai SCIM input is fully working as
> expected. The bug can be closed now.

Well this bug is for ibus not scim. :)  Also currently it is against F13.

Note You need to log in before you can comment on or make changes to this bug.