This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 61940 - /usr/X11R6/lib/X11/fonts/*/encodings.dir not created
/usr/X11R6/lib/X11/fonts/*/encodings.dir not created
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-03-25 21:34 EST by Blair Zajac
Modified: 2007-04-18 12:41 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 14:58:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Blair Zajac 2002-03-25 21:34:05 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
I run two RedHat Linux boxes that I updated pretty consistently to
RawHide packages.

Today I brought most of the packages up to date with skipjack, hence
did an upgrade from XFree86 4.1 to 4.2.0-6.47.

When I install 4.2.0-6.47 and then do rpm -V 4.2.0-6.47, I get this:

rpm -V XFree86-base-fonts-4.2.0-6.47
missing    /usr/X11R6/lib/X11/fonts/100dpi/encodings.dir
.M...... g /usr/X11R6/lib/X11/fonts/100dpi/fonts.dir
missing    /usr/X11R6/lib/X11/fonts/75dpi/encodings.dir
.M...... g /usr/X11R6/lib/X11/fonts/75dpi/fonts.dir
.M.....T   /usr/X11R6/lib/X11/fonts/CID/fonts.dir
missing    /usr/X11R6/lib/X11/fonts/Speedo/encodings.dir
.M.....T   /usr/X11R6/lib/X11/fonts/Speedo/fonts.dir
.M...... g /usr/X11R6/lib/X11/fonts/Type1/fonts.dir
missing    /usr/X11R6/lib/X11/fonts/Type1/fonts.scale
missing    /usr/X11R6/lib/X11/fonts/misc/encodings.dir
SM5....T   /usr/X11R6/lib/X11/fonts/misc/fonts.dir

The encodings.dir files are not being created.

Even removing and reinstalling the packages does not fix this.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Take a box running skipjack.
2. rpm -ev XFree86-base-fonts-4.2.0-6.47
3. rpm -Uvh XFree86-base-fonts-4.2.0-6.47


Actual Results:  The /usr/X11R6/lib/X11/fonts/*/encodings.dir files are missing.

Expected Results:  The /usr/X11R6/lib/X11/fonts/*/encodings.dir should be there.

Additional info:
Comment 1 Bill Nottingham 2002-03-26 14:58:39 EST
Mike, are these supposed to be created by the xfs init script?
Comment 2 Mike A. Harris 2002-03-28 08:45:35 EST
Added missing file flags to quell the above errors in build 4.2.0-6.51 by
flagging with appropriate %ghost, and %verify voodoo magic.

encodings.dir files are completely unnecessary in current XFree86.  It
only supports them still for legacy.  It is not a bug that these files
are no longer being created.  Intentional change.  For now, if the
files are present however, they will be used.
Comment 3 Bill Crawford 2002-03-30 21:46:03 EST
I'm still seeing these files marked as missing with rpm -V on release 6.51 ...

More worrying is the absence of "fonts.alias" from the base-fonts subpackage; as
a result the "large" setting for xterm is picking up a cyrillic font instead of
the expected Latin1 font.  Should I file this seperately or am I overlooking
something?
Comment 4 Mike A. Harris 2002-03-31 07:59:59 EST
Yep, they can legally be missing so that isn't a problem.  Basically, the
way it works is - _if_ the files exist, then they are owned by rpm packaging,
however there isn't any reason for them to exist.  But, a user for
whatever reason could still create them, or could have them left over from
previous releases.

The fonts.alias file that was missing is fixed in 6.52, let me know if it is
ok now.

Thanks also for the update!
Comment 5 Bill Crawford 2002-03-31 16:59:28 EST
I think it's an rpm bug that ghosted files are still reported as "missing" when
they're not really supposed to be there ... and that apparently you can't mark
them as "ghost" and "config" at the same time.  Still, there are more important
things (like getting PCMCIA and NTP to play together :o)
Comment 6 Mike A. Harris 2002-03-31 23:41:04 EST
Could be an rpm bug perhaps.  The files are config files, because they
can change, and can be hand edited even (some of them) such as fonts.alias,
encodings.dir (even though it should not be edited people have..).  They
are ghosts because they do not have to actually exist for things to work
properly.  Not sure what if anything can/should be done now.  I think
the problem is solved now personally.  If I'm wrong, I'm sure I'll get
clue-by-4'd.  ;o)

This bug is also related to bug #61869 since fixing this broke fonts.alias.
I thought I'd flag that here to minimize bug dupes.
Comment 7 Bill Crawford 2002-04-09 21:46:14 EDT
Mike, a fresh install of beta2 is still missing fonts/{75,100}dpi/fonts.alias, I
can't reopen this one as I'm not the reporter.

Note You need to log in before you can comment on or make changes to this bug.