Bug 61869 - X server crash while searching for fixed font
X server crash while searching for fixed font
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
: 62392 62430 62472 62476 (view as bug list)
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-25 08:00 EST by LENHOF
Modified: 2008-08-01 12:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-02 17:21:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XFree log (24.49 KB, text/plain)
2002-03-25 08:02 EST, LENHOF
no flags Details
lspci -v (1.89 KB, text/plain)
2002-03-25 08:04 EST, LENHOF
no flags Details

  None (edit)
Description LENHOF 2002-03-25 08:00:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en] (X11; U; SunOS 5.8 sun4u)

Description of problem:
- Make an Everything install (The installation was done in graphical mode)
- Try to start X


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
Start the system (in level 5)
	

Actual Results:  - X doesn't start


Expected Results:  - X start

Additional info:

See files attached
Comment 1 LENHOF 2002-03-25 08:02:01 EST
Created attachment 50144 [details]
XFree log
Comment 2 LENHOF 2002-03-25 08:04:35 EST
Created attachment 50145 [details]
lspci -v
Comment 3 Mike A. Harris 2002-03-28 08:53:31 EST
Please attach your XF86Config-4 config file.  Also, please attach
the output of:  "rpm -qa | sort"
Comment 4 Mike A. Harris 2002-03-28 08:55:03 EST
Is xfs running?

Also, is this a clean install of skipjack, or is it an upgrade from
a previous release of Red Hat Linux.  If it was an upgrade, is it an
upgrade from a clean install, or from a system which may have
contained previous rawhide contents?
Comment 5 Alan Cox 2002-03-28 18:46:34 EST
I've also seen this. To replicate - as root

dd if=/dev/zero of=/tmp/annoymikeharrisalot

when it says disk full reboot the machine

xfs fails to start up (no disk space in /tmp) and X then fails
Comment 6 Olivier Baudron 2002-03-30 07:25:03 EST
I upgraded XFree86 from 4.2.0-6.48 to -6.51 and got the same problem:

$ startx
...snip...
Fatal server error:
could not open default font 'fixed'

I restarted xfs, but it did not help.
Any clue?
Comment 7 Mike A. Harris 2002-03-31 23:24:41 EST
*** Bug 62392 has been marked as a duplicate of this bug. ***
Comment 8 Mike A. Harris 2002-03-31 23:25:31 EST
*** Bug 62430 has been marked as a duplicate of this bug. ***
Comment 9 Mike A. Harris 2002-03-31 23:41:29 EST
Bug is also related to bug #61940
Comment 10 Mike A. Harris 2002-03-31 23:53:22 EST
This bug was caused when I changed the globs for the files in the
base-fonts package in order to flag individual files properly.  When
I changed from the glob fonts.* to individual filenames, fonts.alias
didn't click into my head, so it got missed.  Simple goofup on my part.

Problem should now be fixed in 4.2.0-6.52 in rawhide.

alan - that /tmp issue is separate this time.  ;o)  It's still open
in another bugziller somewhere.. on the todo list though.

Once someone confirms this fixed, please change resolution to RAWHIDE.
Comment 11 Mike A. Harris 2002-04-01 13:16:53 EST
*** Bug 62472 has been marked as a duplicate of this bug. ***
Comment 12 Mike A. Harris 2002-04-01 13:19:53 EST
*** Bug 62476 has been marked as a duplicate of this bug. ***
Comment 13 Bill Crawford 2002-04-02 17:21:22 EST
Eagerly awaiting the fix ... when's the next push due?

Quick fix is of course to downgrade base-fonts to -6.48 (which requires XFree86
at -6.48 too, I just did both but you could use --nodeps).
Comment 14 Peter Bowen 2002-04-02 17:32:00 EST
confirmed fix in 4.2.0-6.52 in rawhide.
Comment 15 Bill Crawford 2002-04-02 18:15:27 EST
I can't see a -6.52 anywhere ... where are you getting it?
Comment 16 Bill Crawford 2002-04-02 18:23:13 EST
Ah, please ignore ... just seen it on Mike's FTP area.  Wasn't there last time I
checked.
Comment 17 Mike A. Harris 2002-04-03 17:14:34 EST
Whoopsie.. billc got dropped in a bugzilla mid-air-collision.

Note You need to log in before you can comment on or make changes to this bug.