Bug 61947 - up2date_client cannot import clap module
Summary: up2date_client cannot import clap module
Status: CLOSED DUPLICATE of bug 61749
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: up2date   
(Show other bugs)
Version: skipjack-beta1
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-03-26 04:51 UTC by Phil
Modified: 2015-01-07 23:55 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-26 17:16:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Phil 2002-03-26 04:51:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/2.99 (3.0 rc3); Linux)

Description of problem:
Possible not a bug as probably rhn availability is not enabled for this product yet (?) The up2date_client python program cannot import a module called clap. This was a fresh install on a formated partition, and not an upgrade from 7.2 -> skipjack

Traceback (innermost last):
  File "/usr/sbin/up2date", line 16, in ?
    from up2date_client import clap
ImportError: cannot import name clap



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:

After running rhn_register, run up2date 

Actual Results:  Program fails

Expected Results:  up2date should have started

Additional info:

Comment 1 Geoff Lane 2002-03-26 17:16:55 UTC
On line 16 of the up2date python script the import is wrong.
This patch fixes it for me. (done with patch -u)

--- up2date     Tue Mar 26 11:14:44 2002
+++ /usr/sbin/up2date   Mon Mar 25 11:52:57 2002
@@ -13,7 +13,7 @@
 from up2date_client import config
 from up2date_client.translate import _, N_, cat
 from up2date_client import up2date
-from up2date_client import clap
+import clap
 
 try:
     from rhn import rpclib


Comment 2 Adrian Likins 2002-03-26 17:53:13 UTC

*** This bug has been marked as a duplicate of 61749 ***


Note You need to log in before you can comment on or make changes to this bug.