Bug 61749 - up2ate fails to run
up2ate fails to run
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: python-clap (Show other bugs)
skipjack-beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
: 61947 62185 62242 62316 (view as bug list)
Depends On:
Blocks: 61590
  Show dependency treegraph
 
Reported: 2002-03-24 00:14 EST by rhn-note
Modified: 2015-01-07 18:55 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-01 15:58:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix for up2date problem (318 bytes, text/plain)
2002-03-24 00:20 EST, Charlie Lesh
no flags Details
Fix for up2date problem (318 bytes, text/plain)
2002-03-24 00:24 EST, Charlie Lesh
no flags Details

  None (edit)
Description rhn-note 2002-03-24 00:14:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020314

Description of problem:
running up2date (alone, with -u, or with --configure, etc.) fails to run.  Same
outcome in X or CLI (with or without rhn_register run first) - ouputs:
[root@localhost root]# up2date
Traceback (innermost last):
  File "/usr/sbin/up2date", line 16, in ?
    from up2date_client import clap
ImportError: cannot import name clap


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Fresh skipjack install (on new drive)
2. run up2date
	

Actual Results:  Traceback (innermost last):
  File "/usr/sbin/up2date", line 16, in ?
    from up2date_client import clap
ImportError: cannot import name clap

[then returned to prompt]

Expected Results:  A good up2date run, checking RedHat for updates to the
Skipjack beta1 system.

Additional info:

Dell Inspiron 4100
Comment 1 Charlie Lesh 2002-03-24 00:20:47 EST
Created attachment 49904 [details]
Fix for up2date problem
Comment 2 Charlie Lesh 2002-03-24 00:24:06 EST
Created attachment 49905 [details]
Fix for up2date problem
Comment 3 Adrian Likins 2002-03-25 16:54:01 EST
code fixed in cvs, should be in next release. 
(2.7.62)
Comment 4 Adrian Likins 2002-03-26 12:53:08 EST
*** Bug 61947 has been marked as a duplicate of this bug. ***
Comment 5 Adrian Likins 2002-03-26 15:42:57 EST
This should be fixed in versions 2.7.61 or higher.
Comment 6 Jay Turner 2002-03-28 12:27:21 EST
*** Bug 62185 has been marked as a duplicate of this bug. ***
Comment 7 Gene Czarcinski 2002-03-28 15:20:15 EST
*** Bug 62242 has been marked as a duplicate of this bug. ***
Comment 8 Sammy 2002-03-29 11:31:11 EST
I am not sure why this is CLOSED since the bug is still in :

up2date-2.7.65-7.x.3
rpm-python-4.0.4-7x.9
python-clap-1.0.0-2

clap.py is NOT in the up2date directory AND it looks for up2datepopt which
is NOT supplied by any package!
Comment 9 Adrian Likins 2002-04-01 12:38:34 EST
The bug is fixed, the versions in rawhide arent quite new enough. 

Nothing should be looking for up2datepopt in current versions. Sounds
like rawhide is kind of busted.

It will look for python-popt first, and then up2date-popt, sounds like
it's not finding python-popt (and looking at that version of the package,
it's missing the dep on python-popt). 

Install python-popt and it should be fine. The new version of the package
will require python-popt.

reassigning to a python-clap bug.
Comment 10 Bill Nottingham 2002-04-01 15:58:25 EST
*** Bug 62316 has been marked as a duplicate of this bug. ***
Comment 11 Jeremy Katz 2002-04-10 18:36:37 EDT
This is fine on my fresh install from our internal trees

Note You need to log in before you can comment on or make changes to this bug.