Bug 619702 - Spacewalk return error when receive Unicode string in xmlrpc communication
Spacewalk return error when receive Unicode string in xmlrpc communication
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
urgent Severity high
: ---
: ---
Assigned To: Miroslav Suchý
Petr Sklenar
:
: 619706 (view as bug list)
Depends On: 619699
Blocks: sat531-triage 579830 619086
  Show dependency treegraph
 
Reported: 2010-07-30 04:35 EDT by Miroslav Suchý
Modified: 2011-04-21 15:41 EDT (History)
6 users (show)

See Also:
Fixed In Version: spacewalk-backend-0.5.28-58-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 619699
Environment:
Last Closed: 2010-10-05 09:16:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0740 normal SHIPPED_LIVE Red Hat Network Satellite bug fix update 2010-10-05 09:16:28 EDT

  None (edit)
Description Miroslav Suchý 2010-07-30 04:35:51 EDT
+++ This bug was initially created as a clone of Bug #619699 +++

Description of problem:
During work on https://bugzilla.redhat.com/show_bug.cgi?id=579830
I find that if we send unicode string in xmlrpc, we will get from server rhnFault

While running 'registration.add_hw_profile': caught
exceptions.UnicodeEncodeError : 'ascii' codec can't encode character u'\xae' in position 44: ordinal not in range(128) 

This is becouse we do in backend/server/rhnSQL/driver_cx_Oracle.py
     def _execute_wrapper(self, function, *p, **kw):
        params =  ','.join(["%s: %s" % (str(key), str(value)) for key, value \

and str on e.g. '\xae' will fail.
Comment 1 Clifford Perry 2010-07-30 13:09:34 EDT
We should re-spin the backend errata to include fix for this.
Comment 2 Miroslav Suchý 2010-08-03 09:52:39 EDT
cherrypicked to satellite.git as commit da0e561e38969c5223418a57f1ec0511668efa83
Comment 3 Petr Sklenar 2010-08-04 10:27:48 EDT
*** Bug 619706 has been marked as a duplicate of this bug. ***
Comment 5 Miroslav Suchý 2010-09-07 04:31:26 EDT
Can you please retest it again. I assume this was happening due issue which was fixed by http://errata.devel.redhat.com/errata/show/9884
If you find that this bz is still valid, I would welcome if you can provide hostname of client where this issue eventually happen.
Comment 15 errata-xmlrpc 2010-10-05 09:16:53 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0740.html

Note You need to log in before you can comment on or make changes to this bug.