Bug 619706 - cannot register from specific machines
cannot register from specific machines
Status: CLOSED DUPLICATE of bug 619702
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.8
All Linux
high Severity medium
: rc
: ---
Assigned To: Miroslav Suchý
Red Hat Satellite QA List
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-30 04:58 EDT by Petr Sklenar
Modified: 2010-08-04 10:27 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-04 10:27:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hw info (11.25 KB, text/plain)
2010-07-30 05:02 EDT, Petr Sklenar
no flags Details

  None (edit)
Description Petr Sklenar 2010-07-30 04:58:13 EDT
Description of problem:
I cannot register from specific machines.
Its regression discovered by up2date-4.8.1-33.el4_8.5

Version-Release number of selected component (if applicable):
started in up2date-4.8.1-33.el4_8.5 
doesn't work also in up2date-4.8.1-33.el4_8.9


How reproducible:
specific machine

Steps to Reproduce:
1. try to register specific machine into sat530
  
Actual results:
Internal Server Error
[Fri Jul 30 04:56:51 2010] up2date A protocol error occurred: Internal Server Error , attempt #1,
[Fri Jul 30 04:56:56 2010] up2date A protocol error occurred: Internal Server Error , attempt #2,
[Fri Jul 30 04:57:01 2010] up2date A protocol error occurred: Internal Server Error , attempt #3,
[Fri Jul 30 04:57:07 2010] up2date A protocol error occurred: Internal Server Error , attempt #4,
[Fri Jul 30 04:57:12 2010] up2date A protocol error occurred: Internal Server Error , attempt #5,

Expected results:
I can register machine

Additional info:
1.
up2date-4.8.1-33.el4_8.1 works well:
[root@ibm-himalaya ~]# rhnreg_ks --serverUrl=http://rlx-0-14.rhndev.redhat.com/XMLRPC --force --username=XXX --password=YYY --profilename=RHTSTEST-`hostname`
[root@ibm-himalaya ~]# rpm -q rhnlib up2date
rhnlib-2.1.4-14.el4_8.2
up2date-4.8.1-33.el4_8.1

2.
up2date-4.8.1-33.el4_8.5 doesn't work:
# rpm -q rhnlib up2date
rhnlib-2.1.4-14.el4_8.2
up2date-4.8.1-33.el4_8.5
[root@ibm-himalaya ~]# rhnreg_ks --serverUrl=http://rlx-0-14.rhndev.redhat.com/XMLRPC --force --username=XXX --password=YYY --profilename=RHTSTEST-`hostname`
Internal Server Error

3.
rhnregister against xmlrpc.rhn.errata.stage.redhat.com works well.
Comment 1 Petr Sklenar 2010-07-30 04:58:45 EDT
log from sat530:
[root@rlx-0-14 ~]# tail -f /var/log/httpd/error_log
Exception reported from rlx-0-14.rhndev.redhat.com
Time: Thu Jul 29 11:14:18 2010
Exception type xml.parsers.expat.ExpatError
Exception while handling function handler
Request object information:
URI: /XMLRPC
Remote Host: 10.16.64.46
Server Name: rlx-0-14.rhndev.redhat.com:443
Headers passed in:
 Accept-Encoding: identity
 Content-Length: 1756
 Host: rlx-0-14.rhndev.redhat.com:443
 content-type: text/xml
 user-agent: rhn.rpclib.py/$Revision: 191145 $
 x-client-version: 1
 x-info: RPC Processor (C) Red Hat, Inc (version 194800)
 x-rhn-client-capability:
packages.verifyAll(1)=1,caneatCheese(1)=1,packages.extended_profile(1)=1,reboot.reboot(1)=1,packages.verify(1)=1,packages.runTransaction(1)=1,packages.update(2)=2,packages.rollBack(1)=1
 x-rhn-transport-capability: follow-redirects=3
 x-transport-info: Extended Capabilities Transport (C) Red Hat, Inc (version
191145)
 x-up2date-version: 4.8.1-33.el4_8.9
Extra information about this error:
Unhandled exception type

Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/server/apacheServer.py", line 58, in __call__
    ret = f(req)
  File "/usr/share/rhn/server/apacheHandler.py", line 198, in handler
    ret = self._req_processor.process()
  File "/usr/share/rhn/server/apacheRequest.py", line 465, in process
    params, method = self.decode(_body)
  File "/usr/share/rhn/server/apacheRequest.py", line 389, in decode
    self.parser.feed(data)
  File "/usr/lib/python2.4/xmlrpclib.py", line 527, in feed
    self._parser.Parse(data, 0)
ExpatError: not well-formed (invalid token): line 60, column 15
Comment 2 Petr Sklenar 2010-07-30 05:02:13 EDT
Created attachment 435501 [details]
hw info

this is hw info from buggy machine, command:
PYTHONPATH=/usr/share/rhn python -c "from up2date_client import hardware; print hardware.Hardware()"
Comment 4 Miroslav Suchý 2010-07-30 05:23:45 EDT
up2date-4.8.1-33.el4_8.5 was never publicly released. 
up2date-4.8.1-33.el4_8.6 was release in http://rhn.redhat.com/errata/RHBA-2010-0406.html
Comment 5 Petr Sklenar 2010-07-30 10:51:27 EDT
I can register against sat521 with specific machine. So it appears only against sat530+rhn updates
Comment 6 Petr Sklenar 2010-08-04 10:27:48 EDT

*** This bug has been marked as a duplicate of bug 619702 ***

Note You need to log in before you can comment on or make changes to this bug.