Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 619927 - systemd destroys ability to shutdown/restart a machine
systemd destroys ability to shutdown/restart a machine
Status: CLOSED DUPLICATE of bug 605519
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-07-30 17:55 EDT by Michal Jaegermann
Modified: 2010-08-01 09:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-01 09:57:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2010-07-30 17:55:43 EDT
Description of problem:

After a boot with systemd my machine does not stop anymore after "halt" or "shutdown -h now" and does not reboot after "reboot" or "shutdown -r now". A text messages from such actions, observed on a system console, end up like that:
.....
Starting Kill All Processes...
Not stopping monitoring, this is dangerous operation.  Please use force-stop to override.

After that a system is dead with a power swith as the only possible operation; "dangerous" or not.

On other occasions before "Not stopping monitoring ..." the following line may appear:

Stopping System Initialization

but an overall outcome is the same.

Rebooting with "init=/sbin/upstart" restores an ability to shutdown.  This hits bug 618678 (power off on reboot) but at least it does not hang.

Version-Release number of selected component (if applicable):
systemd-4-4.fc14

How reproducible:
always

Additional info:
"Not stopping monitoring, this is dangerous operation." should really read
"Not stopping monitoring. This is a dangerous operation." regardless of a wisdom of such action.
Comment 1 Michal Schmidt 2010-08-01 03:56:08 EDT
Duplicate of bug 605519?
Comment 2 Michal Jaegermann 2010-08-01 09:57:36 EDT
(In reply to comment #1)
> Duplicate of bug 605519?    

Yes, indeed it is.

*** This bug has been marked as a duplicate of bug 605519 ***

Note You need to log in before you can comment on or make changes to this bug.