Bug 619961 - gget needs to be rebuilt against python 2.7 in F14 and devel
Summary: gget needs to be rebuilt against python 2.7 in F14 and devel
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gget (Show other bugs)
(Show other bugs)
Version: 14
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Orcan Ogetbil
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: Python27Rebuild
TreeView+ depends on / blocked
 
Reported: 2010-07-31 00:40 UTC by Dave Malcolm
Modified: 2011-06-01 18:44 UTC (History)
3 users (show)

Fixed In Version: gget-0.0.4-13.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-01 20:33:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dave Malcolm 2010-07-31 00:40:25 UTC
The package needs to be rebuilt against python 2.7 in both F14 and devel.

Looks like this is blocked on:
  https://admin.fedoraproject.org/updates/notify-python-0.1.1-13.fc14

Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

Thanks!

Comment 1 Dave Malcolm 2010-07-31 09:19:56 UTC
Looks like this has already been built and submitted:
https://admin.fedoraproject.org/updates/gget-0.0.4-13.fc14

Comment 2 Orcan Ogetbil 2010-08-01 20:33:32 UTC
The fixed package is built an pushed to stable.

Comment 3 Andre Robatino 2011-06-01 14:37:13 UTC
Still doesn't run in either F15 or Rawhide.

[andre@compaq-pc ~]$ gget
/usr/bin/env: python2.5: No such file or directory
[andre@compaq-pc ~]$

See also bug 523870, bug 614147, and bug 702159. These are all dupes.

Comment 4 Dave Malcolm 2011-06-01 18:44:30 UTC
(In reply to comment #3)
> Still doesn't run in either F15 or Rawhide.
> 
> [andre@compaq-pc ~]$ gget
> /usr/bin/env: python2.5: No such file or directory
> [andre@compaq-pc ~]$
> 
> See also bug 523870, bug 614147, and bug 702159. These are all dupes.
Thanks for the heads up.

I've gone ahead and tried to fix the issue in comment #3 (bug 702159, and all those other dupes), which is that the shebang line in /usr/bin/gget erroneously hardcodes "python2.5", which has been wrong in Fedora since Fedora 11, I believe.

This specific bug covers a slightly different issue, that of the installation path being for 2.7, and to use 2.7's bytecode format, which FWIW is fixed.

Hope this makes sense.


Note You need to log in before you can comment on or make changes to this bug.