Bug 619970 - ocfs2-tools needs to be rebuilt against python 2.7 in F14 and devel
Summary: ocfs2-tools needs to be rebuilt against python 2.7 in F14 and devel
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ocfs2-tools
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mark Fasheh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 620195 (view as bug list)
Depends On:
Blocks: Python27Rebuild
TreeView+ depends on / blocked
 
Reported: 2010-07-31 01:44 UTC by Dave Malcolm
Modified: 2010-12-03 08:28 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2010-12-03 08:28:24 UTC


Attachments (Terms of Use)

Description Dave Malcolm 2010-07-31 01:44:56 UTC
The package needs to be rebuilt against python 2.7 in both F14 and devel.

Automated rebuild failed with:
  mount.ocfs2.c:264:2: error: variable-sized object may not be initialized
http://koji.fedoraproject.org/koji/getfile?taskID=2344885&name=build.log

I'm guessing that this is a GCC 4.4 -> 4.5 change.

Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

Thanks!

Comment 1 Sunil Mushran 2010-08-02 23:15:27 UTC
264         char stackstr[strlen(OCFS2_CLUSTER_STACK_ARG) + OCFS2_STACK_LABEL_LEN + 1] = "";

Not sure I understand the compile error. Trying to get hold of a box with gcc 4.5 to make sense of this.

Comment 2 Sunil Mushran 2010-08-03 00:07:22 UTC
http://oss.oracle.com/git/?p=ocfs2-tools.git;a=commitdiff;h=862001a972b495a79cafa98c8b7559b603ac5bf8

Which version of ocfs2-tools are you building?

Comment 3 Fedora Update System 2010-08-03 12:49:51 UTC
ocfs2-tools-1.4.3-8.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/ocfs2-tools-1.4.3-8.fc14

Comment 4 Toshio Ernie Kuratomi 2010-08-03 12:51:36 UTC
This is fixed with a small patch.  Please see about getting it or another patch that accomplishes the same thing to upstream.  (My C is a little rusty and I'm not sure if strcpy would be better to use to initialize that value).

Comment 5 Toshio Ernie Kuratomi 2010-08-03 12:54:49 UTC
*** Bug 620195 has been marked as a duplicate of this bug. ***

Comment 6 Fedora Update System 2010-08-05 14:26:08 UTC
ocfs2-tools-1.4.3-8.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.