Bug 620195 - ocfs2-tools needs to be rebuilt against python 2.7 in F14 and devel
Summary: ocfs2-tools needs to be rebuilt against python 2.7 in F14 and devel
Status: CLOSED DUPLICATE of bug 619970
Alias: None
Product: Fedora
Classification: Fedora
Component: ocfs2-tools   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Mark Fasheh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: Python27Rebuild
TreeView+ depends on / blocked
 
Reported: 2010-08-01 14:02 UTC by Thomas Spura
Modified: 2010-08-03 12:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 12:54:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thomas Spura 2010-08-01 14:02:19 UTC
The package needs to be rebuilt against python 2.7 in both F14 and devel.

This fails because it needs some changes to compile with gcc4.5:
mount.ocfs2.c: In function 'main':
mount.ocfs2.c:264:2: error: variable-sized object may not be initialized
see:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2371235

Information on the new "dist-git" system can be seen here:
  http://fedoraproject.org/wiki/Using_Fedora_GIT

Information on common difficulties with Python 2.7 rebuilds can be seen here:
  https://fedoraproject.org/wiki/Features/Python_2.7

Once it's been successfully rebuilt for F14, an update needs to be filed to get the rebuild into F14:
  https://admin.fedoraproject.org/updates/new/

Please add this bug to the update, to make it easy to track what's been done, and what's left to do.

Thanks!

Comment 1 Toshio Ernie Kuratomi 2010-08-03 12:54:49 UTC

*** This bug has been marked as a duplicate of bug 619970 ***


Note You need to log in before you can comment on or make changes to this bug.