Bug 620111 - On qemu:///session, "Error: build_row() takes at least 5 arguments (4 given)"
On qemu:///session, "Error: build_row() takes at least 5 arguments (4 given)"
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
13
All Linux
low Severity medium
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 657004
  Show dependency treegraph
 
Reported: 2010-07-31 20:03 EDT by Cesar Eduardo Barros
Modified: 2010-11-24 11:55 EST (History)
6 users (show)

See Also:
Fixed In Version: virt-manager-0.8.5-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 657004 (view as bug list)
Environment:
Last Closed: 2010-09-04 00:59:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cesar Eduardo Barros 2010-07-31 20:03:02 EDT
Description of problem:

When trying to create a new virtual machine using virt-manager on qemu:///session, it gives the message "Error: build_row() takes at least 5 arguments (4 given)" on step 1 of the wizard. The forward button is grayed out and cannot be used.

Version-Release number of selected component (if applicable):

virt-manager-0.8.4-2.fc13.noarch

How reproducible:
Always

Steps to Reproduce:
1.Run virt-manager -c qemu:///session
2.Click the "Create a new virtual machine" button
  
Actual results:
"Error: build_row() takes at least 5 arguments (4 given)", forward button on the wizard grayed out even after typing on anything on the text box.

Expected results:
Working without error

Additional info:

The culprit seems to be on /usr/share/virt-manager/virtManager/uihelpers.py, at the following block of code:

    # For qemu:///session
    if conn.is_qemu_session():
        nettype = VirtualNetworkInterface.TYPE_USER
        add_row(nettype, None, pretty_network_desc(nettype), True)
        set_active(0)
        return

The function add_row() forwards all its arguments to build_row. However, build_row() is expecting 5 arguments, and here add_row() is passing it only 4.
Comment 1 Cole Robinson 2010-08-02 12:22:59 EDT
Fixed upstream:

http://hg.fedorahosted.org/hg/virt-manager/rev/ea94314da7d5
Comment 2 Stephen Haffly 2010-08-17 11:30:16 EDT
I just made the changes listed in the reference above to the uihelpers.py file, and can verify that the dialog now works for me to create a virtual machine as a user.
Comment 3 Fedora Update System 2010-08-25 16:58:54 EDT
virt-manager-0.8.5-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/virt-manager-0.8.5-1.fc13
Comment 4 Fedora Update System 2010-08-25 20:53:17 EDT
virt-manager-0.8.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/virt-manager-0.8.5-1.fc13
Comment 5 Fedora Update System 2010-08-31 23:27:39 EDT
virt-manager-0.8.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/virt-manager-0.8.5-1.fc13
Comment 6 Fedora Update System 2010-09-04 00:58:51 EDT
virt-manager-0.8.5-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.