Bug 657004 - When creating a new VM in virt-manager QEMU usermode, "Error: build_row() takes at least 5 arguments (4 given)"
Summary: When creating a new VM in virt-manager QEMU usermode, "Error: build_row() tak...
Status: CLOSED DUPLICATE of bug 634876
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-manager
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Cole Robinson
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Keywords:
Depends On: 620111
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-11-24 16:55 UTC by Mike Jang
Modified: 2010-11-29 18:31 UTC (History)
8 users (show)

(edit)
Clone Of: 620111
(edit)
Last Closed: 2010-11-29 18:31:00 UTC


Attachments (Terms of Use)

Description Mike Jang 2010-11-24 16:55:51 UTC
+++ This bug was initially created as a clone of Bug #620111 +++

Description of problem:

When trying to create a new virtual machine using virt-manager on qemu:///session, it gives the message "Error: build_row() takes at least 5 arguments (4 given)" on step 1 of the wizard. The forward button is grayed out and cannot be used.

Version-Release number of selected component (if applicable):

virt-manager-0.8.4-2.fc13.noarch

How reproducible:
Always

Steps to Reproduce:
1.Run virt-manager -c qemu:///session
2.Click the "Create a new virtual machine" button
  
Actual results:
"Error: build_row() takes at least 5 arguments (4 given)", forward button on the wizard grayed out even after typing on anything on the text box.

Expected results:
Working without error

Additional info:

The culprit seems to be on /usr/share/virt-manager/virtManager/uihelpers.py, at the following block of code:

    # For qemu:///session
    if conn.is_qemu_session():
        nettype = VirtualNetworkInterface.TYPE_USER
        add_row(nettype, None, pretty_network_desc(nettype), True)
        set_active(0)
        return

The function add_row() forwards all its arguments to build_row. However, build_row() is expecting 5 arguments, and here add_row() is passing it only 4.

--- Additional comment from crobinso@redhat.com on 2010-08-02 12:22:59 EDT ---

Fixed upstream:

http://hg.fedorahosted.org/hg/virt-manager/rev/ea94314da7d5

--- Additional comment from hafflys@earthlink.net on 2010-08-17 11:30:16 EDT ---

I just made the changes listed in the reference above to the uihelpers.py file, and can verify that the dialog now works for me to create a virtual machine as a user.

--- Additional comment from updates@fedoraproject.org on 2010-08-25 16:58:54 EDT ---

virt-manager-0.8.5-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/virt-manager-0.8.5-1.fc13

--- Additional comment from updates@fedoraproject.org on 2010-08-25 20:53:17 EDT ---

virt-manager-0.8.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/virt-manager-0.8.5-1.fc13

--- Additional comment from updates@fedoraproject.org on 2010-08-31 23:27:39 EDT ---

virt-manager-0.8.5-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update virt-manager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/virt-manager-0.8.5-1.fc13

--- Additional comment from updates@fedoraproject.org on 2010-09-04 00:58:51 EDT ---

virt-manager-0.8.5-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 1 Mike Jang 2010-11-24 16:58:06 UTC
This problem also appears in RHEL 6, virt-manager version 0.8.4-8.el6.

I get the error when I try to create a new VM in QEMU usermode. 

Hopefully, RHEL 6 just needs the same update as was done for the cloned bug.

Comment 3 Cole Robinson 2010-11-29 18:31:00 UTC

*** This bug has been marked as a duplicate of bug 634876 ***


Note You need to log in before you can comment on or make changes to this bug.