Bug 620160 - AR2427 wifi on ath9k looses packets, but works fine with recent compat-wireless version
AR2427 wifi on ath9k looses packets, but works fine with recent compat-wirele...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
13
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-01 07:21 EDT by Justin Albstmeijer
Modified: 2010-08-05 13:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 13:52:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Albstmeijer 2010-08-01 07:21:16 EDT
Description of problem:

Network throughput is unstable on my eeepc 1001px using the ath9k moudule for the AR2427 wireless device.
After compiling and installing the ath9k module from compat-wireless-2010-07-08.tar.bz2 all seems to works fine.

Version-Release number of selected component (if applicable):

kernel-2.6.33.6-147.fc13.x86_64

How reproducible:

While browsing random requests never end or are really slow to respond
During a ping, +10% packets are lost.
When downloading throughput is varying a lot during the download.

Steps to Reproduce:
1. ping with default ath9k, and see packet loss.
2. update ath9k from compat-wireless-2010-07-08.tar.bz2.
3. ping with new ath9k loaded, and see no packet loss.
  
Actual results:

packet loss

Expected results:

no or accidental packet loss
 
Additional info:

First tried kernel-2.6.34.1-29.fc13.x86_64.rpm from http://kojipkgs.fedoraproject.org to check if 2.6.34 fixed it, same results.

Then tried wireless-2010-07-31.tar.bz2, but it did not compile, with the following error

net/wireless/core.c:937: error: storage size of ‘vaf’ isn’t known

here a report
http://forum.ubuntu-nl.org/internet-en-draadloos/asus-eeepc-1001-px/msg632534/
suggesting compat-wireless-2010-07-28.tar.bz2 has the same compile issue.

Just gambled and tried compat-wireless-2010-07-08.tar.bz2 which compiled and all seems to works fine.

source of downloads wget http://www.orbit-lab.org/kernel/compat-wireless-2.6/2010/07/
Comment 1 John W. Linville 2010-08-05 13:52:50 EDT
I'm sorry, but you'll just have to use the compat-wireless bits and/or wait for a later upstream base for the Fedora kernels (e.g. 2.6.36).

Note You need to log in before you can comment on or make changes to this bug.