Bug 620176 - Init fails with missing .service files
Summary: Init fails with missing .service files
Status: CLOSED DUPLICATE of bug 618315
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-01 12:40 UTC by Jan Alonzo
Modified: 2010-08-02 11:07 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-02 11:07:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jan Alonzo 2010-08-01 12:40:35 UTC
Description of problem:
Init fails with missing .service files. Console output is:

init[1]: Failed to load configuration for hal.service: No such file or directory

The line above is repeated for the following service files:

- xend.service
- cman.service
- distcache.service
- openct.service
- default.target

Version-Release number of selected component (if applicable):
Most recent version in rawhide (date: 1 Aug 2010 EST)

How reproducible:
Everytime.

Steps to Reproduce:
1. Boot into Fedora and check console output
  
Actual results:
Fails with the error above.

Expected results:
Should continue to GDM.

Additional info:
N/A

Comment 1 Michal Schmidt 2010-08-02 11:07:20 UTC
(In reply to comment #0)
> init[1]: Failed to load configuration for hal.service: No such file or
> directory
> 
> The line above is repeated for the following service files:
> 
> - xend.service
> - cman.service
> - distcache.service
> - openct.service

These are harmless. see bug 614644.

> - default.target

That's a problem with upgrading from an older version of systemd-units. Workaround exists. See bug 618315.

*** This bug has been marked as a duplicate of bug 618315 ***


Note You need to log in before you can comment on or make changes to this bug.