Bug 620273 - Width of '.notdef' character prevents Liberation Mono from being detected as monospace
Width of '.notdef' character prevents Liberation Mono from being detected as ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: liberation-fonts (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
:
: 508899 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-01 18:55 EDT by Cody Boisclair
Modified: 2010-10-12 05:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-02 02:37:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Patch fixing the character widths in Liberation Mono so that it detects correctly as monospaced. (2.55 KB, patch)
2010-08-01 19:09 EDT, Cody Boisclair
no flags Details | Diff
TrueType version of patched Liberation Mono fonts (47 bytes, text/plain)
2010-08-02 19:26 EDT, Cody Boisclair
no flags Details

  None (edit)
Description Cody Boisclair 2010-08-01 18:55:27 EDT
Description of problem:
Because the character '.notdef' has a different width than the rest of the characters in the font, some applications, such as PuTTY on Windows, do not detect Liberation Mono as a valid monospaced font.

Version-Release number of selected component (if applicable):
1.06.0.20100721

Steps to Reproduce:
(This is reproducible both on a real Windows installation and under WINE.)
1. Install the latest version of Liberation Mono.
2. Download putty.exe from <http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html>.
3. Open PuTTY, look under the Appearance tab, and click the "Change" button under Font Settings.

Actual results:
Liberation Mono is not in the font list.

Expected results:
Liberation Mono is in the font list.
Comment 1 Cody Boisclair 2010-08-01 19:09:10 EDT
Created attachment 435925 [details]
Patch fixing the character widths in Liberation Mono so that it detects correctly as monospaced.
Comment 2 Pravin Satpute 2010-08-02 02:37:19 EDT
good catch !!
applied your patch to upstream, will be available in upstream release

Note: created mailing list for liberation-fonts see https://fedorahosted.org/mailman/listinfo/liberation-fonts
Comment 3 Cody Boisclair 2010-08-02 19:17:13 EDT
I believe this also fixes bug 508899 and bug 557862, which describe related issues that seem to have been fixed by this patch - what field should I add those to?
Comment 4 Cody Boisclair 2010-08-02 19:26:07 EDT
Created attachment 436155 [details]
TrueType version of patched Liberation Mono fonts

For those who don't want to build the fonts from source while waiting for the next binary release, here are generated TrueType files of the patched version of Liberation Mono.
Comment 5 Kevin Kofler 2010-08-02 20:51:58 EDT
*** Bug 508899 has been marked as a duplicate of this bug. ***
Comment 6 Pravin Satpute 2010-08-03 01:23:39 EDT
presently we are not building liberation fonts from source in feodra, 
so cant build with patch on fedora, 

i will do it soon

1) building liberation-fonts from source in fedora
2) applying patch for monospace

thanks cody
Comment 7 Fedora Update System 2010-10-12 05:06:23 EDT
liberation-fonts-1.06.0.20100721-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/liberation-fonts-1.06.0.20100721-2.fc14

Note You need to log in before you can comment on or make changes to this bug.