Bug 620354 - Install fails from the F14 alpha TC1 because python problem
Summary: Install fails from the F14 alpha TC1 because python problem
Keywords:
Status: CLOSED DUPLICATE of bug 620274
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-02 09:49 UTC by Joachim Backes
Modified: 2010-08-02 13:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-02 13:29:21 UTC


Attachments (Terms of Use)
See problem description (75.90 KB, image/jpeg)
2010-08-02 09:49 UTC, Joachim Backes
no flags Details

Description Joachim Backes 2010-08-02 09:49:01 UTC
Created attachment 435989 [details]
See problem description

Description of problem:
I downloaded the F14 TC1 Alpha DVD iso (checksum is correct), burned a DVD and booted it directly. Then anaconda fails with a python error. No camera available for taking a screen picture, I now booted the image in VirtualBox, but with exactly the same result. See attachment (the actual VBox window showing the crash).

Version-Release number of selected component (if applicable):
F14 TC1 alpha

How reproducible:
always

Steps to Reproduce:
1.See description
2.
3.
  
Actual results:
Python problem

Expected results:
install proceeds

Additional info:

Comment 1 Petr Lautrbach 2010-08-02 13:19:31 UTC
Same problem here but for x86_64. Message taken from serial console:

Running anaconda 14.12, the Fedora system installer - please wait.             
Traceback (most recent call last):                                             
  File "/usr/lib64/python2.7/site.py", line 553, in <module>                   
    main()                                                                     
  File "/usr/lib64/python2.7/site.py", line 535, in main                       
    known_paths = addusersitepackages(known_paths)                             
  File "/usr/lib64/python2.7/site.py", line 264, in addusersitepackages        
    user_site = getusersitepackages()                                          
  File "/usr/lib64/python2.7/site.py", line 239, in getusersitepackages        
    user_base = getuserbase() # this will also set USER_BASE                   
  File "/usr/lib64/python2.7/site.py", line 229, in getuserbase                
    USER_BASE = get_config_var('userbase')                                     
  File "/usr/lib64/python2.7/sysconfig.py", line 518, in get_config_var        
    return get_config_vars().get(name)                                         
  File "/usr/lib64/python2.7/sysconfig.py", line 421, in get_config_vars       
    _init_posix(_CONFIG_VARS)
  File "/usr/lib64/python2.7/sysconfig.py", line 285, in _init_posix
    raise IOError(msg)
IOError: invalid Python installation: unable to open /usr/include/python2.7/pyconfig-64.h (No such file or directory)
install exited abnormally [1/1]
The system will be rebooted when you press Ctrl-C or Ctrl-Alt-Delete.

Comment 2 Chris Lumens 2010-08-02 13:29:21 UTC

*** This bug has been marked as a duplicate of bug 620274 ***


Note You need to log in before you can comment on or make changes to this bug.