Bug 620274 - pyconfig-32.h is missing, anaconda fails
Summary: pyconfig-32.h is missing, anaconda fails
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 14
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 620297 620354 620464 (view as bug list)
Depends On:
Blocks: F14Alpha, F14AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-08-01 22:56 UTC by Julian Sikorski
Modified: 2010-08-03 20:19 UTC (History)
17 users (show)

Fixed In Version: anaconda-14.14-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 20:19:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of anaconda traceback (14.72 KB, image/png)
2010-08-01 22:56 UTC, Julian Sikorski
no flags Details
/tmp/anaconda.log (2.11 KB, text/plain)
2010-08-02 03:05 UTC, John Reiser
no flags Details

Description Julian Sikorski 2010-08-01 22:56:36 UTC
Created attachment 435923 [details]
screenshot of anaconda traceback

Description of problem:
It is currently impossible to install Branched due to anaconda not being able to find pyconfig-32.h. I tried to install a kvm guest on an F-13 host.

Comment 1 John Reiser 2010-08-02 03:04:42 UTC
I see the same problem on x86_64 except missing pyconfig-64.h.
-----
Running anaconda 14.12, the Fedora system installer - please wait.
Traceack (most recent call last):
  File "/usr/lib64/phthon2.7/site.py", line 553, in <module>
    main()
  File "/usr/lib64/python2.7/site.py", line 535, in main
    known_paths = addusersitepackages(known_paths)
  File "/usr/lib64/python2.7/site.py:, line 264", in addusersitepackages
    user_site = getusersitepackages()
  File "/usr/lib64/pytohon2.7/site.py", line 239, in getusersitepackages
    user_base = getuserbase() # this will also set USER_BASE
  File "/usr/lib64/python2.7/site.py", line 229, in getuserbase
    USER_BASE = get_config_var('userbase')
  File "/usr/lib64/python2.7/sysconfig.py", line 518, in get_config_var
    return get_config_vars().get(name)
  File "/usr/lib64/python2.7/sysconfig.py", line 421, in get_config_vars
    _init_posix(_CONFIG_VARS)
  File "/usr/lib64/python2.7/sysconfig.py", line 285, in _init_posix
    raise IOError(msg)
IOError: invalid Python installation: unable to open /usr/include/python2.7/pyconfig-64.h (No such file or directory)
install exited abnormally [1/1]
-----

Comment 2 John Reiser 2010-08-02 03:05:12 UTC
Created attachment 435946 [details]
/tmp/anaconda.log

Comment 3 Jens Petersen 2010-08-02 04:26:18 UTC
Reproduced here too.

Comment 4 He Rui 2010-08-02 07:49:15 UTC
*** Bug 620297 has been marked as a duplicate of this bug. ***

Comment 5 Thomas Kowaliczek 2010-08-02 09:38:34 UTC
I have the same problem with it.

Comment 6 Thomas Spura 2010-08-02 11:22:16 UTC
Strange issue.

We had similar problems, when rebuilding anything with python 2.7, but I thought this was fixed in python 2.7-4.

What python version is currently on the F-14 Alpha?

Comment 7 Andre Robatino 2010-08-02 11:27:07 UTC
python-2.7-7.fc14 on both DVDs.

Comment 8 Thomas Spura 2010-08-02 11:36:12 UTC
$ repoquery -f /usr/include/python2.7/pyconfig-32.h --repoid=rawhide --enablerepo=rawhide
python-0:2.7-7.fc14.i686
$ repoquery -f /usr/include/python2.7/pyconfig-64.h --repoid=rawhide --enablerepo=rawhide
python-0:2.7-7.fc14.x86_64

Hmm, should be there.

Comment 9 Julian Sikorski 2010-08-02 12:35:15 UTC
http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=f821da35d32098e855709a6b83a95ccebeca99d2

Isn't that fixed in git already? Maybe all we need is a new anaconda release.

Comment 10 Chris Lumens 2010-08-02 13:29:22 UTC
*** Bug 620354 has been marked as a duplicate of this bug. ***

Comment 11 Chris Lumens 2010-08-02 13:30:18 UTC
Yes, that's all that needs to be done.

Comment 12 James Laska 2010-08-02 15:50:52 UTC
clumens: Are you expecting a newer anaconda build, or should we just need to use the existing anaconda-13.14-1 koji build?

Comment 13 Julian Sikorski 2010-08-02 20:09:01 UTC
Can we have a build for F-14 please?

Comment 14 Chris Lumens 2010-08-02 20:11:33 UTC
You could always try looking in koji:

http://koji.fedoraproject.org/koji/buildinfo?buildID=187810

Comment 15 Julian Sikorski 2010-08-02 20:18:27 UTC
oops, missed that somehow. sorry for the noise.

Comment 16 Dave Malcolm 2010-08-02 23:12:57 UTC
Note that https://admin.fedoraproject.org/updates/anaconda-14.14-1.fc14 is awaiting testing.

I'm not sure exactly what the build process is for the installer.  As I understand it, the install.img needs to be built with anaconda-14.14-1 or later for it to work.

Comment 17 Fran Rogers 2010-08-03 19:55:46 UTC
*** Bug 620464 has been marked as a duplicate of this bug. ***

Comment 18 James Laska 2010-08-03 20:08:19 UTC
No longer seeing the reported problem when testing with anaconda-14.14-1 using test compose#2 - http://serverbeach1.fedoraproject.org/pub/alt/stage/14.TC2/

NOTE: You will run into bug#620900 using TC2

Comment 19 Julian Sikorski 2010-08-03 20:13:44 UTC
Is there any ETA when the fixed install.img will make it to "normal" mirrors?

Comment 20 James Laska 2010-08-03 20:19:35 UTC
(In reply to comment #19)
> Is there any ETA when the fixed install.img will make it to "normal" mirrors?    

Test composes are not published to mirrors.  Please use the URL in comment#18 for any downloads.

Closing this issue since it is resolved in test compose#2 (anaconda-14.14-1)


Note You need to log in before you can comment on or make changes to this bug.