Bug 620464 - Preupgrade from F13 to F14 alpha fails with "invalid Python installation"
Preupgrade from F13 to F14 alpha fails with "invalid Python installation"
Status: CLOSED DUPLICATE of bug 620274
Product: Fedora
Classification: Fedora
Component: preupgrade (Show other bugs)
13
i686 Linux
low Severity high
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-02 11:35 EDT by Fran Rogers
Modified: 2010-08-03 15:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-03 15:55:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Fran Rogers 2010-08-02 11:35:26 EDT
Description of problem:
Using "preupgrade" to upgrade from F13 to F14 alpha fails with the error "IOError: invalid Python installation: unable to open /usr/include/python2.7/pyconfig-32.h (No such file or directory)".

Version-Release number of selected component (if applicable):
preupgrade-1.1.4-1.fc13.noarch

How reproducible:
Reproducible on demand on my x86 netbook.

Steps to Reproduce:
1. Run "preupgrade" as root. Click Next.
2. Check "Display unstable test releases"; select "Fedora 14 (Laughlin)"; click "Apply".
3. Click Next until prompted to reboot; reboot when prompted.
  
Actual results:
I get the following traceback from Anaconda after the reboot:

Traceback (most recent call last):
  File "/usr/lib/python2.7/site.py", line 549, in <module>
    main()
  File "/usr/lib/python2.7/site.py", line 531, in main
    known_paths = addusersitepackages(known_paths)
  File "/usr/lib/python2.7/site.py", line 264, in addusersitepackages
    user_site = getusersitepackages()
  File "/usr/lib/python2.7/site.py", line 239, in getusersitepackages
    user_base = getuserbase() # this will also set USER_BASE
  File "/usr/lib/python2.7/site.py", line 229, in getuserbase
    USER_BASE = get_config_var('userbase')
  File "/usr/lib/python2.7/sysconfig.py", line 518, in get_config_var
    return get_config_vars().get(name)
  File "/usr/lib/python2.7/sysconfig.py", line 421, in get_config_vars
    _init_posix(_CONFIG_VARS)
  File "/usr/lib/python2.7/sysconfig.py", line 285, in _init_posix
    raise IOError(msg)
IOError: invalid Python installation: unable to open /usr/include/python2.7/pyconfig-32.h (No such file or directory)

Anaconda then prompts to press Ctrl-C or Ctrl-Alt-Delete to reboot; after a reboot, I'm back to my previous F13 installation.

Expected results:
The upgrade should go as planned.

Additional info:
It's probably worth noting that no /usr/include directory exists at all in this installation environment.
Comment 1 Fran Rogers 2010-08-03 15:55:46 EDT
Looks like this is a duplicate of #620274.

*** This bug has been marked as a duplicate of bug 620274 ***

Note You need to log in before you can comment on or make changes to this bug.