Bug 620595 - [abrt] crash in fedora-packager-0.5.1.0-1.fc13: __init__.py:797:build:FedpkgError: There are unpushed changes in your repo
[abrt] crash in fedora-packager-0.5.1.0-1.fc13: __init__.py:797:build:FedpkgE...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-packager (Show other bugs)
13
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
abrt_hash:257cd831
:
: 622921 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-02 19:12 EDT by Neal Becker
Modified: 2013-01-10 01:07 EST (History)
5 users (show)

See Also:
Fixed In Version: fedora-packager-0.5.1.2-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 01:36:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (682 bytes, text/plain)
2010-08-02 19:12 EDT, Neal Becker
no flags Details

  None (edit)
Description Neal Becker 2010-08-02 19:12:56 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/fedpkg build
comment: See above
component: fedora-packager
executable: /usr/bin/fedpkg
kernel: 2.6.33.6-147.fc13.x86_64
package: fedora-packager-0.5.1.0-1.fc13
reason: __init__.py:797:build:FedpkgError: There are unpushed changes in your repo
release: Fedora release 13 (Goddard)

backtrace
-----
__init__.py:797:build:FedpkgError: There are unpushed changes in your repo

Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 959, in <module>
    args.command(args)
  File "/usr/bin/fedpkg", line 319, in build
    url, chain)
  File "/usr/lib/python2.6/site-packages/pyfedpkg/__init__.py", line 797, in build
    raise FedpkgError('There are unpushed changes in your repo')
FedpkgError: There are unpushed changes in your repo

Local variables in innermost frame:
remote: 'origin/master'
branch: <git.Head "refs/heads/master">
chain: None
url: None
scratch: False
self: <pyfedpkg.PackageModule instance at 0x1d95560>
cmd: ['koji']
skip_tag: False
background: False

How to reproduce
-----
1.
2.
3.
fedpkg build
Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 959, in <module>
    args.command(args)
  File "/usr/bin/fedpkg", line 319, in build
    url, chain)
  File "/usr/lib/python2.6/site-packages/pyfedpkg/__init__.py", line 797, in build
    raise FedpkgError('There are unpushed changes in your repo')
pyfedpkg.FedpkgError: There are unpushed changes in your repo
Comment 1 Neal Becker 2010-08-02 19:12:59 EDT
Created attachment 436154 [details]
File: backtrace
Comment 2 Jesse Keating 2010-08-02 20:15:06 EDT
This is telling you the right thing and correctly exiting, however I need to trap that traceback and exit more gracefully.
Comment 3 Mads Kiilerich 2010-08-08 17:42:02 EDT
Package: fedora-packager-0.5.1.0-1.fc13
Architecture: i686
OS Release: Fedora release 13 (Goddard)


How to reproduce
-----
run "fedpkg build" with unpushed changes
Comment 4 Jesse Keating 2010-08-12 02:49:52 EDT
Trapped now in next version.
Comment 5 Jesse Keating 2010-08-12 03:24:46 EDT
*** Bug 622921 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2010-08-12 15:53:16 EDT
python-kitchen-0.2-0.1.a2.el5,fedora-packager-0.5.1.2-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/python-kitchen-0.2-0.1.a2.el5,fedora-packager-0.5.1.2-1.el5
Comment 7 Fedora Update System 2010-08-12 15:56:53 EDT
fedora-packager-0.5.1.2-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-1.fc14
Comment 8 Fedora Update System 2010-08-12 16:01:21 EDT
fedora-packager-0.5.1.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-1.fc13
Comment 9 Fedora Update System 2010-08-12 16:07:16 EDT
fedora-packager-0.5.1.2-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-1.fc12
Comment 10 Fedora Update System 2010-08-13 17:06:14 EDT
fedora-packager-0.5.1.2-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fedora-packager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-2.fc13
Comment 11 Fedora Update System 2010-08-13 18:38:51 EDT
fedora-packager-0.5.1.2-2.el5, python-kitchen-0.2-0.1.a2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fedora-packager python-kitchen'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-kitchen-0.2-0.1.a2.el5,fedora-packager-0.5.1.2-2.el5
Comment 12 Fedora Update System 2010-08-17 01:35:43 EDT
fedora-packager-0.5.1.2-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2010-08-24 17:08:59 EDT
fedora-packager-0.5.1.2-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2010-08-24 19:03:26 EDT
fedora-packager-0.5.1.2-2.el5, python-kitchen-0.2-0.1.a2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2010-08-24 21:19:12 EDT
fedora-packager-0.5.1.2-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.