Bug 622921 - [abrt] crash in fedora-packager-0.5.1.0-1.fc12: __init__.py:790:build:FedpkgError: There are uncommitted changes in your repo
[abrt] crash in fedora-packager-0.5.1.0-1.fc12: __init__.py:790:build:FedpkgE...
Status: CLOSED DUPLICATE of bug 620595
Product: Fedora
Classification: Fedora
Component: fedora-packager (Show other bugs)
12
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
abrt_hash:ce158097
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-10 15:26 EDT by Paul Wouters
Modified: 2013-01-10 01:08 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-12 03:24:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (627 bytes, text/plain)
2010-08-10 15:26 EDT, Paul Wouters
no flags Details

  None (edit)
Description Paul Wouters 2010-08-10 15:26:25 EDT
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/fedpkg build
component: fedora-packager
executable: /usr/bin/fedpkg
kernel: 2.6.32.16-150.fc12.x86_64
package: fedora-packager-0.5.1.0-1.fc12
reason: __init__.py:790:build:FedpkgError: There are uncommitted changes in your repo
release: Fedora release 12 (Constantine)

backtrace
-----
__init__.py:790:build:FedpkgError: There are uncommitted changes in your repo

Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 959, in <module>
    args.command(args)
  File "/usr/bin/fedpkg", line 319, in build
    url, chain)
  File "/usr/lib/python2.6/site-packages/pyfedpkg/__init__.py", line 790, in build
    raise FedpkgError('There are uncommitted changes in your repo')
FedpkgError: There are uncommitted changes in your repo

Local variables in innermost frame:
chain: None
url: None
scratch: False
self: <pyfedpkg.PackageModule instance at 0xe09560>
cmd: ['koji']
skip_tag: False
background: False

How to reproduce
-----
1. forgot to git commit first
2.
3.
Comment 1 Paul Wouters 2010-08-10 15:26:26 EDT
Created attachment 437977 [details]
File: backtrace
Comment 2 Jesse Keating 2010-08-10 15:31:14 EDT
Yeah, this shouldn't traceback, I thought I had a trap on it, will add one.
Comment 3 Jesse Keating 2010-08-12 03:24:46 EDT

*** This bug has been marked as a duplicate of bug 620595 ***

Note You need to log in before you can comment on or make changes to this bug.