Bug 620903 - TypeError: argument 2 to map() must support iteration
Summary: TypeError: argument 2 to map() must support iteration
Keywords:
Status: CLOSED DUPLICATE of bug 620900
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F14Alpha, F14AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-08-03 18:16 UTC by James Laska
Modified: 2013-09-02 06:50 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-03 18:18:12 UTC


Attachments (Terms of Use)
anaconda traceback.txt (169.20 KB, text/plain)
2010-08-03 18:16 UTC, James Laska
no flags Details

Description James Laska 2010-08-03 18:16:20 UTC
Created attachment 436344 [details]
anaconda traceback.txt

Description of problem:

Attempting an install using the F14-Alpha test compose#2 boot.iso results in a traceback.

Version-Release number of selected component (if applicable):
 * anaconda-14.14-1

How reproducible:


Steps to Reproduce:
1. Boot the netinst.iso and proceed to stage#2
2. Accept all defaults and continue installation
  
Actual results:

anaconda 14.14 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 183, in storageComplete
    anaconda.storage.fsset)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1262, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1175, in nextClicked
    self.setScreen ()
TypeError: argument 2 to map() must support iteration

Expected results:

No traceback

Additional info:

 * Adding to F14Alpha per the following alpha release criteria ...

#  The installer must be able to complete an installation using the entire disk, existing free space, or existing Linux partitions methods, with or without encryption enabled

Comment 1 James Laska 2010-08-03 18:18:12 UTC

*** This bug has been marked as a duplicate of bug 620900 ***


Note You need to log in before you can comment on or make changes to this bug.