This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 620900 - traceback on install of F14 Alpha Test Compose #2
traceback on install of F14 Alpha Test Compose #2
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
: 620903 621029 621101 621502 621629 (view as bug list)
Depends On:
Blocks: F14Alpha/F14AlphaBlocker
  Show dependency treegraph
 
Reported: 2010-08-03 14:14 EDT by John Poelstra
Modified: 2010-08-13 15:56 EDT (History)
12 users (show)

See Also:
Fixed In Version: anaconda-14.15-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 16:07:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
traceback (108.81 KB, application/octet-stream)
2010-08-03 14:14 EDT, John Poelstra
no flags Details
traceback (108.81 KB, text/plain)
2010-08-03 14:16 EDT, John Poelstra
no flags Details

  None (edit)
Description John Poelstra 2010-08-03 14:14:18 EDT
Created attachment 436343 [details]
traceback

Description of problem:

Traceback after taking all defaults, including "install to existing storage" on KVM 64bit virtual machine running on Fedora 12 64bit.

Version-Release number of selected component (if applicable):
Test Compose #2 DVD ISO

How reproducible: 100%
Comment 1 John Poelstra 2010-08-03 14:16:41 EDT
Created attachment 436345 [details]
traceback
Comment 2 James Laska 2010-08-03 14:18:02 EDT
<report xmlns="http://www.redhat.com/gss/strata"><binding name="localhash">d08be2354f9373e1cb5b89a5016b6a9435c7f52160235bb8ebf6c4bd5442487c</binding><binding name="product" /><binding name="description">The following was filed automatically by anaconda:
anaconda 14.14 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 183, in storageComplete
    anaconda.storage.fsset)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1262, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1175, in nextClicked
    self.setScreen ()
TypeError: argument 2 to map() must support iteration
</binding><binding fileName="/tmp/anaconda-tb-BftMo0" name="pythonUnhandledException" type="text">anaconda 14.14 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 183, in storageComplete
    anaconda.storage.fsset)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1262, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1175, in nextClicked
    self.setScreen ()
TypeError: argument 2 to map() must support iteration

Local variables in innermost frame:
existing_luks: False
devs: []
new_luks: False
anaconda: &lt;pyanaconda.Anaconda object at 0x7f1fb311d990&gt;
Comment 3 James Laska 2010-08-03 14:18:12 EDT
*** Bug 620903 has been marked as a duplicate of this bug. ***
Comment 4 Kevin Fenzi 2010-08-03 14:18:46 EDT
See it here too with the dvd. 

http://www.scrye.com/~kevin/fedora/fedora-14-alpha-tc2-anaconda.png
Comment 5 Bill Nottingham 2010-08-03 14:18:54 EDT
See 2e1f5c30ea69a721a7052f0c77a85d97ba3fa464
Comment 6 James Laska 2010-08-03 14:19:21 EDT
Adding to F14Alpha per the following release criteria 

#  The installer must be able to complete an installation using the entire disk, existing free space, or existing Linux partitions methods, with or without encryption enabled
Comment 7 Chris Lumens 2010-08-03 14:21:23 EDT
Why are we getting xml files attached to bugs instead of plain text?  This is annoying and hard to read.  Please stop.
Comment 9 James Laska 2010-08-03 15:12:44 EDT
An updates is available with this fix at http://jlaska.fedorapeople.org/updates/620900.img

For guidance using an updates.img, consult https://fedoraproject.org/wiki/Anaconda/Updates
Comment 10 Julian Sikorski 2010-08-03 17:45:59 EDT
The 602900.img seems to solve the problem, I was able to install TC2 with it on a kvm guest running on F13 x86_64 host.
Comment 11 Jens Petersen 2010-08-03 20:58:59 EDT
Works past the storage backtrace for me too.
Comment 12 Brian Lane 2010-08-03 23:29:10 EDT
*** Bug 621029 has been marked as a duplicate of this bug. ***
Comment 13 Chris Lumens 2010-08-04 10:11:24 EDT
*** Bug 621101 has been marked as a duplicate of this bug. ***
Comment 14 James Laska 2010-08-04 12:13:54 EDT
Moving back to MODIFIED until the fix is available in a compose.
Comment 15 Kamil Páral 2010-08-05 06:41:51 EDT
*** Bug 621502 has been marked as a duplicate of this bug. ***
Comment 16 Amit Shah 2010-08-05 13:37:45 EDT
*** Bug 621629 has been marked as a duplicate of this bug. ***
Comment 17 Joachim Backes 2010-08-06 03:13:51 EDT
(In reply to comment #9)
> An updates is available with this fix at
> http://jlaska.fedorapeople.org/updates/620900.img
> 
> For guidance using an updates.img, consult
> https://fedoraproject.org/wiki/Anaconda/Updates    

I'va a bit trouble to use 620900.img: "https://fedoraproject.org/wiki/Anaconda/Updates" says that it should be an ext2 image, but using a file command I get "updates.img: gzip compressed data, from Unix, last modified: Tue Aug  3 21:08:45 2010, max compression",
ang trying gunzip produces an "ASCII cpio archive (SVR4 with no CRC)" as result.

Finally, I tried to install F14 after having dd'ed 62090.img to a floppy as described, but after having answered in anaconda the question for updates media to /dev/fd0, it is rejected by anaconda (no valid updates media). Seems that I'm doing something wrong.
Comment 18 Joachim Backes 2010-08-06 04:22:54 EDT
(In reply to comment #17)
> (In reply to comment #9)
> > An updates is available with this fix at
> > http://jlaska.fedorapeople.org/updates/620900.img
> > 
> > For guidance using an updates.img, consult
> > https://fedoraproject.org/wiki/Anaconda/Updates    
> 
> I'va a bit trouble to use 620900.img:
> "https://fedoraproject.org/wiki/Anaconda/Updates" says that it should be an
> ext2 image, but using a file command I get "updates.img: gzip compressed data,
> from Unix, last modified: Tue Aug  3 21:08:45 2010, max compression",
> ang trying gunzip produces an "ASCII cpio archive (SVR4 with no CRC)" as
> result.
> 
> Finally, I tried to install F14 after having dd'ed 62090.img to a floppy as
> described, but after having answered in anaconda the question for updates media
> to /dev/fd0, it is rejected by anaconda (no valid updates media). Seems that
> I'm doing something wrong.    

Sorry for the noise: I did not read completely the instructions for applying the anaconda patch (I read over that it only can be used together with "updates=http://..." or "updates=ftp://...".
Comment 19 Joachim Backes 2010-08-06 05:01:29 EDT
(In reply to comment #9)
> An updates is available with this fix at
> http://jlaska.fedorapeople.org/updates/620900.img
> 
> For guidance using an updates.img, consult
> https://fedoraproject.org/wiki/Anaconda/Updates    

Install proceeds now, but only in text mode (booting with "text" boot parameter). The installer hangs up if booting without "text" after the first graphical window appears (with the F13 logo), but it's impossible to activate the "next" button.

My video card:

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

I tried a vesa boot, but with the same negative results.
Comment 20 He Rui 2010-08-06 05:12:19 EDT
Verified fixed in anaconda 14.15 of F14-alpha-rc1-i386 images
Comment 21 James Laska 2010-08-06 08:53:30 EDT
(In reply to comment #19)
> (In reply to comment #9)
> > An updates is available with this fix at
> > http://jlaska.fedorapeople.org/updates/620900.img
> > 
> > For guidance using an updates.img, consult
> > https://fedoraproject.org/wiki/Anaconda/Updates    
> 
> Install proceeds now, but only in text mode (booting with "text" boot
> parameter). The installer hangs up if booting without "text" after the first
> graphical window appears (with the F13 logo), but it's impossible to activate
> the "next" button.
> 
> My video card:
> 
> 00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated
> Graphics Controller (rev 02)
> 
> I tried a vesa boot, but with the same negative results.    

Please record any graphical problems as a new bugzilla.  Also, you might find more information to help debug and provide information at http://fedoraproject.org/wiki/How_to_debug_Xorg_problems
Comment 22 James Laska 2010-08-06 08:53:59 EDT
(In reply to comment #20)
> Verified fixed in anaconda 14.15 of F14-alpha-rc1-i386 images    

Marking as VERIFIED, thanks rhe!
Comment 23 Joachim Backes 2010-08-06 10:00:09 EDT
(In reply to comment #21)
> (In reply to comment #19)
> > (In reply to comment #9)
> > > An updates is available with this fix at
> > > http://jlaska.fedorapeople.org/updates/620900.img
> > > 
> > > For guidance using an updates.img, consult
> > > https://fedoraproject.org/wiki/Anaconda/Updates    
> > 
> > Install proceeds now, but only in text mode (booting with "text" boot
> > parameter). The installer hangs up if booting without "text" after the first
> > graphical window appears (with the F13 logo), but it's impossible to activate
> > the "next" button.
> > 
> > My video card:
> > 
> > 00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated
> > Graphics Controller (rev 02)
> > 
> > I tried a vesa boot, but with the same negative results.    
> 
> Please record any graphical problems as a new bugzilla.  Also, you might find
> more information to help debug and provide information at
> http://fedoraproject.org/wiki/How_to_debug_Xorg_problems    

Got rid of all problems by usage of the F14-alpha-rc1-i386 install image (anaconda-14.15): I could install F14 in the graphical mode, no more X11 problems.
Comment 24 Adam Williamson 2010-08-09 12:12:07 EDT
can those who reported success with 14.15 please add feedback to the bodhi request?

https://admin.fedoraproject.org/updates/anaconda-14.15-1.fc14

it's a critpath update so it needs at least a +1 from a proven tester and +1 from anyone else.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 25 John Poelstra 2010-08-09 12:35:48 EDT
I'm no longer seeing this problem.
Comment 26 Adam Williamson 2010-08-11 16:07:08 EDT
14.15 has been pushed stable, and composes since TC2 have confirmed this issue is fixed. Closing.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Note You need to log in before you can comment on or make changes to this bug.