Bug 620971 - grubby recieved SIGSEGV! Backtrace (8)
grubby recieved SIGSEGV! Backtrace (8)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
13
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-03 17:30 EDT by Allen Hewes
Modified: 2010-08-17 01:43 EDT (History)
2 users (show)

See Also:
Fixed In Version: grubby-7.0.16-1.fc13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 01:43:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Allen Hewes 2010-08-03 17:30:35 EDT
Description of problem:
When running a yum update on a Fedora 13 x86_64 machine and a kernel update is present, grubby crashes.

Version-Release number of selected component (if applicable):
[allen@fedora-zero Documents]$ sudo rpm -qa| grep grubby
grubby-7.0.13-1.fc13.x86_64

[allen@fedora-zero Documents]$ uname -a
Linux fedora-zero 2.6.33.6-147.fc13.x86_64 #1 SMP Tue Jul 6 22:32:17 UTC 2010 x86_64 x86_64 x86_64 GNU/Linux

How reproducible:
run yum update with a kernel update.

Steps to Reproduce:
1.yum update with kernel update
2.
3.
  
Actual results:
  Installing     : kernel-2.6.33.6-147.2.4.fc13.x86_64                                  32/72 
grubby recieved SIGSEGV!  Backtrace (8):
/sbin/grubby[0x40805f]
/lib64/libc.so.6[0x3f51e32a20]
/lib64/libc.so.6[0x3f51f2783a]
/sbin/grubby[0x40695e]
/sbin/grubby[0x406ae3]
/sbin/grubby[0x407e58]
/lib64/libc.so.6(__libc_start_main+0xfd)[0x3f51e1ec5d]
/sbin/grubby[0x401709]

[allen@fedora-zero Documents]$ sudo cat /boot/grub/grub.conf 
# grub.conf generated by anaconda
#
# native panel vga=838, otherwise use vga=31a
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=0
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.33.6-147.fc13.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.33.6-147.fc13.x86_64 ro root=/dev/VolGroup00/LogVol00 rhgb quiet vga=795 SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us
	initrd /initramfs-2.6.33.6-147.fc13.x86_64.img


Expected result:
no grubby crashes and an updated grub.conf so that I can boot into updated kernel.

Additional info:
No brtfs here and / and /boot are LVM with ext4. This has been an issue for me for all of the kernel updates for Fedora 13; a kernel update has never worked.

I have to edit grub.conf with the updated kernel info.

[allen@fedora-zero Documents]$ sudo cat /etc/fstab
#
# /etc/fstab
# Created by anaconda on Wed Mar  4 14:16:47 2009
#
# Accessible filesystems, by reference, are maintained under '/dev/disk'
# See man pages fstab(5), findfs(8), mount(8) and/or vol_id(8) for more info
#
/dev/VolGroup00/LogVol00		/		ext4	defaults	1 1
UUID=0493ec34-6afe-4936-957f-1e1a2b35d890 /boot                   ext4    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
/dev/VolGroup00/LogVol01 swap                    swap    defaults        0 0


[allen@fedora-zero Documents]$ sudo blkid
/dev/mapper/VolGroup00-LogVol01: TYPE="swap" UUID="7ec8733d-f04a-4e65-8264-1d282b8698f9" 
/dev/VolGroup00/LogVol01: TYPE="swap" UUID="7ec8733d-f04a-4e65-8264-1d282b8698f9" 
/dev/sda1: LABEL="/boot" UUID="0493ec34-6afe-4936-957f-1e1a2b35d890" TYPE="ext4" 
/dev/sda2: UUID="QRRGLP-OBv8-VnZe-A5qN-R4Lu-2Fs7-eB8Tel" TYPE="LVM2_member" 
/dev/mapper/VolGroup00-LogVol00: UUID="8c35fac6-6684-4023-b612-e9585b56705a" TYPE="ext4" 
[allen@fedora-zero Documents]$
Comment 1 Brian Lane 2010-08-03 17:50:06 EDT
This is likely related to bug 592294
Comment 2 Brian Lane 2010-08-03 17:54:13 EDT
You could try installing the f14 build of grubby and see if that clears it up - https://koji.fedoraproject.org/koji/buildinfo?buildID=183459
Comment 3 Allen Hewes 2010-08-03 22:39:25 EDT
Hi Brian,

Yes, the grubby from f14 does appear to fix the issue.

I was not able to 'downgrade' the kernel via yum downgrade, but I did download the previous released kernel from koji and was able to coerce yum to install it;

sudo yum --nogpgcheck install kernel-2.6.33.6-147.fc13.x86_64.rpm

I received no grubby segfaults. My grub.conf was updated correctly;

[allen@fedora-zero Download]$ sudo cat /boot/grub/grub.conf 
# grub.conf generated by anaconda
#
# native panel vga=838, otherwise use vga=31a
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=0
splashimage=(hd0,0)/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.33.6-147.fc13.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.33.6-147.fc13.x86_64 ro root=/dev/VolGroup00/LogVol00 rhgb quiet vga=795 SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us
	initrd /initramfs-2.6.33.6-147.fc13.x86_64.img
title Fedora (2.6.33.6-147.2.4.fc13.x86_64)
	root (hd0,0)
	kernel /vmlinuz-2.6.33.6-147.2.4.fc13.x86_64 ro root=/dev/VolGroup00/LogVol00 rhgb quiet vga=795 SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 KEYTABLE=us
	initrd /initramfs-2.6.33.6-147.2.4.fc13.x86_64.img

I was also able to erase the previous kernel, but I never got any grubby segfaults on yum erase.

Also this runs OK;

[allen@fedora-zero Download]$ sudo grubby --default-kernel
/boot/vmlinuz-2.6.33.6-147.2.4.fc13.x86_64

Since I wasn't able to make my system identical to the state it was in when I was getting grubby segfaults, is the basic test of installing a kernel enough?

I suppose I could make it like it was and re-run yum-update then report back...

Thanks!
Comment 4 Allen Hewes 2010-08-03 22:40:50 EDT
Forgot to report on the grubby info;

I grabbed the source ball and built it on my f13 system.

[allen@fedora-zero Download]$ sudo rpm -qa| grep grubby
grubby-7.0.16-1.fc13.x86_64
Comment 5 Fedora Update System 2010-08-09 17:17:53 EDT
grubby-7.0.16-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/grubby-7.0.16-1.fc13
Comment 6 Fedora Update System 2010-08-10 17:43:42 EDT
grubby-7.0.16-1.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update grubby'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/grubby-7.0.16-1.fc13
Comment 7 Fedora Update System 2010-08-17 01:43:37 EDT
grubby-7.0.16-1.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.