This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 621027 - Graphical screen in anaconda shows F-13
Graphical screen in anaconda shows F-13
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fedora-logos (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
http://fedoraproject.org/wiki/Common_...
: CommonBugs
: 623008 (view as bug list)
Depends On:
Blocks: F14Beta/F14BetaBlocker
  Show dependency treegraph
 
Reported: 2010-08-03 22:59 EDT by He Rui
Modified: 2010-09-22 00:10 EDT (History)
10 users (show)

See Also:
Fixed In Version: fedora-logos-14.0.0-1.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-22 00:10:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Anaconda screen in F14 Alpha TC2 (58.39 KB, image/png)
2010-08-03 23:01 EDT, He Rui
no flags Details
'F14 development' splash (80.11 KB, image/png)
2010-08-04 14:08 EDT, Máirín Duffy
no flags Details
source for F14 development splash (25.48 KB, image/svg+xml)
2010-08-04 14:09 EDT, Máirín Duffy
no flags Details

  None (edit)
Description He Rui 2010-08-03 22:59:24 EDT
Description of problem:
See the attached screen.

Version-Release number of selected component (if applicable):
anaconda 14.14 in F-14 Alpha TC2

How reproducible:
100%
Comment 1 He Rui 2010-08-03 23:01:36 EDT
Created attachment 436421 [details]
Anaconda screen in F14 Alpha TC2
Comment 2 Tom "spot" Callaway 2010-08-04 09:00:03 EDT
I don't actually have F14 art yet. CC'ing Mo.
Comment 3 Máirín Duffy 2010-08-04 14:08:18 EDT
I think we won't have that until the Beta, but here's something that can be used in the meantime.
Comment 4 Máirín Duffy 2010-08-04 14:08:43 EDT
Created attachment 436615 [details]
'F14 development' splash
Comment 5 Máirín Duffy 2010-08-04 14:09:07 EDT
Created attachment 436616 [details]
source for F14 development splash
Comment 6 James Laska 2010-08-11 09:10:56 EDT
*** Bug 623008 has been marked as a duplicate of this bug. ***
Comment 7 James Laska 2010-08-11 09:12:42 EDT
We've not yet determined how to prioritize graphics for a release.  I'm adding
this to F14Beta since the graphics in the installer are fairly visible with the
# and we may at least want something temporary in place for the Beta (if not
permanent).  

Mo: The proposed graphics in comment#4 and comment#5 are not yet included in F14Alpha.  Should they be?  Will having the installer say "Fedora 13" be confusing enough to users?
Comment 8 James Laska 2010-08-11 09:47:41 EDT
Adding to F14Alpha ... I'd like additional input on addressing this for Alpha.
Comment 9 Jared Smith 2010-08-11 10:03:18 EDT
I'm fine with using the updated "F14 Development" splash screen that Máirín Duffy attached.  In fact, I think we should use that for Alphas going forward, and write a shell script to replace the version number in the SVG and regenerate the PNG -- that way, it's not an additional manual step every time to generate the graphic.
Comment 10 Adam Williamson 2010-08-11 12:18:37 EDT
I think it'd be nice to use it, but I don't think artwork issues should count as Alpha blockers. I'd expect this criterion to kick in at Beta or even Final, but not Alpha.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Adam Williamson 2010-08-11 16:05:46 EDT
For go/no-go meeting discussion: we do not yet have artwork release criteria in place, though we've been meaning to add them for a while. We should decide at which point we require new artwork to be in place. I'd say Beta or Final, not Alpha.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 Jens Petersen 2010-08-11 21:18:44 EDT
(In reply to comment #9)
> I'm fine with using the updated "F14 Development" splash screen that Máirín
> Duffy attached.  In fact, I think we should use that for Alphas going forward,
> and write a shell script to replace the version number in the SVG and
> regenerate the PNG

Yes, that would be good - it is confusing/misleading for people testing
that the installer splash still says "Fedora 13".
Comment 13 Adam Williamson 2010-08-11 21:32:13 EDT
Discussed at today's go/no-go meeting. We agreed this should not be a blocker, and the release criteria should only kick in artwork issues at Beta and Final. However, we did agree it would be best for Alpha releases to be identified as such in future. We may take a fix for this for RC4, if it's a simple fix and an update with the fix included is proposed in time for the planned RC4 compose tomorrow (2010-08-12).



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Adam Williamson 2010-08-11 21:32:31 EDT

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Máirín Duffy 2010-08-12 10:58:13 EDT
@James I think Adam is right in that this shouldn't be an Alpha blocker. I think alpha testers are sophisticated enough to not be thrown off too much by the graphic. 

That being said it's my bad the graphic in F13 included a version number at all. We try to freshen up the anaconda and firstboot graphics every release and traditionally we don't include version numbers in the installer at all. (Although FWIW I think it's a good idea to have a version number somewhere in the installer so folks know what they're actually installing)

We can change the design team guidelines & schedule so we create "development" artwork as well as specific-version artwork for every release if needed.
Comment 16 Máirín Duffy 2010-08-12 11:02:48 EDT
@Jared I think the graphic will have to be made custom every time - the graphic attached to this bug uses the F13 rocket artwork and I think it would get dated quickly. That being said there's no reason we couldn't have a standard / release-art-agnostic graphic for development releases that doesn't change besides the version number (via script as you suggested)
Comment 17 Adam Williamson 2010-08-12 13:22:54 EDT
I think that would be a great way to do it.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 18 Adam Williamson 2010-08-12 14:19:08 EDT
-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 19 Adam Williamson 2010-08-27 12:15:20 EDT
Discussed at today's blocker bug review meeting. The status of this one is undecided until we've consulted with the design team about what release criteria are desirable for artwork.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 20 Adam Williamson 2010-09-03 11:50:38 EDT
Note for today's blocker review - jlaska has the ball on the artwork criteria.
Comment 21 Adam Williamson 2010-09-03 12:34:09 EDT
Discussed at today's blocker review meeting. We tentatively accept this as a blocker based on Mo's outline of the design team's planned workflow here: we expect that the requirement for Beta will be for the proposed final wallpaper to be in place and all other artwork to be either completely unversioned or have the  correct version, having an incorrect version will not be acceptable for beta.
Comment 22 James Laska 2010-09-10 12:18:41 EDT
Spot: Mizmo indicates that her work on this issue is completed, and that new packages are needed that use the artwork attached to this bugzilla.  Are you able to rebuild fedora-logos by 2010-09-14 to include the updated artwork?
Comment 23 Tom "spot" Callaway 2010-09-10 17:12:47 EDT
I was under the impression that the art posted here was 'placeholder', rather than final.
Comment 24 James Laska 2010-09-13 07:59:46 EDT
(In reply to comment #23)
> I was under the impression that the art posted here was 'placeholder', rather
> than final.

Hi Spot, that matches my understanding.  The proposed artwork in this bug is a placeholder until the final artwork will be available for F-14-Final.  The work required here is to remove the '13' branded artwork from Fedora 14.  This will line up with the updated release criteria around Fedora artwork.  For details on the criteria, see ...

 * https://fedoraproject.org/wiki/Fedora_14_Alpha_Release_Criteria
 * https://fedoraproject.org/wiki/Fedora_14_Final_Release_Criteria
Comment 25 Fedora Update System 2010-09-13 15:59:07 EDT
fedora-logos-14.0.0-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/fedora-logos-14.0.0-1.fc14
Comment 26 Tom "spot" Callaway 2010-09-13 16:00:31 EDT
Note: It is unlikely that this update will hit "stable" before 2010-09-14, unless it is explicitly forced or manually tagged. Lemme know if you need me to do anything else.
Comment 27 Fedora Update System 2010-09-14 00:30:01 EDT
fedora-logos-14.0.0-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fedora-logos'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/fedora-logos-14.0.0-1.fc14
Comment 28 James Laska 2010-09-14 07:30:27 EDT
(In reply to comment #26)
> Note: It is unlikely that this update will hit "stable" before 2010-09-14,
> unless it is explicitly forced or manually tagged. Lemme know if you need me to
> do anything else.

Thanks spot, I've made an update in the appropriate rel-eng F-14-Beta tickets to be sure to include this update even if not yet in stable.
Comment 29 James Laska 2010-09-14 12:12:59 EDT
Using the updated fedora-logos package, I can confirm this specific issue is resolved.  When testing, Fedora 14 graphics are properly displayed ....

 * running anaconda (tested with liveinst)
 * grub background, when booting installed system
 * firstboot, properly themed for f14

One issue, also observed by adamw, is that the syslinux/isolinux background doesn't properly display.  Instead, only a gray background is visible.  I'm uncertain whether this is related to the updated fedora-logos package, or something else.
Comment 30 James Laska 2010-09-14 15:58:08 EDT
I just discovered that the live image I created had an incorrect syslinux.cfg that wasn't using the splash.png provided by the updated fedora-logos package (see http://fpaste.org/gymS/).  I've corrected that and can now confirm that the syslinux graphics appear correctly.

Will move this to VERIFIED once we have official ISO builds that contain the fix
Comment 31 Adam Williamson 2010-09-14 16:24:56 EDT
but where did that syslinux.cfg come from?
Comment 32 Adam Williamson 2010-09-14 16:40:15 EDT
ah, now I see the point of James' comment: the fact that the problem is in syslinux.cfg indicates that livecd-tools is the culprit, and fedora-logos is fine. Agreed, in that case.
Comment 33 James Laska 2010-09-15 09:30:15 EDT
Tested and confirmed that images created using livecd-tools-034-7.fc14 have a proper grub/syslinux themed background.  

I believe we can consider this VERIFIED.  However, I'll wait for official media that includes this fix before marking VERIFIED.
Comment 34 Adam Williamson 2010-09-18 04:43:10 EDT
It seems like this was left off RC1. The initial anaconda screen when booting from RC1 netinst.iso shows F13 art. :/
Comment 35 John Watzke 2010-09-18 23:19:22 EDT
This works in RC2 (at least the i386 netinst image)
Comment 36 Adam Williamson 2010-09-19 02:51:38 EDT
Live images are good too, and the new desktop background is in. Marking VERIFIED. Can someone please submit the update to stable?
Comment 37 Fedora Update System 2010-09-22 00:10:53 EDT
fedora-logos-14.0.0-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.