Bug 621119 - Fail to install in anaconda in text mode
Fail to install in anaconda in text mode
Status: CLOSED DUPLICATE of bug 621685
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-04 06:21 EDT by MingtaoNiu
Modified: 2010-08-06 06:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-06 06:45:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description MingtaoNiu 2010-08-04 06:21:24 EDT
Description of problem:
When installing in text mode, failed to install in anaconda

Version-Release number of selected component (if applicable):

anaconda 14.14
F14-alpha-tc2

How reproducible:
100%

Steps to Reproduce:
1.Boot the installation passing the command line argument text

  
Actual results:

<report xmlns="http://www.redhat.com/gss/strata"><binding name="localhash">0768a7902f8fec5cd990f7cdc419d77b1b47f6238df3aeabb4288220f426c09c</binding><binding name="product" /><binding name="description">The following was filed automatically by anaconda:
anaconda 14.14 exception report
Traceback (most recent call first):
  File "/tmp/updates/pyanaconda/upgrade.py", line 86, in findRootParts
    oldInstalls += " on ".join(info)
  File "/tmp/updates/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/tmp/updates/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/tmp/updates/pyanaconda/text.py", line 510, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 887, in &lt;module&gt;
    anaconda.intf.run(anaconda)
TypeError: sequence item 0: expected string, NoneType found
</binding><binding fileName="/tmp/anaconda-tb-3d0kgf" name="pythonUnhandledException" type="text">anaconda 14.14 exception report
Traceback (most recent call first):
  File "/tmp/updates/pyanaconda/upgrade.py", line 86, in findRootParts
    oldInstalls += " on ".join(info)
  File "/tmp/updates/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/tmp/updates/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/tmp/updates/pyanaconda/text.py", line 510, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 887, in &lt;module&gt;
    anaconda.intf.run(anaconda)
TypeError: sequence item 0: expected string, NoneType found

Local variables in innermost frame:
info: (None, None, 'VolGroup-lv_root')
oldInstalls:
anaconda: &lt;pyanaconda.Anaconda object at 0xb71c556c&gt;
notUpgradable: [(None, None, 'VolGroup-lv_root')]


Expected results:
   1.  Anaconda uses text-mode for installation
   2. Anaconda completes successfully
   3. Reboot successfully into installed system 

Additional info:
Comment 1 Chris Lumens 2010-08-04 10:08:38 EDT
Please attach the complete traceback in non-xml format to this bug so we can get some better context on what's going on here.  Also, what do you have previously installed?
Comment 2 Radek Vykydal 2010-08-06 06:45:46 EDT

*** This bug has been marked as a duplicate of bug 621685 ***

Note You need to log in before you can comment on or make changes to this bug.