Bug 621685 - TypeError: sequence item 0: expected string, NoneType found
TypeError: sequence item 0: expected string, NoneType found
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
anaconda_trace_hash:dd5d9121b3d09d62c...
: CommonBugs
: 621100 621119 624318 626993 630254 630291 (view as bug list)
Depends On:
Blocks: F14Blocker/F14FinalBlocker
  Show dependency treegraph
 
Reported: 2010-08-05 15:52 EDT by James Laska
Modified: 2013-09-02 02:50 EDT (History)
28 users (show)

See Also:
Fixed In Version: anaconda-14.16-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-01 12:43:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (229.00 KB, text/plain)
2010-08-05 15:52 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (175.76 KB, text/plain)
2010-08-06 09:02 EDT, AdiRusF
no flags Details
Attached traceback automatically from anaconda. (117.18 KB, text/plain)
2010-08-11 03:34 EDT, He Rui
no flags Details
Attached traceback automatically from anaconda. (96.63 KB, text/plain)
2010-08-11 08:48 EDT, Michal Schmidt
no flags Details
Attached traceback automatically from anaconda. (230.22 KB, text/plain)
2010-08-14 09:35 EDT, Flóki Pálsson
no flags Details
Attached traceback automatically from anaconda. (173.72 KB, text/plain)
2010-08-14 23:40 EDT, David Timms
no flags Details
Attached traceback automatically from anaconda. (201.93 KB, text/plain)
2010-08-19 08:31 EDT, cornel panceac
no flags Details
Attached traceback automatically from anaconda. (200.67 KB, text/plain)
2010-08-19 08:38 EDT, cornel panceac
no flags Details
Attached traceback automatically from anaconda. (200.66 KB, text/plain)
2010-08-20 02:00 EDT, cornel panceac
no flags Details
Attached traceback automatically from anaconda. (201.16 KB, text/plain)
2010-08-20 02:04 EDT, cornel panceac
no flags Details
Attached traceback automatically from anaconda. (241.26 KB, text/plain)
2010-08-23 04:49 EDT, Geert Jansen
no flags Details
Attached traceback automatically from anaconda. (198.37 KB, text/plain)
2010-08-23 05:19 EDT, Mike Chambers
no flags Details
Attached traceback automatically from anaconda. (196.83 KB, text/plain)
2010-08-23 18:34 EDT, Mike Chambers
no flags Details
Attached traceback automatically from anaconda. (156.66 KB, text/plain)
2010-08-24 09:15 EDT, Lawrence Graves
no flags Details
Attached traceback automatically from anaconda. (143.17 KB, text/plain)
2010-08-25 10:10 EDT, Sigitas Mockus
no flags Details
Attached traceback automatically from anaconda. (113.71 KB, text/plain)
2010-08-25 12:54 EDT, Aioanei Rares
no flags Details
Attached traceback automatically from anaconda. (127.57 KB, text/plain)
2010-08-26 14:39 EDT, Bill Pemberton
no flags Details
Attached traceback automatically from anaconda. (218.27 KB, text/plain)
2010-08-29 09:49 EDT, Todd
no flags Details
Attached traceback automatically from anaconda. (156.36 KB, text/plain)
2010-08-31 16:32 EDT, Lawrence Graves
no flags Details
Attached traceback automatically from anaconda. (130.80 KB, text/plain)
2010-09-03 02:12 EDT, Ben Lambrechts
no flags Details
Attached traceback automatically from anaconda. (130.75 KB, text/plain)
2010-09-03 02:15 EDT, Ben Lambrechts
no flags Details
Attached traceback automatically from anaconda. (156.54 KB, text/plain)
2010-09-04 12:23 EDT, Lawrence Graves
no flags Details
Attached traceback automatically from anaconda. (145.26 KB, text/plain)
2010-09-09 00:49 EDT, Jan Cramer
no flags Details
Attached traceback automatically from anaconda. (197.14 KB, text/plain)
2010-09-09 15:23 EDT, Thomas Woerner
no flags Details
Attached traceback automatically from anaconda. (96.95 KB, text/plain)
2010-09-10 08:46 EDT, Steve Tyler
no flags Details
Attached traceback automatically from anaconda. (190.27 KB, text/plain)
2010-09-17 05:11 EDT, David Bernier
no flags Details
Attached traceback automatically from anaconda. (190.27 KB, text/plain)
2010-09-17 05:13 EDT, David Bernier
no flags Details
Attached traceback automatically from anaconda. (158.82 KB, text/plain)
2010-09-29 21:16 EDT, Tom Gutwin
no flags Details
Attached traceback automatically from anaconda. (132.85 KB, text/plain)
2010-12-19 20:20 EST, goldlyron
no flags Details
Attached traceback automatically from anaconda. (132.85 KB, text/plain)
2010-12-19 20:21 EST, goldlyron
no flags Details
Attached traceback automatically from anaconda. (132.47 KB, text/plain)
2010-12-19 20:26 EST, goldlyron
no flags Details

  None (edit)
Description James Laska 2010-08-05 15:52:03 EDT
The following was filed automatically by anaconda:
anaconda 14.14 exception report
Traceback (most recent call first):
  File "/tmp/updates/pyanaconda/upgrade.py", line 86, in findRootParts
    oldInstalls += " on ".join(info)
  File "/tmp/updates/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/tmp/updates/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/tmp/updates/pyanaconda/gui.py", line 1262, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/tmp/updates/pyanaconda/gui.py", line 1175, in nextClicked
    self.setScreen ()
TypeError: sequence item 0: expected string, NoneType found
Comment 1 James Laska 2010-08-05 15:52:09 EDT
Created attachment 436963 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2010-08-05 16:24:23 EDT
Testing F-14-Alpha TC#2 with an updates.img that pulls in all recent anaconda changes, hits the above traceback.  This appears to be the result of installing to system on top of a previously incomplete install.  Talking to clumens, we agreed this likely won't impact a significant number of F14Alpha users considering the exceptional conditions around the issue.  An updates.img will be available for those users.
Comment 3 Radek Vykydal 2010-08-06 06:45:46 EDT
*** Bug 621119 has been marked as a duplicate of this bug. ***
Comment 4 AdiRusF 2010-08-06 09:02:45 EDT
Created attachment 437140 [details]
Attached traceback automatically from anaconda.
Comment 5 Brian Lane 2010-08-06 13:06:28 EDT
*** Bug 621100 has been marked as a duplicate of this bug. ***
Comment 6 He Rui 2010-08-11 03:34:39 EDT
Created attachment 438098 [details]
Attached traceback automatically from anaconda.
Comment 7 He Rui 2010-08-11 03:36:51 EDT
After the system encountered bug#590640 with unfinished install, this issue can be reproduced on it.
Comment 8 Michal Schmidt 2010-08-11 08:48:21 EDT
Created attachment 438178 [details]
Attached traceback automatically from anaconda.
Comment 9 James Laska 2010-08-11 14:07:12 EDT
When documenting this issue for F-14-Alpha CommonBugs, one can create a updates.img that includes the change referenced at http://git.fedorahosted.org/git/?p=anaconda.git;a=commitdiff;h=1cf0ab74176b8203ffb590c47c508716fb4a5727
Comment 10 Flóki Pálsson 2010-08-14 09:35:41 EDT
Created an attachment (id=438794)
Attached traceback automatically from anaconda.
Comment 11 David Timms 2010-08-14 23:40:49 EDT
Created an attachment (id=438809)
Attached traceback automatically from anaconda.
Comment 12 David Timms 2010-08-14 23:53:46 EDT
(In reply to comment #11)
> Created an attachment (id=438809)
> Attached traceback automatically from anaconda.
The QEMU storage in this case was screwed up by problem in F14alphaRC2 (which I forgot about). It seems such a situation could be more nicely explained to user.
Comment 13 Radek Vykydal 2010-08-16 05:57:02 EDT
*** Bug 624318 has been marked as a duplicate of this bug. ***
Comment 14 cornel panceac 2010-08-19 08:31:12 EDT
Created an attachment (id=439666)
Attached traceback automatically from anaconda.
Comment 15 cornel panceac 2010-08-19 08:38:58 EDT
Created an attachment (id=439670)
Attached traceback automatically from anaconda.
Comment 16 James Laska 2010-08-19 08:52:47 EDT
A workaround is to manually remove the incomplete disk configuration using parted or 'dd'.  Alternatively, an updates image is available for test at http://jlaska.fedorapeople.org/updates/621685.img
Comment 17 cornel panceac 2010-08-20 02:00:29 EDT
Created an attachment (id=439867)
Attached traceback automatically from anaconda.
Comment 18 cornel panceac 2010-08-20 02:04:59 EDT
Created an attachment (id=439868)
Attached traceback automatically from anaconda.
Comment 19 cornel panceac 2010-08-20 02:18:14 EDT
i get over it by removing the existing lvm. (while leaving alone the /boot partition). affects both rc3 and rc4.
Comment 20 Geert Jansen 2010-08-23 04:49:39 EDT
Created an attachment (id=440323)
Attached traceback automatically from anaconda.
Comment 21 Mike Chambers 2010-08-23 05:19:02 EDT
Created an attachment (id=440340)
Attached traceback automatically from anaconda.
Comment 22 Mike Chambers 2010-08-23 18:34:12 EDT
Created an attachment (id=440515)
Attached traceback automatically from anaconda.
Comment 23 Lawrence Graves 2010-08-24 09:15:16 EDT
Created an attachment (id=440651)
Attached traceback automatically from anaconda.
Comment 24 Chris Lumens 2010-08-24 16:07:52 EDT
*** Bug 626993 has been marked as a duplicate of this bug. ***
Comment 25 Sigitas Mockus 2010-08-25 10:10:15 EDT
Created an attachment (id=440952)
Attached traceback automatically from anaconda.
Comment 26 Aioanei Rares 2010-08-25 12:54:43 EDT
Created an attachment (id=440995)
Attached traceback automatically from anaconda.
Comment 27 Bill Pemberton 2010-08-26 14:39:43 EDT
Created an attachment (id=441298)
Attached traceback automatically from anaconda.
Comment 28 Adam Williamson 2010-08-27 12:24:47 EDT
Discussed at today's blocker review meeting. We don't have an exact criterion to cover it, but 'The installer must be able to create and install to any workable partition layout using any file system offered in a default installer configuration, LVM, software, hardware or BIOS RAID, or combination of the above'  (final) is close enough. This should be fixed now anyway so we aren't too worried. We may propose a new criterion to cover handling existing disk contents.
Comment 29 Todd 2010-08-29 09:49:24 EDT
Created an attachment (id=441790)
Attached traceback automatically from anaconda.
Comment 30 Lawrence Graves 2010-08-31 16:32:22 EDT
Created an attachment (id=442272)
Attached traceback automatically from anaconda.
Comment 31 Ben Lambrechts 2010-09-03 02:12:17 EDT
Created an attachment (id=442800)
Attached traceback automatically from anaconda.
Comment 32 Ben Lambrechts 2010-09-03 02:15:18 EDT
Created an attachment (id=442801)
Attached traceback automatically from anaconda.
Comment 33 Phil Cole 2010-09-04 12:11:12 EDT
*** Bug 630254 has been marked as a duplicate of this bug. ***
Comment 34 Lawrence Graves 2010-09-04 12:23:20 EDT
Created an attachment (id=443067)
Attached traceback automatically from anaconda.
Comment 35 Chris Lumens 2010-09-04 17:22:01 EDT
*** Bug 630291 has been marked as a duplicate of this bug. ***
Comment 36 Jan Cramer 2010-09-09 00:49:09 EDT
Created an attachment (id=446135)
Attached traceback automatically from anaconda.
Comment 37 Thomas Woerner 2010-09-09 15:23:35 EDT
Created an attachment (id=446353)
Attached traceback automatically from anaconda.
Comment 38 Steve Tyler 2010-09-10 08:46:41 EDT
Created an attachment (id=446505)
Attached traceback automatically from anaconda.
Comment 39 Thomas Woerner 2010-09-10 08:59:22 EDT
Clearing the some 100 MB from the start of the partition I used for an aborted installation before solved this for me.
Comment 40 Steve Tyler 2010-09-10 09:22:32 EDT
(In reply to comment #38)
> Created an attachment (id=446505)
> Attached traceback automatically from anaconda.

This occurred when I restarted an install after aborting the previous one
shortly after packages were being downloaded. IIRC, I aborted with
ctrl-alt-del. Partitioning was done with custom layout and had one ext4 and one
swap.

After booting in rescue mode:
blkid can recognize both partitions and reports their UUIDs.
e2fsck does not report any problems with the ext4 partition.
The partition can be mounted and there are directories and files in it.

I recovered by deleting all partitions with fdisk while in rescue mode.

$ qemu-kvm -cdrom Fedora-14-Alpha-x86_64-netinst.iso -m 512m -hda foobar.img
-boot menu=on

$ qemu-img info foobar.img 
image: foobar.img
file format: raw
virtual size: 3.0G (3221225472 bytes)
disk size: 357M
Comment 41 David Bernier 2010-09-17 05:11:19 EDT
Created attachment 447950 [details]
Attached traceback automatically from anaconda.
Comment 42 David Bernier 2010-09-17 05:13:17 EDT
Created attachment 447952 [details]
Attached traceback automatically from anaconda.
Comment 43 James Laska 2010-09-27 15:13:47 EDT
This issue was not encountered while testing F-14-Beta.  Marking as VERIFIED.
Comment 44 Tom Gutwin 2010-09-29 21:16:41 EDT
Created attachment 450633 [details]
Attached traceback automatically from anaconda.
Comment 45 Tom Gutwin 2010-09-29 21:24:47 EDT
Fedora 14 beta i386 version still exists.

I had a 2nd primary partition with F9 on it that I was going to blow away anyway.
I will try to fdisk it away and try again.
Comment 46 Brian Lane 2010-09-30 00:25:58 EDT
That isn't F14 Beta. your report says anaconda 14.15 and Beta has 14.17 in it.
Comment 47 Adam Williamson 2010-10-01 12:43:36 EDT
we can close this, 14.17 has been pushed stable.
Comment 48 goldlyron 2010-12-19 20:20:47 EST
Created attachment 469653 [details]
Attached traceback automatically from anaconda.
Comment 49 goldlyron 2010-12-19 20:21:35 EST
Created attachment 469654 [details]
Attached traceback automatically from anaconda.
Comment 50 goldlyron 2010-12-19 20:26:23 EST
Created attachment 469655 [details]
Attached traceback automatically from anaconda.
Comment 51 Manfred Blankenfeld 2013-06-17 00:40:25 EDT
Creating of livecds FC19 with spin-kickstarts ends with this output:

[code]
Traceback (most recent call last):
File "/bin/livecd-creator", line 237, in <module>
sys.exit(main())
File "/bin/livecd-creator", lin 218, in main
creator.install()
File "/usr/lib/python2.7/site-packages/imgcreate/creator.py", line 655 in install
ayum.runInstall()
File "/usr/lib/python2.7/site-packages/imgcreate/yuminst.py", line 220, in runInstall
raise CreateError("Dependency check failed : %s" % "\n".join(deps))
TypeError: sequence item 0: expected string, tuple found
[/code]

2013-06-17

Manfred Blankenfeld
Comment 52 Brian Lane 2013-06-17 13:01:17 EDT
(In reply to Manfred Blankenfeld from comment #51)
> Creating of livecds FC19 with spin-kickstarts ends with this output:
> 
> [code]
> Traceback (most recent call last):
> File "/bin/livecd-creator", line 237, in <module>
> sys.exit(main())
> File "/bin/livecd-creator", lin 218, in main
> creator.install()
> File "/usr/lib/python2.7/site-packages/imgcreate/creator.py", line 655 in
> install
> ayum.runInstall()
> File "/usr/lib/python2.7/site-packages/imgcreate/yuminst.py", line 220, in
> runInstall
> raise CreateError("Dependency check failed : %s" % "\n".join(deps))
> TypeError: sequence item 0: expected string, tuple found
> [/code]
> 
> 2013-06-17
> 
> Manfred Blankenfeld

Please open a new bug for this against f19, also include the version of livecd-creator and yum that you have installed.

Note You need to log in before you can comment on or make changes to this bug.