Bug 621502 - TypeError: argument 2 to map() must support iteration
Summary: TypeError: argument 2 to map() must support iteration
Keywords:
Status: CLOSED DUPLICATE of bug 620900
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 14
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F14Alpha, F14AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2010-08-05 10:10 UTC by Kamil Páral
Modified: 2010-08-05 10:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-05 10:41:51 UTC


Attachments (Terms of Use)
anaconda logs (310.00 KB, application/x-tar)
2010-08-05 10:10 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2010-08-05 10:10:56 UTC
Created attachment 436791 [details]
anaconda logs

Description of problem:
I received this error when trying to install F14 Alpha TC2:

05:28:50,703 CRIT anaconda: anaconda 14.14 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 183, in storageComplete
    anaconda.storage.fsset)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1262, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1175, in nextClicked
    self.setScreen ()
TypeError: argument 2 to map() must support iteration

Version-Release number of selected component (if applicable):
anaconda 14.14

How reproducible:


Steps to Reproduce:
1. Do default install of F14 Alpha TC2 DVD x86_64.
2. Select whole disk as installation type.
3. The exception occurs when going to the next dialog.
  
Actual results:


Expected results:


Additional info:

Comment 1 Kamil Páral 2010-08-05 10:12:25 UTC
Reproduced in 2 of 2 attempts.

Comment 2 Kamil Páral 2010-08-05 10:12:56 UTC
This bug seems very similar to bug 619659.

Comment 3 Kamil Páral 2010-08-05 10:41:51 UTC

*** This bug has been marked as a duplicate of bug 620900 ***


Note You need to log in before you can comment on or make changes to this bug.