Bug 621686 - mount.cifs(8) man page missing nounix option
mount.cifs(8) man page missing nounix option
Status: CLOSED DUPLICATE of bug 459842
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba3x (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Jeff Layton
qe-baseos-daemons
: Reopened
Depends On:
Blocks: 621926 701979
  Show dependency treegraph
 
Reported: 2010-08-05 15:52 EDT by Jeff Bastian
Modified: 2014-06-18 03:40 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 621926 (view as bug list)
Environment:
Last Closed: 2011-02-10 13:21:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Bastian 2010-08-05 15:52:44 EDT
Description of problem:
The mount.cifs command includes a 'nounix' mount option:
    # /sbin/mount.cifs --help
    ...
    Less commonly used options:
    ...
            directio,nounix,cifsacl,sec=<authentication mechanism>,sign
                     ^^^^^^

However, the mount.cifs(8) man page does not describe this option.

Newer man pages include this description:
       nounix
           Disable the CIFS Unix Extensions for this mount. This can be useful
           in order to turn off multiple settings at once. This includes POSIX
           acls, POSIX locks, POSIX paths, symlink support and retrieving
           uids/gids/mode from the server. This can also be useful to work
           around a bug in a server that supports Unix Extensions.

           See section INODE NUMBERS for more information.

Please update the mount.cifs(8) man page.


Version-Release number of selected component (if applicable):
samba3x-client-3.3.8-0.52.el5_5

How reproducible:
every time

Steps to Reproduce:
1. /sbin/mount.cifs --help | grep --color nounix
2. man 8 mount.cifs
3. search for nounix
  
Actual results:
no description of nounix mount option

Expected results:
documentation for nounix mount option

Additional info:
Comment 1 RHEL Product and Program Management 2011-01-11 15:37:43 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2011-01-12 10:07:59 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 4 Jeff Layton 2011-02-10 07:37:03 EST
It looks like the current samba3x already has this manpage section. Closing this as a duplicate of bug 459842 as that was the one where samba3x got rebased.

*** This bug has been marked as a duplicate of bug 459842 ***
Comment 5 Julio Entrena Perez 2011-02-10 13:13:58 EST
Hi Jeff,

Customer is using samba instead of samba3x. The 'nounix' option is available in samba-client (no samba3x-client) mount.cifs, and they would like to see all available options documented in the mount.cifs man page:

[root@rhel5564b ~]# man mount.cifs | grep nounix | wc -l
0

[root@rhel5564b ~]# rpm -q --whatprovides /usr/share/man/man8/mount.cifs.8.gz
samba-client-3.0.33-3.29.el5_5.1

[root@rhel5564b ~]# yum update samba-client
Loaded plugins: rhnplugin, security
Skipping security plugin, no data
Setting up Update Process
No Packages marked for Update
Comment 6 Jeff Layton 2011-02-10 13:21:14 EST
Julio, I think you want to attach your customer's case to bug 621926. This one is against samba3x which is already fixed.

*** This bug has been marked as a duplicate of bug 459842 ***

Note You need to log in before you can comment on or make changes to this bug.