Bug 621926 - mount.cifs(8) man page missing nounix option
mount.cifs(8) man page missing nounix option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
5.5
All Linux
low Severity medium
: rc
: ---
Assigned To: Ivana Varekova
: ManPageChange
Depends On: 621686
Blocks: 701979
  Show dependency treegraph
 
Reported: 2010-08-06 10:05 EDT by Jeff Bastian
Modified: 2011-07-21 03:36 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The path to the cifs.upcall program has been corrected in the cifs.upcall(8) manual page, and the nounix option description has been added to the mount.cifs(8) manual page.
Story Points: ---
Clone Of: 621686
: 701979 (view as bug list)
Environment:
Last Closed: 2011-07-21 03:36:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch -- add nounix section and fix path to cifs.upcall (1.90 KB, patch)
2011-01-10 11:09 EST, Jeff Layton
no flags Details | Diff

  None (edit)
Description Jeff Bastian 2010-08-06 10:05:17 EDT
+++ This bug was initially created as a clone of Bug #621686 +++

Description of problem:
RHEL 5.2 updated the CIFS kernel code to 1.50 (see bug 417961).  This update added a 'nounix' mount option, however, it is not documented in the 'mount.cifs --help' output nor in the mount.cifs(8) man page.

The mount.cifs command should list 'nounix' in the options:
    # /sbin/mount.cifs --help
    ...
    Less commonly used options:
    ...
            directio,nounix,cifsacl,sec=<authentication mechanism>,sign
                     ^^^^^^

And newer man pages include this description:
       nounix
           Disable the CIFS Unix Extensions for this mount. This can be useful
           in order to turn off multiple settings at once. This includes POSIX
           acls, POSIX locks, POSIX paths, symlink support and retrieving
           uids/gids/mode from the server. This can also be useful to work
           around a bug in a server that supports Unix Extensions.

           See section INODE NUMBERS for more information.

Please update the 'mount.cifs --help' output and the mount.cifs(8) man page.


Version-Release number of selected component (if applicable):
samba-client-3.0.33-3.29.el5_5

How reproducible:
every time

Steps to Reproduce:
1. /sbin/mount.cifs --help | grep nounix
2. man 8 mount.cifs
3. search for nounix
  
Actual results:
no description of nounix mount option

Expected results:
documentation for nounix mount option

Additional info:
Comment 1 Jeff Layton 2011-01-10 11:09:03 EST
Created attachment 472631 [details]
patch -- add nounix section and fix path to cifs.upcall

Patch to fix manpages. I left off the INODE NUMBERS section since RHEL5's behavior is different in this regard than RHEL6/upstream.
Comment 2 RHEL Product and Program Management 2011-01-11 15:37:29 EST
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 3 RHEL Product and Program Management 2011-01-12 10:07:50 EST
This request was erroneously denied for the current release of
Red Hat Enterprise Linux.  The error has been fixed and this
request has been re-proposed for the current release.
Comment 9 Miroslav Svoboda 2011-07-15 12:29:49 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The path to the cifs.upcall program has been corrected in the cifs.upcall(8) manual page, and the nounix option description has been added to the mount.cifs(8) manual page.
Comment 10 errata-xmlrpc 2011-07-21 03:36:31 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-1009.html

Note You need to log in before you can comment on or make changes to this bug.