Bug 621697 - Systemd does not complete boot after yum upgrade from F13 to Rawhide
Systemd does not complete boot after yum upgrade from F13 to Rawhide
Status: CLOSED DUPLICATE of bug 621200
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-05 16:45 EDT by W. Michael Petullo
Modified: 2010-08-05 18:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-05 18:13:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description W. Michael Petullo 2010-08-05 16:45:52 EDT
Description of problem:
Systemd does not complete boot after yum upgrade from F13 to Rawhide.

Version-Release number of selected component (if applicable):
systemd-sysvinit-5-2.fc15.x86_64

How reproducible:
Every time

Steps to Reproduce:
Try to boot
  
Actual results:
Boot hangs after starting all services (between last service and mingetty / X, I think). I am still trying to figure out how systemd boots, so I have not yet been able to pinpoint where in the process the system hangs.

Expected results:
System should boot

Additional info:
Adding init=/sbin/upstart results in the system booting fine.

Also, the following works:
1. Boot into single user mode
2. /etc/rc 5
3. gdm
Comment 1 Michal Schmidt 2010-08-05 17:51:22 EDT
I think you'll find that the post-install script of systemd-units-5-2 failed to enable the necessary services (getty, prefdm, ...) because systemctl segfaulted (bug 621200).

Use "yum history info systemd-units" to see if there was any unusual output from the scriptlet.
Comment 2 W. Michael Petullo 2010-08-05 18:13:46 EDT
Confirmed as the effects of bug #621200.

*** This bug has been marked as a duplicate of bug 621200 ***

Note You need to log in before you can comment on or make changes to this bug.