Bug 621200 - [abrt] systemd-units-5-2.fc15: selabel_lookup_common: Process /bin/systemctl was killed by signal 11 (SIGSEGV)
Summary: [abrt] systemd-units-5-2.fc15: selabel_lookup_common: Process /bin/systemctl ...
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: systemd   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c1d4a4d6aeb09eb75045fe65db4...
Keywords: Reopened
: 621584 621658 621681 621697 622475 623433 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-04 14:05 UTC by Jeff Layton
Modified: 2014-06-18 07:40 UTC (History)
16 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-11 19:36:11 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (14.55 KB, text/plain)
2010-08-04 14:05 UTC, Jeff Layton
no flags Details
patch which allows it to not segfault (427 bytes, patch)
2010-08-04 14:38 UTC, Eric Paris
no flags Details | Diff
Here is my patch. You want to execute the fini or valgrind will complain about memmory leak (538 bytes, text/plain)
2010-08-05 17:16 UTC, Daniel Walsh
no flags Details

Description Jeff Layton 2010-08-04 14:05:52 UTC
abrt version: 1.1.10
architecture: x86_64
Attached file: backtrace
cmdline: systemctl enable graphical.target
component: systemd
crash_function: selabel_lookup_common
executable: /bin/systemctl
kernel: 2.6.35-0.57.rc6.git5.fc15.x86_64
package: systemd-units-5-2.fc15
rating: 4
reason: Process /bin/systemctl was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Rawhide)
time: 1280930023
uid: 0

comment
-----
Nothing special. Started occurring after I updated systemd and tried to get it into a semi-working state.

How to reproduce
-----
As root, I ran:

systemctl enable graphical.target

Comment 1 Jeff Layton 2010-08-04 14:05:55 UTC
Created attachment 436547 [details]
File: backtrace

Comment 2 Michal Schmidt 2010-08-04 14:31:27 UTC
The SELinux handle (label_hnd) was NULL. systemctl does not call label_init()...

Comment 3 Eric Paris 2010-08-04 14:38:36 UTC
Created attachment 436563 [details]
patch which allows it to not segfault

Comment 4 James Laska 2010-08-04 16:34:56 UTC
Jeff or Eric: What's the fallout of this issue?  Does it prevent boot, or cause spewage during the boot process?

Comment 5 Jeff Layton 2010-08-04 16:44:09 UTC
Neither -- I saw it spew the message while patching the machine, and again when I tried to follow the directions here to see if it would fix my systemd problems:

http://lists.fedoraproject.org/pipermail/devel/2010-August/140294.html

(hint: it didn't)

Comment 6 Lennart Poettering 2010-08-05 11:40:50 UTC
A different patch has been merged upstream. Will upload a fixed version to f14 today.

Eric, thanks for your patch!

Comment 7 Michal Schmidt 2010-08-05 15:36:14 UTC
*** Bug 621584 has been marked as a duplicate of this bug. ***

Comment 8 Daniel Walsh 2010-08-05 17:16:25 UTC
Created attachment 436914 [details]
Here is my patch.  You want to execute the fini or valgrind will complain about memmory leak

Comment 9 Michal Schmidt 2010-08-05 19:52:32 UTC
*** Bug 621658 has been marked as a duplicate of this bug. ***

Comment 10 Michal Schmidt 2010-08-05 20:06:12 UTC
*** Bug 621681 has been marked as a duplicate of this bug. ***

Comment 11 Adam Williamson 2010-08-05 20:57:00 UTC
we need this to be open to track getting it fixed for the f14 alpha compose; we need a build that fixes this before we can go ahead with the RC.

Comment 12 Adam Williamson 2010-08-05 21:43:03 UTC
scratch that, i just tested and it doesn't prevent boot with 5-2.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 13 Michal Schmidt 2010-08-05 21:57:04 UTC
(In reply to comment #12)
> scratch that, i just tested and it doesn't prevent boot with 5-2.

I suppose if you already had systemd-4 installed and working, then upgrading to systemd-5-2 will not break you boot.

But a segfaulting systemctl must be pretty bad for new installs, because the tool is used to enable essential services in postinstall scriptlets of systemd-units and dbus.

Comment 14 Adam Williamson 2010-08-05 22:09:15 UTC
do we know exactly what operation triggered the systemctl fail?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 15 W. Michael Petullo 2010-08-05 22:13:46 UTC
*** Bug 621697 has been marked as a duplicate of this bug. ***

Comment 16 Michal Schmidt 2010-08-05 22:15:43 UTC
(In reply to comment #14)
> do we know exactly what operation triggered the systemctl fail?

systemctl enable $ANY_SYSTEMD_UNIT
as long as SELinux is enabled (enforcing or permissive).

Comment 17 Adam Williamson 2010-08-05 22:25:26 UTC
ah. so, yes, that does seem very likely to break new installs. looks like we will need a fix for this.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 18 Adam Williamson 2010-08-05 22:26:07 UTC

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 19 Nicolas Mailhot 2010-08-05 22:42:31 UTC
Package: systemd-units-5-2.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Branched)


How to reproduce
-----
systemctl enable graphical.target

Comment 20 Fedora Update System 2010-08-06 10:44:41 UTC
systemd-6-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/systemd-6-1.fc14

Comment 21 James Laska 2010-08-06 12:47:01 UTC
(In reply to comment #17)
> ah. so, yes, that does seem very likely to break new installs. looks like we
> will need a fix for this.

Yeah I agree ... seems to touch on the following release criteria (https://fedoraproject.org/wiki/Fedora_14_Alpha_Release_Criteria)

 "In most cases, the installed system must boot to a functional graphical environment without user intervention"

Moving to ON_QA as an update is available with this fix.

Comment 22 He Rui 2010-08-09 08:03:39 UTC
(In reply to comment #21)
> (In reply to comment #17)
> > ah. so, yes, that does seem very likely to break new installs. looks like we
> > will need a fix for this.
> 
> Yeah I agree ... seems to touch on the following release criteria
> (https://fedoraproject.org/wiki/Fedora_14_Alpha_Release_Criteria)
> 
>  "In most cases, the installed system must boot to a functional graphical
> environment without user intervention"
> 
> Moving to ON_QA as an update is available with this fix.    

F14-Alpha-RC2 still used systemd-5-2, therefore caused default.target (and other links) not to be created in the postinstall scriptlets when SELinux is enabled.(bug#618315)

Comment 23 He Rui 2010-08-09 10:22:17 UTC
(In reply to comment #22)
> (In reply to comment #21)
> > (In reply to comment #17)
> > > ah. so, yes, that does seem very likely to break new installs. looks like we
> > > will need a fix for this.
> > 
> > Yeah I agree ... seems to touch on the following release criteria
> > (https://fedoraproject.org/wiki/Fedora_14_Alpha_Release_Criteria)
> > 
> >  "In most cases, the installed system must boot to a functional graphical
> > environment without user intervention"
> > 
> > Moving to ON_QA as an update is available with this fix.    
> 
> F14-Alpha-RC2 still used systemd-5-2, therefore caused default.target (and
> other links) not to be created in the postinstall scriptlets when SELinux is
> enabled.(bug#618315)    

Sorry, I made a mistake. Systemd-5-2 was installed by net-install with branched repo. But DVDs contain the right 6-2 version.

Comment 24 Michal Schmidt 2010-08-09 13:50:13 UTC
*** Bug 622475 has been marked as a duplicate of this bug. ***

Comment 25 Adam Williamson 2010-08-11 19:20:24 UTC
7-1 has the fix for this and is stable and in alpha rc3, so closing.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 26 Jeff Layton 2010-08-11 19:25:39 UTC
Reopening bug. This bug was opened against rawhide and the latest package in rawhide is 5-2.

Please build the newer package for rawhide (fc15) and then close the bug.

Comment 27 Bill Nottingham 2010-08-11 19:30:41 UTC
*** Bug 623433 has been marked as a duplicate of this bug. ***

Comment 28 Bill Nottingham 2010-08-11 19:36:11 UTC
Build going out for F-15 now.

Comment 29 Adam Williamson 2010-08-11 21:11:59 UTC
This doesn't block F14 Alpha, even if it's not fixed in Rawhide.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.