Bug 621712 - [abrt] crash in hplip-gui-3.10.5-1.fc13: hp-sendfax crashed in _dbus_counter_adjust
Summary: [abrt] crash in hplip-gui-3.10.5-1.fc13: hp-sendfax crashed in _dbus_counter_...
Status: CLOSED DUPLICATE of bug 600932
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:1b15aea518bdd5cd536c5e82fd4...
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-05 22:01 UTC by Michael Wiktowy
Modified: 2010-12-13 17:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-13 17:21:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (63.72 KB, text/plain)
2010-08-05 22:01 UTC, Michael Wiktowy
no flags Details

Description Michael Wiktowy 2010-08-05 22:01:02 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
Attached file: backtrace
cmdline: python /usr/bin/hp-toolbox
component: hplip
crash_function: _dbus_counter_adjust
executable: /usr/bin/python
global_uuid: 1b15aea518bdd5cd536c5e82fd46222a0d1dd4de
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: hplip-gui-3.10.5-1.fc13
rating: 4
reason: Process /usr/bin/python was killed by signal 11 (SIGSEGV)
release: Fedora release 13 (Goddard)

comment
-----
1. After setting up HP 6500 Wireless multifunction printer using hp-setup at root to add the fax option that setup via normal admin interface didn't add, tried printing to fax device.
2. Fax job just sat in queue doing nothing.
3. Tried to manually send, via hp-sendfax, just a cover page with some cut and pasted notes in the comments section to my own number (just to see if the printer would pick up the phone and call itself to try to send).
4. It send the job to the queue again which just sat there but the hp-sendfax crashed which triggered abrt. The fax jopb remained in the queue and I could redirect it to the normal printer queue to print.

How to reproduce
-----
1. Failed to print to fax as normal user with HP 6500 after setting up with hp-setup ar root
2. Tried to print a cover page using hp-sendfax as normal user
3. hp-sendfax crashed and left fax job in CUPS queue

Comment 1 Michael Wiktowy 2010-08-05 22:01:05 UTC
Created attachment 436988 [details]
File: backtrace

Comment 2 Michael Wiktowy 2010-08-05 22:03:07 UTC
Printer can fax manually by using it independently of computer.

Comment 3 Jiri Popelka 2010-08-06 10:06:03 UTC
Backtrace is similar to the one from bug #600932.

Comment 4 Tim Waugh 2010-12-13 17:21:07 UTC
Yes.  As HPLIP is known to use D-Bus from two threads (which it cannot), this is likely to be the same cause.

*** This bug has been marked as a duplicate of bug 600932 ***


Note You need to log in before you can comment on or make changes to this bug.