Bug 62176 - strace -f freezes when a child exits.
Summary: strace -f freezes when a child exits.
Status: CLOSED DUPLICATE of bug 62591
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: strace   
(Show other bugs)
Version: 7.3
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 61590
TreeView+ depends on / blocked
 
Reported: 2002-03-28 05:28 UTC by Aleksey Nogin
Modified: 2007-04-18 16:41 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-04-09 17:40:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aleksey Nogin 2002-03-28 05:28:23 UTC
If I debug a process using "strace -f" and the process spawns a child and waits
for it, strace would freeze. ps would show both the child and the parent in the
"T" state and if will stay that way untill kill -9.

P.S. Is this related to bug 53191?

Comment 1 Brent Fox 2002-04-09 15:28:54 UTC
This looks very similar to bug #62591

Comment 2 Aleksey Nogin 2002-04-09 17:38:07 UTC
Yes, bug 62591 is definitely a dup of this one (judging among other things by
https://bugzilla.redhat.com/bugzilla/showattachment.cgi?attach_id=51924 ending
with a child's _exit).

Comment 3 Aleksey Nogin 2002-04-09 17:40:26 UTC
Still seeing it with
strace-4.4-3
glibc-2.2.5-30
kernel-2.4.18-0.13

Comment 4 Bill Nottingham 2002-04-10 04:50:30 UTC

*** This bug has been marked as a duplicate of 62591 ***


Note You need to log in before you can comment on or make changes to this bug.