Bug 62591 - strace -f [threaded process] freezes when a child exits.
strace -f [threaded process] freezes when a child exits.
Product: Red Hat Raw Hide
Classification: Retired
Component: strace (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Brian Brock
: 62176 (view as bug list)
Depends On:
Blocks: 61590
  Show dependency treegraph
Reported: 2002-04-02 16:02 EST by Bill Crawford
Modified: 2007-04-18 12:41 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-08-05 21:53:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
strace output (20.48 KB, text/plain)
2002-04-02 16:04 EST, Bill Crawford
no flags Details
snippet from output of "ps auxww" (580 bytes, text/plain)
2002-04-02 16:05 EST, Bill Crawford
no flags Details

  None (edit)
Description Bill Crawford 2002-04-02 16:02:23 EST
Description of Problem:
Running "strace -f host www.redhat.com" never finishes, and I have to kill -9
the strace process.

Version-Release number of selected component (if applicable):
[bill@pikachu bill]$ rpm -qf $( which strace )
[bill@pikachu bill]$ rpm -qf $( which host )
[bill@pikachu bill]$ rpm -q glibc
[bill@pikachu bill]$ uname -a
Linux pikachu.bchsz.org.uk 2.4.18-0.12 #1 Wed Mar 27 16:18:42 EST 2002 i686
Comment 1 Bill Crawford 2002-04-02 16:04:34 EST
Created attachment 51924 [details]
strace output
Comment 2 Bill Crawford 2002-04-02 16:05:16 EST
Created attachment 51925 [details]
snippet from output of "ps auxww"
Comment 3 Bill Crawford 2002-04-02 16:08:45 EST
killall -9 host yields the following after the strace output instead of "Killed"

Unable to wait on inferior: No child processes
Unable to wait on inferior: No child processes
Comment 4 Brent Fox 2002-04-09 11:29:09 EDT
This looks very similar to bug #62176
Comment 5 Bill Crawford 2002-04-09 16:57:25 EDT
... bug  #62176 which I can't read ... this is really frustrating, yanno?
Comment 6 Bill Nottingham 2002-04-10 00:50:25 EDT
*** Bug 62176 has been marked as a duplicate of this bug. ***
Comment 7 Aleksey Nogin 2002-04-10 10:26:43 EDT
If I debug a process using "strace -f" and the process spawns a child and waits
for it, strace would freeze. ps would show both the child and the parent in the
"T" state and if will stay that way untill kill -9.

I am seeing it with

It didn't exist in 7.2

Comment 8 Jakub Jelinek 2002-04-11 14:01:20 EDT
Are you really sure this did not exist in 7.2?
I just tried strace -f -o log ./ex3 (where ex3 is libc/linuxthreads/Examples/ex3.c,
quite simple pthread test).
strace needs to be kill -9ed with glibc-2.2.5-32+strace-4.3-2+kernel-2.4.9-21smp,
glibc-2.2.4-24+strace-4.3-2+kernel-2.4.17-0.13smp and glibc-2.2.5-32+strace-4.4-3+kernel-2.4.17-0.13smp
Comment 9 Aleksey Nogin 2002-04-11 14:43:59 EDT
Yes, pretty sure.

My test is

strace -f sh -c 'TEST=`/bin/echo xyz`; exec /bin/echo xyz'

It works OK on
glibc-2.2.4-19.3 kernel-smp-2.4.9-31 strace-4.3-2 and
glibc-2.2.4-19.3 kernel-smp-2.4.9-21 strace-4.3-2

but gets stuck (and requires kill -9) on
glibc-2.2.5-30 kernel-2.4.18-0.13 strace-4.4-3

I will go upgrade one of 7.2 machines to the latest glibc and report back.
Comment 10 Aleksey Nogin 2002-04-11 15:34:47 EDT
(disregard the kernel-smp-2.4.9-31 line in the above - that machine still runs -21).

Works OK:

glibc-2.2.4-19.3 kernel-2.4.9-31 strace-4.2.20010119-3  (RH7.1+updates)

After upgrading to glibc-2.2.4-24 both the above and the kernel-smp-2.4.9-21
strace-4.3-2 one (but not rebooting it), it still works.
Comment 11 Jakub Jelinek 2002-04-12 15:19:03 EDT
This means there are two separate problems.
strace -f sh -c 'TEST=`/bin/echo xyz`; exec /bin/echo xyz'
which is caused by the patch which was added in strace-4.3-3,
and problems with threaded programs, which existed in 7.2 and probably earlier
Comment 12 Bill Nottingham 2002-04-14 23:26:55 EDT
*** Bug 63370 has been marked as a duplicate of this bug. ***
Comment 13 Jay Berkenbilt 2002-04-15 11:13:46 EDT
I reported this problem in bug 63370 as a problem with skipjack.... Sorry -- I
limited my search only to the beta release and not rawhide.  Oops.

In any case, since this does impact the version of strace in the beta release,
does it make sense to change the Product of this bug?
Comment 14 Jakub Jelinek 2002-04-17 04:01:03 EDT
Should be fixed in strace-4.4-4.
Comment 15 Jay Berkenbilt 2002-05-16 12:30:17 EDT
This problem appears to be fixed in RedHat 7.3, but the problem I reported in
63370, which was marked as a duplicate of this bug, has not been entirely fixed.
 I am reopening that bug, as it is different from this one, changing it to a
Valhalla problem, and updating it with new information.  I don't see why this
specific bug, which no longer appears in 7.3 with strace-4.4-4, can't be closed,
but I am obviously not the one who should make that judgment call being neither
a RedHat person nor the original poster....
Comment 16 Jay Berkenbilt 2002-08-05 21:52:57 EDT
This problem appears to be fixed in limbo.  Maybe someone should close it.
Comment 17 Brian Brock 2002-09-03 17:22:56 EDT
Fix verified, closing.

(resolution set to RAWHIDE due to product version of defect, likely fixed much

Note You need to log in before you can comment on or make changes to this bug.