Bug 621808 - [abrt] crash in fedora-packager-0.5.1.0-1.fc13: __init__.py:488:sources:ValueError: need more than 0 values to unpack
Summary: [abrt] crash in fedora-packager-0.5.1.0-1.fc13: __init__.py:488:sources:Value...
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-packager   
(Show other bugs)
Version: 13
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:8b990960
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-08-06 07:34 UTC by David Woodhouse
Modified: 2013-01-10 06:07 UTC (History)
2 users (show)

Fixed In Version: fedora-packager-0.5.1.2-2.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-17 05:37:13 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.56 KB, text/plain)
2010-08-06 07:34 UTC, David Woodhouse
no flags Details

Description David Woodhouse 2010-08-06 07:34:30 UTC
abrt 1.1.1 detected a crash.

architecture: x86_64
cmdline: /usr/bin/python /usr/bin/fedpkg local
component: fedora-packager
executable: /usr/bin/fedpkg
kernel: 2.6.33.6-147.2.4.fc13.x86_64
package: fedora-packager-0.5.1.0-1.fc13
reason: __init__.py:488:sources:ValueError: need more than 0 values to unpack
release: Fedora release 13 (Goddard)

backtrace
-----
__init__.py:488:sources:ValueError: need more than 0 values to unpack

Traceback (most recent call last):
  File "/usr/bin/fedpkg", line 959, in <module>
    args.command(args)
  File "/usr/bin/fedpkg", line 510, in local
    return mymodule.local(arch=arch)
  File "/usr/lib/python2.6/site-packages/pyfedpkg/__init__.py", line 1190, in local
    sources(self.path)
  File "/usr/lib/python2.6/site-packages/pyfedpkg/__init__.py", line 488, in sources
    csum, file = archive.split()
ValueError: need more than 0 values to unpack

Local variables in innermost frame:
files: ['linux-firmware.spec', '.gitignore', 'linux-firmware-20100806.tar.gz', 'sources', '.git']
f: 'linux-firmware.spec'
url: 'http://pkgs.fedoraproject.org/repo/pkgs/linux-firmware/radeon-firmware-2.tar.bz2/ee8574e13b60be59b6b18b21e20d9e3a/radeon-firmware-2.tar.bz2'
module: 'linux-firmware'
spec: 'linux-firmware.spec'
outfile: '/home/dwmw2/fedora/linux-firmware/master/radeon-firmware-2.tar.bz2'
command: ['curl', '-H', 'Pragma:', '-O', '-R', '-S', '--fail', '--show-error', 'http://pkgs.fedoraproject.org/repo/pkgs/linux-firmware/radeon-firmware-2.tar.bz2/ee8574e13b60be59b6b18b21e20d9e3a/radeon-firmware-2.tar.bz2']
archives: ['63ab27c4cd53b88ca3071b2c0848cc79  linux-firmware-20100806.tar.gz\n', '554e432993f138bd5c6704dbca109d71  nouveau-firmware-1.tar.bz2\n', 'ee8574e13b60be59b6b18b21e20d9e3a  radeon-firmware-2.tar.bz2\n', '\n']
file: 'radeon-firmware-2.tar.bz2'
csum: 'ee8574e13b60be59b6b18b21e20d9e3a'
path: '/home/dwmw2/fedora/linux-firmware/master'
archive: '\n'
outdir: '/home/dwmw2/fedora/linux-firmware/master'

How to reproduce
-----
1. fedpkg clone -B linux-firmware
2. cd linux-firmware/master
3. Update tarball
4. fedpkg local

Comment 1 David Woodhouse 2010-08-06 07:34:33 UTC
Created attachment 437053 [details]
File: backtrace

Comment 2 David Woodhouse 2010-08-06 07:41:52 UTC
Aha, caused by a blank line in the sources file.

Comment 3 Jesse Keating 2010-08-06 19:40:22 UTC
Oh neat.  How did the blank line get in there?  (we should handle that better anyway)

Comment 4 David Woodhouse 2010-08-06 20:13:35 UTC
I put it there when editing the sources file to put back some of the original source files after running 'fedpkg new-sources'

Comment 5 Jesse Keating 2010-08-12 07:12:11 UTC
Catching this error now.

Comment 6 Fedora Update System 2010-08-12 19:53:44 UTC
python-kitchen-0.2-0.1.a2.el5,fedora-packager-0.5.1.2-1.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/python-kitchen-0.2-0.1.a2.el5,fedora-packager-0.5.1.2-1.el5

Comment 7 Fedora Update System 2010-08-12 19:57:18 UTC
fedora-packager-0.5.1.2-1.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-1.fc14

Comment 8 Fedora Update System 2010-08-12 20:01:45 UTC
fedora-packager-0.5.1.2-1.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-1.fc13

Comment 9 Fedora Update System 2010-08-12 20:07:40 UTC
fedora-packager-0.5.1.2-1.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-1.fc12

Comment 10 Fedora Update System 2010-08-13 21:06:37 UTC
fedora-packager-0.5.1.2-2.fc13 has been pushed to the Fedora 13 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fedora-packager'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/fedora-packager-0.5.1.2-2.fc13

Comment 11 Fedora Update System 2010-08-13 22:39:16 UTC
fedora-packager-0.5.1.2-2.el5, python-kitchen-0.2-0.1.a2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update fedora-packager python-kitchen'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/python-kitchen-0.2-0.1.a2.el5,fedora-packager-0.5.1.2-2.el5

Comment 12 Fedora Update System 2010-08-17 05:36:11 UTC
fedora-packager-0.5.1.2-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2010-08-24 21:09:24 UTC
fedora-packager-0.5.1.2-2.fc12 has been pushed to the Fedora 12 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2010-08-24 23:03:51 UTC
fedora-packager-0.5.1.2-2.el5, python-kitchen-0.2-0.1.a2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2010-08-25 01:19:35 UTC
fedora-packager-0.5.1.2-2.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.