Bug 622141 - /usr/bin/sealert crashed
/usr/bin/sealert crashed
Status: CLOSED DUPLICATE of bug 623299
Product: Fedora
Classification: Fedora
Component: python-bugzilla (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-07 13:07 EDT by Martin Kho
Modified: 2010-08-13 12:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-13 12:13:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Kho 2010-08-07 13:07:26 EDT
Description of problem:

base.py:957:request:AttributeError: HTTPSConnection instance has no attribute 'getreply'

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/setroubleshoot/browser.py", line 108, in submit_button_clicked
    self.submit()
  File "/usr/lib64/python2.7/site-packages/setroubleshoot/browser.py", line 129, in submit
    rc = report.report(signature, report.io.GTKIO.GTKIO(self.parent.accounts))
  File "/usr/lib64/python2.7/site-packages/report/__init__.py", line 493, in report
    retval = choice(signature, io)
  File "/usr/lib64/python2.7/site-packages/report/__init__.py", line 413, in <lambda>
    (lambda module, optionsDict: lambda signature, io : module.report(signature, io, optionsDict))(module, optionsDict)))
  File "/usr/lib64/python2.7/site-packages/report/plugins/bugzilla/__init__.py", line 106, in report
    fileDescription)
  File "/usr/lib64/python2.7/site-packages/report/plugins/bugzilla/__init__.py", line 176, in sendToBugzilla
    withBugzillaDo(bzfiler, lambda b: b.login(loginResult['username'],
  File "/usr/lib64/python2.7/site-packages/report/plugins/bugzilla/__init__.py", line 125, in withBugzillaDo
    retval = fn(bz)
  File "/usr/lib64/python2.7/site-packages/report/plugins/bugzilla/__init__.py", line 177, in <lambda>
    loginResult['password']))
  File "/usr/lib64/python2.7/site-packages/report/plugins/bugzilla/filer.py", line 328, in login
    retval = self._bz.login(username, password)
  File "/usr/lib/python2.7/site-packages/bugzilla/base.py", line 308, in login
    r = self._login(self.user,self.password)
  File "/usr/lib/python2.7/site-packages/bugzilla/bugzilla3.py", line 27, in _login
    return self._proxy.User.login({'login':user,'password':password})
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1224, in __call__
    return self.__send(self.__name, args)
  File "/usr/lib64/python2.7/xmlrpclib.py", line 1570, in __request
    verbose=self.__verbose
  File "/usr/lib/python2.7/site-packages/bugzilla/base.py", line 957, in request
    errcode, errmsg, headers = h.getreply()
AttributeError: HTTPSConnection instance has no attribute 'getreply'

Local variables in innermost frame:
verbose: 0
request_body: "<?xml version='1.0'?>\n<methodCall>\n<methodName>User.login</methodName>\n<params>\n<param>\n<value><struct>\n<member>\n<name>login</name>\n<value><string>lists.kho@gmail.com</string></value>\n</member>\n<member>\n<name>password</name>\n<value><string>my3rd8</string></value>\n</member>\n</struct></value>\n</param>\n</params>\n</methodCall>\n"
h: <httplib.HTTPSConnection instance at 0x2c35c68>
self: <bugzilla.base.SafeCookieTransport instance at 0x2c35f38>
host: 'bugzilla.redhat.com'
cookie_request: <urllib2.Request instance at 0x2c35c20>
handler: '/xmlrpc.cgi'
request_url: 'https://bugzilla.redhat.com/xmlrpc.cgi'

Version-Release number of selected component (if applicable):
setroubleshoot-server-2.2.91-2.fc15.x86_64

How reproducible:
Report a denial with sealert

Steps to Reproduce:
1. Open bin/seapplet
2. Try to report denial to Redhat bugzilla
3. Abrt opens -> not usable because gnome-keyring crashes :-)
  
Actual results:
Impossible to report the denial

Expected results:
Report of denial

Additional info:
Comment 1 Daniel Walsh 2010-08-13 12:13:17 EDT

*** This bug has been marked as a duplicate of bug 623299 ***

Note You need to log in before you can comment on or make changes to this bug.