Bug 622149 - kernel/sched.c:616 invoked rcu_dereference_check() without protection!
Summary: kernel/sched.c:616 invoked rcu_dereference_check() without protection!
Status: CLOSED DUPLICATE of bug 626026
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 14
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kyle McMartin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 610967 624783 (view as bug list)
Depends On:
Blocks: F14Target
TreeView+ depends on / blocked
 
Reported: 2010-08-07 18:25 UTC by Nicolas Mailhot
Modified: 2015-09-01 03:53 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-09-21 20:51:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (56.18 KB, text/plain)
2010-08-07 18:25 UTC, Nicolas Mailhot
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Linux Kernel 16323 None None None Never
Linux Kernel 16546 None None None Never

Description Nicolas Mailhot 2010-08-07 18:25:37 UTC
Created attachment 437363 [details]
dmesg

Description of problem:

[ INFO: suspicious rcu_dereference_check() usage. ]
---------------------------------------------------
kernel/sched.c:616 invoked rcu_dereference_check() without protection!

other info that might help us debug this:


rcu_scheduler_active = 1, debug_locks = 0
3 locks held by swapper/1:
 #0:  (cpu_add_remove_lock){+.+.+.}, at: [<ffffffff81052b4b>] cpu_maps_update_begin+0x17/0x19
 #1:  (cpu_hotplug.lock){+.+.+.}, at: [<ffffffff81052a5e>] cpu_hotplug_begin+0x2c/0x53
 #2:  (&rq->lock){-.....}, at: [<ffffffff814919c9>] init_idle+0x30/0x131

stack backtrace:
Pid: 1, comm: swapper Not tainted 2.6.35.1-4.rc1.fc14.x86_64 #1
Call Trace:
 [<ffffffff8107bc7a>] lockdep_rcu_dereference+0xaa/0xb3
 [<ffffffff8103fda5>] task_group+0x80/0x8f
 [<ffffffff8103fdcb>] set_task_rq+0x17/0x73
 [<ffffffff81491a83>] init_idle+0xea/0x131
 [<ffffffff81491e53>] fork_idle+0x92/0xa3
 [<ffffffff8107e760>] ? mark_held_locks+0x50/0x72
 [<ffffffff8148f8f9>] do_fork_idle+0x1c/0x2d
 [<ffffffff8148fa41>] do_boot_cpu+0x137/0x9ac
 [<ffffffff8148f8dd>] ? do_fork_idle+0x0/0x2d
 [<ffffffff81490ada>] native_cpu_up+0x100/0x1c2
 [<ffffffff81491f2c>] _cpu_up+0x9d/0xf9
 [<ffffffff8149205b>] cpu_up+0xd3/0xe5
 [<ffffffff81d78d86>] kernel_init+0x105/0x2c9
 [<ffffffff8100aae4>] kernel_thread_helper+0x4/0x10
 [<ffffffff81499210>] ? restore_args+0x0/0x30
 [<ffffffff81d78c81>] ? kernel_init+0x0/0x2c9
 [<ffffffff8100aae0>] ? kernel_thread_helper+0x0/0x10


How reproducible:

On boot

Comment 1 David Timms 2010-08-15 04:04:46 UTC
(In reply to comment #0)
> [ INFO: suspicious rcu_dereference_check() usage. ]
Seems very similar to bug 610967 from kernel 2.6.35-0.19.rc3.git4.fc14.x86_64

Comment 2 Sergei LITVINENKO 2010-08-15 08:10:45 UTC
Also:

[root@rawhide etc]# uname -r

2.6.35-3.fc14.i686.PAE


===================================================
[ INFO: suspicious rcu_dereference_check() usage. ]
---------------------------------------------------
include/linux/cgroup.h:542 invoked rcu_dereference_check() without protection!

other info that might help us debug this:


rcu_scheduler_active = 1, debug_locks = 0
1 lock held by swapper/1:
 #0:  (net_mutex){+.+.+.}, at: [<c0747df5>] register_pernet_subsys+0x17/0x34

stack backtrace:
Pid: 1, comm: swapper Not tainted 2.6.35-3.fc14.i686.PAE #1
Call Trace:
 [<c07de9a2>] ? printk+0x25/0x2b
 [<c04677a5>] lockdep_rcu_dereference+0x7d/0x86
 [<c074094a>] sock_update_classid+0x6c/0x8e
 [<c07409cb>] sk_alloc+0x5f/0x6a
 [<c0763ce1>] __netlink_create+0x2a/0x90
 [<c076558c>] netlink_kernel_create+0x5f/0x14f
 [<c07548b8>] rtnetlink_net_init+0x23/0x3b
 [<c0755c6e>] ? rtnetlink_rcv+0x0/0x27
 [<c0747be8>] ops_init+0xda/0xe9
 [<c0747d28>] register_pernet_operations+0x84/0xee
 [<c0747e01>] register_pernet_subsys+0x23/0x34
 [<c0ab3dda>] rtnetlink_init+0x42/0xe0
 [<c0ab4440>] netlink_proto_init+0xee/0x103
 [<c0ab4352>] ? netlink_proto_init+0x0/0x103
 [<c0403182>] do_one_initcall+0x62/0x170
 [<c0a7c9d3>] kernel_init+0x1b9/0x23a
 [<c0a7c81a>] ? kernel_init+0x0/0x23a
 [<c0409002>] kernel_thread_helper+0x6/0x10

How reproduce:

On boot

Comment 3 Chuck Ebbert 2010-08-18 12:39:38 UTC
*** Bug 624783 has been marked as a duplicate of this bug. ***

Comment 4 Szabo Akos 2010-08-19 22:58:00 UTC
I've got this too, when my notebook is booting:

NET: Registered protocol family 16

===================================================
[ INFO: suspicious rcu_dereference_check() usage. ]
---------------------------------------------------
include/linux/cgroup.h:542 invoked rcu_dereference_check() without protection!

other info that might help us debug this:


rcu_scheduler_active = 1, debug_locks = 0
1 lock held by swapper/1:
 #0:  (net_mutex){+.+.+.}, at: [<c07368f5>] register_pernet_subsys+0x17/0x34

stack backtrace:
Pid: 1, comm: swapper Not tainted 2.6.35-0.57.rc6.git1.fc14.i686 #1
Call Trace:
 [<c07cc316>] ? printk+0x25/0x2f
 [<c046094d>] lockdep_rcu_dereference+0x7d/0x86
 [<c072f46a>] sock_update_classid+0x6c/0x8e
 [<c072f4eb>] sk_alloc+0x5f/0x6a
 [<c07527bd>] __netlink_create+0x2a/0x90
 [<c0754068>] netlink_kernel_create+0x5f/0x14f
 [<c0743394>] rtnetlink_net_init+0x23/0x3b
 [<c074474a>] ? rtnetlink_rcv+0x0/0x27
 [<c07366e8>] ops_init+0xda/0xe9
 [<c0736828>] register_pernet_operations+0x84/0xee
 [<c0736901>] register_pernet_subsys+0x23/0x34
 [<c0a93d1d>] rtnetlink_init+0x42/0xe0
 [<c0a94383>] netlink_proto_init+0xee/0x103
 [<c0a94295>] ? netlink_proto_init+0x0/0x103
 [<c040126a>] do_one_initcall+0x62/0x170
 [<c0a5e9c2>] kernel_init+0x1b9/0x23a
 [<c0a5e809>] ? kernel_init+0x0/0x23a
 [<c0403982>] kernel_thread_helper+0x6/0x10
ACPI: bus type pci registered

uname -r: 2.6.35-0.57.rc6.git1.fc14.i686
PC: Asus A3l: http://www.smolts.org/client/show/pub_b684b09c-afb6-41d8-95ce-3739173efde5

Comment 5 Paul E. McKenney 2010-08-26 16:18:09 UTC
Does the patch posted to LKML at http://lkml.org/lkml/2010/8/16/258 fix this problem?

Comment 6 IBM Bug Proxy 2010-08-31 09:21:25 UTC
------- Comment From Subrata Modak subrata@linux.vnet.ibm.com 2010-08-26 07:27 EDT-------
Tried Installing the new Fedora14 Alpha on x86_64 with the following kernel command line parameters:

title Fedora 14 Alpha X86_64 Installation
root (hd0,0)
kernel /VMLINUZ-F14-ALPHA-X86_64-INSTALLATION vnc=1 askmethod debug ro root=UUID=a0a6b9e6-0716-4231-b62f-e72966df97c1 rd_NO_LUKS rd_NO_LVM rd_NO_MD rd_NO_DM LANG=en_US.UTF-8 SYSFONT=latarcyrheb-sun16 KEYTABLE=us rhgb quiet console=tty0 console=ttyS0,9600n1
initrd /INITRD.IMG-F14-ALPHA-X86_64-INSTALLATION

When the Installation kernel boots, the following backtrace with suspicious rcu_dereference_check() usage info is displayed:

kernel/sched.c:616 invoked rcu_dereference_check() without protection!


3 locks held by swapper/1:
#0:  (cpu_add_remove_lock){+.+.+.}, at: [<ffffffff81052b57>] cpu_maps_update_begin+0x17/0x19
#1:  (cpu_hotplug.lock){+.+.+.}, at: [<ffffffff81052a6a>] cpu_hotplug_begin+0x2c/0x53
#2:  (&rq->lock){-.....}, at: [<ffffffff814919e9>] init_idle+0x30/0x131

Pid: 1, comm: swapper Not tainted 2.6.35-0.57.rc6.git1.fc14.x86_64 #1
[<ffffffff8107bc56>] lockdep_rcu_dereference+0xaa/0xb3
[<ffffffff8103fceb>] task_group+0x80/0x8f
[<ffffffff8103fd11>] set_task_rq+0x17/0x73
[<ffffffff81491aa3>] init_idle+0xea/0x131
[<ffffffff81491e73>] fork_idle+0x92/0xa3
[<ffffffff8107e73c>] ? mark_held_locks+0x50/0x72
[<ffffffff8148f919>] do_fork_idle+0x1c/0x2d
[<ffffffff8148fa61>] do_boot_cpu+0x137/0x9ac
[<ffffffff8148f8fd>] ? do_fork_idle+0x0/0x2d
[<ffffffff81490afa>] native_cpu_up+0x100/0x1c2
[<ffffffff81491f4c>] _cpu_up+0x9d/0xf9
[<ffffffff8149207b>] cpu_up+0xd3/0xe5
[<ffffffff81d78d86>] kernel_init+0x105/0x2c9
[<ffffffff8100aae4>] kernel_thread_helper+0x4/0x10
[<ffffffff81499250>] ? restore_args+0x0/0x30
[<ffffffff81d78c81>] ? kernel_init+0x0/0x2c9
[<ffffffff8100aae0>] ? kernel_thread_helper+0x0/0x10

Please note that this has been reported against stable 2.6.35 kernel boot on a Power system earlier:
https://bugzilla.linux.ibm.com/show_bug.cgi?id=66322,

And the same has been reported to community earlier:
http://marc.info/?l=linux-kernel&m=128073918419530&w=2,

Kindly mirror this to Redhat.

Regards--
Subrata

Comment 7 James G. Brown III 2010-09-06 15:08:39 UTC
Still seeing this on 2.6.35.4-12.fc14.i686.PAE

- James

Comment 8 Kyle McMartin 2010-09-06 18:25:33 UTC
Hi James, care to try the build here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=2449680
and let us know if that squelches the warning?

Comment 9 James G. Brown III 2010-09-06 18:42:17 UTC
Kyle, NP, build doesn't look done yet though, so will check in a bit later. 

- James

Comment 10 James G. Brown III 2010-09-06 19:40:31 UTC
Kyle, I now receive this;

===================================================
[ INFO: suspicious rcu_dereference_check() usage. ]
---------------------------------------------------
include/linux/cgroup.h:542 invoked rcu_dereference_check() without protection!

other info that might help us debug this:


rcu_scheduler_active = 1, debug_locks = 0
1 lock held by swapper/1:
 #0:  (net_mutex){+.+.+.}, at: [<c073a049>] register_pernet_subsys+0x17/0x34

stack backtrace:
Pid: 1, comm: swapper Not tainted 2.6.35.4-20.fc14.i686 #1
Call Trace:
 [<c07cfb1c>] ? printk+0x25/0x29
 [<c0460b89>] lockdep_rcu_dereference+0x7d/0x86
 [<c0732baa>] sock_update_classid+0x6c/0x8e
 [<c0732c2b>] sk_alloc+0x5f/0x6a
 [<c0755f4d>] __netlink_create+0x2a/0x90
 [<c07577f8>] netlink_kernel_create+0x5f/0x14f
 [<c0746b00>] rtnetlink_net_init+0x23/0x3b
 [<c0747eb6>] ? rtnetlink_rcv+0x0/0x27
 [<c0739e3c>] ops_init+0xda/0xe9
 [<c0739f7c>] register_pernet_operations+0x84/0xee
 [<c073a055>] register_pernet_subsys+0x23/0x34
 [<c0a97e03>] rtnetlink_init+0x42/0xe0
 [<c0a98469>] netlink_proto_init+0xee/0x103
 [<c0a9837b>] ? netlink_proto_init+0x0/0x103
 [<c040126a>] do_one_initcall+0x62/0x170
 [<c0a629c2>] kernel_init+0x1b9/0x23a
 [<c0a62809>] ? kernel_init+0x0/0x23a
 [<c0403982>] kernel_thread_helper+0x6/0x10

Comment 11 Kyle McMartin 2010-09-06 20:20:02 UTC
Yes, we will likely continue to receive these for the time being, as it seems most kernel developers do not have both these debugging options, and cgroups enabled.

Paul, any ideas about the other tracebacks in this bug report?

Thanks!
  Kyle

Comment 12 Jeff Raber 2010-09-21 19:46:34 UTC
(In reply to comment #10)
> Kyle, I now receive this;
> 
> ===================================================
> [ INFO: suspicious rcu_dereference_check() usage. ]
> ---------------------------------------------------
> include/linux/cgroup.h:542 invoked rcu_dereference_check() without protection!
> 
See bug 572520 for the cgroup.h version of this bug.

Comment 13 Jeff Raber 2010-09-21 20:03:34 UTC
*** Bug 610967 has been marked as a duplicate of this bug. ***

Comment 14 Jeff Raber 2010-09-21 20:34:31 UTC
*** Bug 626026 has been marked as a duplicate of this bug. ***

Comment 15 Jeff Raber 2010-09-21 20:51:35 UTC
Duping against bug 626026 as it is a F14 blocker.  Sorry for the SPAM.

*** This bug has been marked as a duplicate of bug 626026 ***


Note You need to log in before you can comment on or make changes to this bug.