Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 624783 - lockdep: suspicious rcu_dereference_check() usage
lockdep: suspicious rcu_dereference_check() usage
Status: CLOSED DUPLICATE of bug 622149
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
14
All Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-17 14:52 EDT by Jurgen Kramer
Modified: 2010-08-18 08:39 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-18 08:39:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full dmesg output (27.19 KB, text/plain)
2010-08-17 14:53 EDT, Jurgen Kramer
no flags Details

  None (edit)
Description Jurgen Kramer 2010-08-17 14:52:36 EDT
Description of problem:
When booting F14 alpha RC4 I saw a lockdep problem when checking /var/log/messages.

Version-Release number of selected component (if applicable):
2.6.35-3.fc14.x86_64

How reproducible:
always

Steps to Reproduce:
1. Boot F14 alpha RC4 in F13 x86_64 KVM
2.
3.
  
Actual results:
Lockdep issue appears

Expected results:
No lockdep

Additional info:
I first saw this message on a fresh F14 alpha RC4 with kernel 2.6.35-0.57.rc6.git1.fc14.x86_64 after updating the problem persists.
This is with F14 x86_64 alpha RC4 updated (17 aug 2010) running in KVM on a F13 x86_64 host with 2 vCPUs and 2048MB memory appointed to it.


Setting APIC routing to flat
..TIMER: vector=0x30 apic1=0 pin1=2 apic2=-1 pin2=-1
CPU0: Intel QEMU Virtual CPU version 0.12.3 stepping 03
lockdep: fixing up alternatives.

===================================================
[ INFO: suspicious rcu_dereference_check() usage. ]
---------------------------------------------------
kernel/sched.c:616 invoked rcu_dereference_check() without protection!

other info that might help us debug this:


rcu_scheduler_active = 1, debug_locks = 0
3 locks held by swapper/1:
 #0:  (cpu_add_remove_lock){+.+.+.}, at: [<ffffffff81052b4b>] cpu_maps_update_begin+0x17/0x19
 #1:  (cpu_hotplug.lock){+.+.+.}, at: [<ffffffff81052a5e>] cpu_hotplug_begin+0x2c/0x53
 #2:  (&rq->lock){-.-...}, at: [<ffffffff81491989>] init_idle+0x30/0x131

stack backtrace:
Pid: 1, comm: swapper Not tainted 2.6.35-3.fc14.x86_64 #1
Call Trace:
 [<ffffffff8107bc62>] lockdep_rcu_dereference+0xaa/0xb3
 [<ffffffff8103fda5>] task_group+0x80/0x8f
 [<ffffffff8103fdcb>] set_task_rq+0x17/0x73
 [<ffffffff81491a43>] init_idle+0xea/0x131
 [<ffffffff81491e13>] fork_idle+0x92/0xa3
 [<ffffffff8107e748>] ? mark_held_locks+0x50/0x72
 [<ffffffff8148f8b9>] do_fork_idle+0x1c/0x2d
 [<ffffffff8148fa01>] do_boot_cpu+0x137/0x9ac
 [<ffffffff8148f89d>] ? do_fork_idle+0x0/0x2d
 [<ffffffff81490a9a>] native_cpu_up+0x100/0x1c2
 [<ffffffff81491eec>] _cpu_up+0x9d/0xf9
 [<ffffffff8149201b>] cpu_up+0xd3/0xe5
 [<ffffffff81d78d86>] kernel_init+0x105/0x2c9
 [<ffffffff8100aae4>] kernel_thread_helper+0x4/0x10
 [<ffffffff814991d0>] ? restore_args+0x0/0x30
 [<ffffffff81d78c81>] ? kernel_init+0x0/0x2c9
 [<ffffffff8100aae0>] ? kernel_thread_helper+0x0/0x10
Booting Node   0, Processors  #1 Ok.
kvm-clock: cpu 1, msr 0:53d5a81, secondary cpu clock
Brought up 2 CPUs
Total of 2 processors activated (10689.24 BogoMIPS).
sizeof(vma)=176 bytes
sizeof(page)=56 bytes
sizeof(inode)=1168 bytes
sizeof(dentry)=256 bytes
sizeof(ext3inode)=1600 bytes
sizeof(buffer_head)=104 bytes
sizeof(skbuff)=240 bytes
sizeof(task_struct)=9216 bytes
Comment 1 Jurgen Kramer 2010-08-17 14:53:34 EDT
Created attachment 439189 [details]
Full dmesg output
Comment 2 Chuck Ebbert 2010-08-18 08:39:38 EDT

*** This bug has been marked as a duplicate of bug 622149 ***

Note You need to log in before you can comment on or make changes to this bug.