Bug 622366 - SELinux empêche l'accès en "read" à /usr/bin/certwatch on /etc/pki/dovecot/certs/dovecot.c
SELinux empêche l'accès en "read" à /usr/bin/certwatch on /etc/pki/dovec...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
14
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:e8db1aab633...
:
: 622367 (view as bug list)
Depends On:
Blocks: F14Target
  Show dependency treegraph
 
Reported: 2010-08-09 01:13 EDT by Nicolas Mailhot
Modified: 2010-09-17 14:12 EDT (History)
3 users (show)

See Also:
Fixed In Version: selinux-policy-3.8.8-14.fc14
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-23 21:50:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2010-08-09 01:13:47 EDT
Résumé:

SELinux empêche l'accès en "read" à /usr/bin/certwatch on
/etc/pki/dovecot/certs/dovecot.c

Description détaillée:

[SELinux est en mode permissif. Cet accès n'a pas été refusé.]

SELinux a refusé l'accès demandé par certwatch. Il n'est pas prévu que cet
accès soit requis par certwatch et cet accès peut signaler une tentative
d'intrusion. Il est également possible que cette version ou cette configuration
spécifique de l'application provoque cette demande d'accès supplémenta

Autoriser l'accès:

Vous pouvez créer un module de stratégie locale pour autoriser cet accès -
lisez la FAQ (http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Merci de
remplir un rapport de bogue.

Informations complémentaires:

Contexte source               system_u:system_r:certwatch_t:s0-s0:c0.c1023
Contexte cible                system_u:object_r:dovecot_cert_t:s0
Objets du contexte            /etc/pki/dovecot/certs/dovecot.crt [ file ]
source                        certwatch
Chemin de la source           /usr/bin/certwatch
Port                          <Inconnu>
Hôte                         (supprimé)
Paquetages RPM source         crypto-utils-2.4.1-27
Paquetages RPM cible          
Politique RPM                 selinux-policy-3.8.8-11.fc14
Selinux activé               True
Type de politique             targeted
Mode strict                   Permissive
Nom du plugin                 catchall
Nom de l'hôte                (supprimé)
Plateforme                    Linux (supprimé) 2.6.35.1-4.rc1.fc14.x86_64 #1 SMP
                              Sat Aug 7 17:02:35 UTC 2010 x86_64 x86_64
Compteur d'alertes            2
Première alerte              lun. 09 août 2010 03:26:02 CEST
Dernière alerte              lun. 09 août 2010 03:26:02 CEST
ID local                      3d176fd7-7510-4a08-b971-7063bde66453
Numéros des lignes           

Messages d'audit bruts        

node=(supprimé) type=AVC msg=audit(1281317162.844:905): avc:  denied  { read } for  pid=15330 comm="certwatch" name="dovecot.crt" dev=dm-1 ino=183874 scontext=system_u:system_r:certwatch_t:s0-s0:c0.c1023 tcontext=system_u:object_r:dovecot_cert_t:s0 tclass=file

node=(supprimé) type=AVC msg=audit(1281317162.844:905): avc:  denied  { open } for  pid=15330 comm="certwatch" name="dovecot.crt" dev=dm-1 ino=183874 scontext=system_u:system_r:certwatch_t:s0-s0:c0.c1023 tcontext=system_u:object_r:dovecot_cert_t:s0 tclass=file

node=(supprimé) type=SYSCALL msg=audit(1281317162.844:905): arch=c000003e syscall=2 success=yes exit=6 a0=7fff902e0f1c a1=0 a2=0 a3=1 items=0 ppid=15328 pid=15330 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=85 comm="certwatch" exe="/usr/bin/certwatch" subj=system_u:system_r:certwatch_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,certwatch,certwatch_t,dovecot_cert_t,file,read
audit2allow suggests:

#============= certwatch_t ==============
allow certwatch_t dovecot_cert_t:file { read open };
Comment 1 Nicolas Mailhot 2010-08-09 01:21:17 EDT
*** Bug 622367 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2010-08-11 09:34:41 EDT
You can add these rules for now using

# grep avc /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Fixed in selinux-policy-3.8.8-12.fc14

Miroslav you probably want to back port the change of adding cert_type, that I added to F14.
Comment 3 Daniel Walsh 2010-08-11 09:35:10 EDT
Should have said 

Fixed in selinux-policy-3.8.8-13.fc14
Comment 4 Miroslav Grepl 2010-08-11 09:44:28 EDT
Ok,
waiting for commit.
Comment 5 Fedora Update System 2010-08-13 16:29:19 EDT
selinux-policy-3.8.8-14.fc14 has been submitted as an update for Fedora 14.
http://admin.fedoraproject.org/updates/selinux-policy-3.8.8-14.fc14
Comment 6 Fedora Update System 2010-08-23 21:48:40 EDT
selinux-policy-3.8.8-14.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.