Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 622367 - SELinux empêche l'accès en "getattr" à /usr/bin/certwatch on /etc/pki/dovecot/certs/dovecot.c
SELinux empêche l'accès en "getattr" à /usr/bin/certwatch on /etc/pki/do...
Status: CLOSED DUPLICATE of bug 622366
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
14
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
setroubleshoot_trace_hash:a9f5ecd21c4...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-09 01:15 EDT by Nicolas Mailhot
Modified: 2010-08-09 01:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-08-09 01:21:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2010-08-09 01:15:00 EDT
Résumé:

SELinux empêche l'accès en "getattr" à /usr/bin/certwatch on
/etc/pki/dovecot/certs/dovecot.c

Description détaillée:

[SELinux est en mode permissif. Cet accès n'a pas été refusé.]

SELinux a refusé l'accès demandé par certwatch. Il n'est pas prévu que cet
accès soit requis par certwatch et cet accès peut signaler une tentative
d'intrusion. Il est également possible que cette version ou cette configuration
spécifique de l'application provoque cette demande d'accès supplémenta

Autoriser l'accès:

Vous pouvez créer un module de stratégie locale pour autoriser cet accès -
lisez la FAQ (http://docs.fedoraproject.org/selinux-faq-fc5/#id2961385) Merci de
remplir un rapport de bogue.

Informations complémentaires:

Contexte source               system_u:system_r:certwatch_t:s0-s0:c0.c1023
Contexte cible                system_u:object_r:dovecot_cert_t:s0
Objets du contexte            /etc/pki/dovecot/certs/dovecot.crt [ file ]
source                        certwatch
Chemin de la source           /usr/bin/certwatch
Port                          <Inconnu>
Hôte                         (supprimé)
Paquetages RPM source         crypto-utils-2.4.1-27
Paquetages RPM cible          
Politique RPM                 selinux-policy-3.8.8-11.fc14
Selinux activé               True
Type de politique             targeted
Mode strict                   Permissive
Nom du plugin                 catchall
Nom de l'hôte                (supprimé)
Plateforme                    Linux (supprimé) 2.6.35.1-4.rc1.fc14.x86_64 #1 SMP
                              Sat Aug 7 17:02:35 UTC 2010 x86_64 x86_64
Compteur d'alertes            1
Première alerte              lun. 09 août 2010 03:26:02 CEST
Dernière alerte              lun. 09 août 2010 03:26:02 CEST
ID local                      33a7988b-c595-4547-89dd-3d73c747caf7
Numéros des lignes           

Messages d'audit bruts        

node=(supprimé) type=AVC msg=audit(1281317162.845:906): avc:  denied  { getattr } for  pid=15330 comm="certwatch" path="/etc/pki/dovecot/certs/dovecot.crt" dev=dm-1 ino=183874 scontext=system_u:system_r:certwatch_t:s0-s0:c0.c1023 tcontext=system_u:object_r:dovecot_cert_t:s0 tclass=file

node=(supprimé) type=SYSCALL msg=audit(1281317162.845:906): arch=c000003e syscall=5 success=yes exit=0 a0=6 a1=7fff902dee40 a2=7fff902dee40 a3=30 items=0 ppid=15328 pid=15330 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=85 comm="certwatch" exe="/usr/bin/certwatch" subj=system_u:system_r:certwatch_t:s0-s0:c0.c1023 key=(null)



Hash String generated from  catchall,certwatch,certwatch_t,dovecot_cert_t,file,getattr
audit2allow suggests:

#============= certwatch_t ==============
allow certwatch_t dovecot_cert_t:file getattr;
Comment 1 Nicolas Mailhot 2010-08-09 01:21:16 EDT

*** This bug has been marked as a duplicate of bug 622366 ***

Note You need to log in before you can comment on or make changes to this bug.