Bug 622376 - KeyError: <pyanaconda.yuminstall.AnacondaYumRepo object at 0x7f0edfb98390>
KeyError: <pyanaconda.yuminstall.AnacondaYumRepo object at 0x7f0edfb98390>
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:a7ab76ad320a303fa...
:
: 679466 733213 740666 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2010-08-09 02:31 EDT by Jens Petersen
Modified: 2012-08-03 15:25 EDT (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-03 15:25:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (382.97 KB, text/plain)
2010-08-09 02:31 EDT, Jens Petersen
no flags Details
Attached traceback automatically from anaconda. (582.45 KB, text/plain)
2010-08-25 23:51 EDT, Brad Watson
no flags Details
Attached traceback automatically from anaconda. (413.08 KB, text/plain)
2010-08-27 06:19 EDT, Ben Lambrechts
no flags Details
Attached traceback automatically from anaconda. (450.16 KB, text/plain)
2010-09-12 22:45 EDT, Christofer Bertonha
no flags Details
Attached traceback automatically from anaconda. (541.16 KB, text/plain)
2010-09-30 05:32 EDT, Fred New
no flags Details
Attached traceback automatically from anaconda. (1020.44 KB, text/plain)
2010-10-14 15:51 EDT, James Laska
no flags Details
Attached traceback automatically from anaconda. (324.62 KB, text/plain)
2011-01-04 13:03 EST, Zack Cerza
no flags Details
Attached traceback automatically from anaconda. (537.22 KB, text/plain)
2011-02-20 08:54 EST, João Carlos Mendes Luís
no flags Details
Attached traceback automatically from anaconda. (895.82 KB, text/plain)
2011-03-01 08:22 EST, Daniel Mach
no flags Details
Attached traceback automatically from anaconda. (800.27 KB, text/plain)
2011-03-31 18:59 EDT, rct+redhat
no flags Details

  None (edit)
Description Jens Petersen 2010-08-09 02:31:33 EDT
The following was filed automatically by anaconda:
anaconda 14.15 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 233, in _sql_MD
    cache = getattr(self.sack, MD + 'db')[self.repo]
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 46, in newFunc
    return func(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/yum/sqlitesack.py", line 388, in returnPrco
    cur = self._sql_MD('primary', sql, (self.pkgKey,))
  File "/usr/lib/python2.7/site-packages/yum/packageSack.py", line 868, in _delPackageFromIndex
    for (n, fl, (e,v,r)) in obj.returnPrco('obsoletes'):
  File "/usr/lib/python2.7/site-packages/yum/packageSack.py", line 888, in delPackage
    self._delPackageFromIndex(obj)
  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line 300, in remove
    self._inSack.delPackage(txmbr.po)
  File "/usr/lib/python2.7/site-packages/yum/transactioninfo.py", line 697, in remove
    TransactionData.remove(self, pkgtup)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/sortedtransaction.py", line 87, in remove
    SortableTransactionData.remove(self, pkgtup)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/yuminstall.py", line 1332, in resetPackageSelections
    self.ayum.tsInfo.remove(txmbr.pkgtup)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/backend.py", line 294, in doBasePackageSelect
    anaconda.backend.resetPackageSelections()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 212, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 131, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1174, in nextClicked
    self.anaconda.dispatch.gotoNext()
KeyError: <pyanaconda.yuminstall.AnacondaYumRepo object at 0x7f0edfb98390>
Comment 1 Jens Petersen 2010-08-09 02:31:39 EDT
Created attachment 437526 [details]
Attached traceback automatically from anaconda.
Comment 2 Radek Vykydal 2010-08-09 09:40:42 EDT
This seems similar to bug #505189
only that now the stale repo references after going back and forth in repo UI (through reposetup step) would come not from user edited/added repo but from elsewhere (failed updates/testing repo?).
Comment 3 Radek Vykydal 2010-08-09 10:54:34 EDT
Jens, are you able to reproduce the issue? My suspicion is that it is related to going back in repo UI and failure of Updates Testing repository. Can you also describe the actions in repo UI you did (enabling/disabling/adding/editing repositiories) and error messages you were seeing (if there were any). What media did you use? DVD?
Comment 4 Jens Petersen 2010-08-10 03:18:51 EDT
Yes that is basically right: currently F14 anaconda enables testing
repo by default - but it had broken deps.  So Back, disable testing repo
and forward and anaconda made this backtrace.
Comment 5 Radek Vykydal 2010-08-25 09:31:55 EDT
I have a hacky patch for this one:
https://www.redhat.com/archives/anaconda-devel-list/2010-August/msg00140.html

To deal with "go back after creating of transaction and then disable a repo in UI" situation cleanly, big parts of repositories handling would need to be rewritten. Basically it would mean moving tasksel (which is also repo edit) UI step before reposetup step. I want to look at it, but it seems tough.
Comment 6 Brad Watson 2010-08-25 23:51:28 EDT
Created an attachment (id=441103)
Attached traceback automatically from anaconda.
Comment 7 Brad Watson 2010-08-25 23:58:31 EDT
I added the F14-Alpha x86_64 repo at first. This reported dependency problems. So I went BACK and unselected F14-Alpha x86_64 which left just the original Installation Repo selected. This then resulted in the crash.
Comment 8 Ben Lambrechts 2010-08-27 06:19:38 EDT
Created an attachment (id=441460)
Attached traceback automatically from anaconda.
Comment 9 Christofer Bertonha 2010-09-12 22:45:14 EDT
Created an attachment (id=446825)
Attached traceback automatically from anaconda.
Comment 10 Fred New 2010-09-30 05:32:26 EDT
Created attachment 450702 [details]
Attached traceback automatically from anaconda.
Comment 11 Fred New 2010-09-30 05:57:24 EDT
This is still here in the F14 Beta.  It's a major inconvenience since this was a hard disk installation.  The iso image is still on the hard disk, but with /boot formatted, there's no way to boot the installation again.  (Grumbly message about having to use Windows to download and create a CD.)  I'm thinking this should have a little higher priority, if not blocking status.  I don't think you can guarantee that this won't happen after the repositories are sorted out.

With regard to the sequence of events, the gnome-panel package was lacking the dependency lib<maybe-something>ui<something>.  I didn't think I wanted to install gnome-panel without this dependency, so I went back and turned off the testing-updates repository.
Comment 12 Brian Lane 2010-09-30 09:40:56 EDT
Did you try Radek's patch from comment 5?
Comment 13 Fred New 2010-09-30 10:20:03 EDT
No, this was my first pass.  I assume you're asking me to rebuild the ISO.  Never done that before.  I would be willing to experiment if you gave me some pointers (like in the Fedora Project wiki).
Comment 14 Radek Vykydal 2010-09-30 10:28:03 EDT
(In reply to comment #13)
> No, this was my first pass.  I assume you're asking me to rebuild the ISO. 
> Never done that before.  I would be willing to experiment if you gave me some
> pointers (like in the Fedora Project wiki).

Hold on, I'll post updates image for F14 beta.
Comment 15 Radek Vykydal 2010-09-30 10:36:49 EDT
(In reply to comment #14)

> 
> Hold on, I'll post updates image for F14 beta.

It is here:

http://rvykydal.fedorapeople.org/updates.conflict_back.img
 
You can use it by adding:

updates=http://rvykydal.fedorapeople.org/updates.conflict_back.img

to boot parameters.

See http://fedoraproject.org/wiki/Anaconda/Updates if you are interested in details.
Comment 16 Fred New 2010-10-01 07:13:19 EDT
Unfortunately, we don't have any broken dependencies in updates-testing today and my system started installing without having to go back to uncheck the bad repository.  I can try again Monday.

By the way, since GRUB starts my hard disk installation, it was easy to copy and paste that long updates= line to the boot parameters in grub.conf.
Comment 17 Fred New 2010-10-06 04:55:40 EDT
I'm still waiting for updates-testing to be broken.  Maybe this problem isn't as serious as I thought it was.  I was mostly concerned about ending up with a non-booting computer, but people who run hard-disk installations like I do probably know how to recover.

Perhaps rather than being able to go back to turn off repositories, the final installation process could use a --skip-broken parameter.
Comment 18 James Laska 2010-10-14 15:51:27 EDT
Created attachment 453544 [details]
Attached traceback automatically from anaconda.
Comment 19 Fred New 2010-10-15 07:27:04 EDT
I ran a couple installations today and it looks like the patch mentioned in comment 5 and comment 15 works.  During the first installation I learned where the last point was where I could start going "back".

During the second installation, I went back to the repositories page several times without any problems.  My system still got installed without leaving me with a non-bootable hard disk like I originally complained about.  This is an acceptable result.

The only problem I had after going back all those times was that "Customize now" was ignored.  That is, the system started installing without allowing me to customize which packages I wanted to install.  Customize now was still marked; I didn't try turning it off and turning it on.
Comment 20 Zack Cerza 2011-01-04 13:03:57 EST
Created attachment 471720 [details]
Attached traceback automatically from anaconda.
Comment 21 Radek Vykydal 2011-01-11 11:53:40 EST
My attempt to solve the issue in bigger scope instead of the hack haven't got attention. Perhaps its time (or time for repository UI rewrite) is yet to come.
Comment 22 Radek Vykydal 2011-01-11 11:55:00 EST
(In reply to comment #21)
> My attempt to solve the issue in bigger scope instead of the hack haven't got
> attention. Perhaps its time (or time for repository UI rewrite) is yet to come.

Oh, here is the patchset for the record:
http://www.redhat.com/archives/anaconda-devel-list/2010-September/msg00181.html
Comment 23 João Carlos Mendes Luís 2011-02-20 08:54:15 EST
Created attachment 479762 [details]
Attached traceback automatically from anaconda.
Comment 24 Daniel Mach 2011-03-01 08:22:30 EST
Created attachment 481610 [details]
Attached traceback automatically from anaconda.
Comment 25 rct+redhat 2011-03-31 18:59:21 EDT
Created attachment 489259 [details]
Attached traceback automatically from anaconda.
Comment 26 Radek Vykydal 2011-06-23 08:12:23 EDT
*** Bug 679466 has been marked as a duplicate of this bug. ***
Comment 27 Chris Lumens 2011-08-25 09:21:23 EDT
*** Bug 733213 has been marked as a duplicate of this bug. ***
Comment 28 Radek Vykydal 2011-09-23 06:26:17 EDT
*** Bug 740666 has been marked as a duplicate of this bug. ***
Comment 29 Chris Lumens 2012-08-03 15:25:48 EDT
The code this bug resulted from is no longer present as of anaconda-18.3.  Please test with F18 and if you see similar problems, open a new bug.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.