Bug 622451 - Author info is wrong in man page.
Author info is wrong in man page.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: man-pages-overrides (Show other bugs)
6.1
All Linux
low Severity medium
: rc
: ---
Assigned To: Ivana Varekova
BaseOS QE - Apps
: ManPageChange
Depends On: 622059
Blocks: 659705
  Show dependency treegraph
 
Reported: 2010-08-09 08:24 EDT by Jan Kaluža
Modified: 2011-05-19 10:28 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 622059
: 659705 (view as bug list)
Environment:
Last Closed: 2011-05-19 10:28:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Kaluža 2010-08-09 08:24:35 EDT
+++ This bug was initially created as a clone of Bug #622059 +++

Description of problem:
Author info is wrong in man page.

Version-Release number of selected component (if applicable):
The AUTHORS section of logrotate(8) shows two Red Hat employees who are not with the company any more, Erik Troan <ewt@redhat.com> and Preston Brown <pbrown@redhat.com>.  A customer mentioned it to me and it seems we might need to do something about it, although I am not sure what, exactly.

I know Erik is reachable at ewtroan@livejournal.com and I think Preston is at Bronto these days (http://www.bronto.com/company/leadership/preston-brown).

Do we amend or remove, or do those man pages need to be changed upstream?  I dug around for only a few minutes and I can't find anything which seems to be the official home page for logrotate.

--- Additional comment from tsmetana@redhat.com on 2010-08-09 07:57:14 EDT ---

Hello,
  logrotate lives on Fedora Hosted: https://fedorahosted.org/logrotate/

I believe the correct solution would be to remove the mail addresses (which are useless anyway) of the original logrotate authors, keep just their names in the documentation and add the contacts to the recent upstream. I don't think those gentlemen wish to be contacted with questions about logrotate.

Regards.

--- Additional comment from jkaluza@redhat.com on 2010-08-09 08:03:56 EDT ---

(In reply to comment #0)
> Description of problem:
> Author info is wrong in man page.
> 
> Version-Release number of selected component (if applicable):
> The AUTHORS section of logrotate(8) shows two Red Hat employees who are not
> with the company any more, Erik Troan <ewt@redhat.com> and Preston Brown
> <pbrown@redhat.com>.  A customer mentioned it to me and it seems we might need
> to do something about it, although I am not sure what, exactly.
> 
> I know Erik is reachable at ewtroan@livejournal.com and I think Preston is at
> Bronto these days (http://www.bronto.com/company/leadership/preston-brown).

I think the proper solution is to remove old emails from the man page. In my opinion it's not right to put their "private" emails there without any permission.

> Do we amend or remove, or do those man pages need to be changed upstream?  I
> dug around for only a few minutes and I can't find anything which seems to be
> the official home page for logrotate.    

Current official upstream is located at <https://fedorahosted.org/logrotate>. I've added that link to the man page as well as <logrotate-owner@fedoraproject.org> email, which is always forwarded to the actual logrotate package owner.

--- Additional comment from jkaluza@redhat.com on 2010-08-09 08:07:02 EDT ---

Created an attachment (id=437578)
proposed patch
Comment 2 RHEL Product and Program Management 2010-08-09 08:47:51 EDT
This issue has been proposed when we are only considering blocker
issues in the current Red Hat Enterprise Linux release.

** If you would still like this issue considered for the current
release, ask your support representative to file as a blocker on
your behalf. Otherwise ask that it be considered for the next
Red Hat Enterprise Linux release. **
Comment 7 errata-xmlrpc 2011-05-19 10:28:46 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0780.html

Note You need to log in before you can comment on or make changes to this bug.