Bug 62246 - if an option is specified at the command line, and no host is specified for the query, whois will segfault and coredump
Summary: if an option is specified at the command line, and no host is specified for t...
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: whois (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC3BugWeekTracker
TreeView+ depends on / blocked
 
Reported: 2002-03-28 20:23 UTC by Ryan Yagatich
Modified: 2007-04-18 16:41 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 21:23:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ryan Yagatich 2002-03-28 20:23:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; Q312461)

Description of problem:
if an option is specified at the command line, and no host is specified for the 
query, whois will segfault and coredump. for example, if you type whois -h at 
the command line, with no host specified. you will get a segmentation fault.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. log into your redhat linux system
2. type: whois pantek.com
   (that will test to make sure whois is really doing querys...
3. type: whois -h
   (this will segfault whois)
	

Actual Results:  as expected, whois segfaults.

Expected Results:  it should have prompted with the "Usage"

Additional info:

[ryany@procyon bugzilla]$ whois
syntax: whois [-v] [-r] [-h server] [-p port] [--] query[@server[:port]]
default server is whois.crsnic.net
[ryany@procyon bugzilla]$ whois -h
Segmentation fault (core dumped)
[ryany@procyon bugzilla]$ whois --
Segmentation fault (core dumped)
[ryany@procyon bugzilla]$ whois -r
Segmentation fault (core dumped)
[ryany@procyon bugzilla]$ whois -v
Segmentation fault (core dumped)
[ryany@procyon bugzilla]$ whois pantek.com
... works fine for this ...

full results: http://www.pantek.com/~ryany/bugzilla

Comment 1 Ryan Yagatich 2002-05-02 01:51:54 UTC
This bug is not present in RedHat Linux 7.2

Comment 2 Sean Porterfield 2003-09-18 20:37:35 UTC
Looks like a duplicate of bug 30468.  Answer is to upgrade.

Comment 3 Marcin Garski 2004-09-27 21:23:36 UTC
whois is no longer included in Fedora Core.
It has been replaced by jwhois.
Upgrade to lastest release of Fedora Core and try jwois, if this bug
still occur, please reopen.

Note that I can't reproduce this bug on jwhois-3.2.2-3, so updating to
FC2 should resolve this bug.


Note You need to log in before you can comment on or make changes to this bug.